summaryrefslogtreecommitdiff
path: root/media-libs/vkroots
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 03:19:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 03:19:26 +0000
commitcaf79cb4f7c4d5f7cce488d8f50dfb98ddbd09ab (patch)
tree4fb39a9252efabe8f160ef46b7b3be2f52af25aa /media-libs/vkroots
parent3606ceecb950b302a6ba2a9882aeeff2a851e5dc (diff)
gentoo auto-resync : 10:12:2022 - 03:19:26
Diffstat (limited to 'media-libs/vkroots')
-rw-r--r--media-libs/vkroots/Manifest3
-rw-r--r--media-libs/vkroots/metadata.xml11
-rw-r--r--media-libs/vkroots/vkroots-0_p20221205.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/vkroots/Manifest b/media-libs/vkroots/Manifest
new file mode 100644
index 000000000000..8d951f6f7953
--- /dev/null
+++ b/media-libs/vkroots/Manifest
@@ -0,0 +1,3 @@
+DIST vkroots-0_p20221205.tar.gz 272641 BLAKE2B ee61988cf1a110d39e96f027160cbefb2e3815e9ef60e367b54be94348d2cd75037a7eb115620460ed1c1c36256e919e568551258217e1b12aea760d2c90dd61 SHA512 a1a21f53d38385a5f300d9dd5650145074baad66b081beaab59179995afcc5a8df8adf19d52c5da15a7ee10fa530aa9d24c3ff1e04df3f7e1d3af526abc1e55e
+EBUILD vkroots-0_p20221205.ebuild 758 BLAKE2B 67171cd731e7308e303db7ce316eccb709ca938e65cfaaaf865eacd582a4c70b9cc9607ec64b6dbd395b3f3b18f8bd09e4e405fe359653513e9d05a35bf9cc80 SHA512 e9ade5e3531380e1c01d51fdeab9706a12d089287c08dc8ecd951bcde2ff44299b52d51cd3f9cb24836ea69c1ee0826c4feec59f72f875611d03da39f96abb34
+MISC metadata.xml 334 BLAKE2B b5c4bac2b5e4d1727a382788694763badfb49459ea3874d4d058cc0c141aab14c4111b888e877f095190aabdfac350826b359e0f8a2aed23b44cec9b957f75cf SHA512 c37b1589b9a73654d19a8cbf8fe77035fb8a513f1924fde74613e9cb6ad502ff282e6e915ea366cc847190616285a5753eb2e2e5b8f069bbd5ee2c60beb7913c
diff --git a/media-libs/vkroots/metadata.xml b/media-libs/vkroots/metadata.xml
new file mode 100644
index 000000000000..853b3e8c417f
--- /dev/null
+++ b/media-libs/vkroots/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Joshua-Ashton/vkroots</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/vkroots/vkroots-0_p20221205.ebuild b/media-libs/vkroots/vkroots-0_p20221205.ebuild
new file mode 100644
index 000000000000..639396330c56
--- /dev/null
+++ b/media-libs/vkroots/vkroots-0_p20221205.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit python-any-r1
+
+COMMIT="e6b89494142eec0ac6061f82a947d2f1246d3d7a"
+DESCRIPTION="Simple framework for writing Vulkan layers"
+HOMEPAGE="https://github.com/Joshua-Ashton/vkroots"
+SRC_URI="https://github.com/Joshua-Ashton/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+LICENSE="Apache-2.0 MIT LGPL-2.1"
+SLOT="0"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/vulkan-headers
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() {
+ "${PYTHON}" ./gen/make_vkroots --xml "${BROOT}"/usr/share/vulkan/registry/vk.xml || die
+}
+
+src_install() {
+ default
+ insinto /usr/include/${PN}
+ doins ${PN}.h meson.build
+}