summaryrefslogtreecommitdiff
path: root/media-libs/vigra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /media-libs/vigra
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'media-libs/vigra')
-rw-r--r--media-libs/vigra/Manifest2
-rw-r--r--media-libs/vigra/vigra-9999.ebuild20
2 files changed, 11 insertions, 11 deletions
diff --git a/media-libs/vigra/Manifest b/media-libs/vigra/Manifest
index ed2dda34c3af..6357fdfae7a8 100644
--- a/media-libs/vigra/Manifest
+++ b/media-libs/vigra/Manifest
@@ -7,5 +7,5 @@ AUX vigra-1.11.1-python3.7.patch 1254 BLAKE2B 24e23db29992efa86154edb402e250c782
AUX vigra-1.11.1-sphinx.ext.pngmath.patch 1411 BLAKE2B 6ffdd2f40ac982d693a6e71a89754d453202ba70e6ae65b3b45d64add3d2cc7a9710773e94b0604cb67dadb53ea27912ccce7fe844e6264f7c989bb96149cbcc SHA512 4e0ade84985ecc9c7c45afd949671b9cbc041db486c29732b17c1b62eadfdf6e299396a18686c03c3ed4e2b3ac6d830a8e224c56e3b8d20361c2f5e5fcc14650
DIST vigra-1.11.1-src.tar.gz 55119047 BLAKE2B c67dc61515075843faacb4ee054f3e28b4edd033dc6cb89d3c591827309eafa697b839ca85ff7c68d6aff9d7e08b1d3db73d50e6c3b065a5210b64a90e242444 SHA512 9c1638d626d658fa4b13069e5850b628d91db02bb18b8a9f0a4642fee501ede8a6f4f267d79ca5cd5baf3991e704163345cd18ab7919ff2a93db6bd496096de3
EBUILD vigra-1.11.1-r3.ebuild 3535 BLAKE2B 0af86fbaeb60e40a3eaea93de6a22ac0310023aa16a10669ce87a7b21d6460f4b9cb1e49fedf88e5386a86777505134fdc9e787724f0fc5b2babb076d566feca SHA512 2c7dfdc5d3dfa1b4f2bb084f1ce91868b30cd4067ad41471b5de973ced7c2cb4d1119d0d4317b34a00c097598b194ecba46029036f1e3bd7e01dd97602cf8391
-EBUILD vigra-9999.ebuild 3905 BLAKE2B 36f5a5e95225129ed05d2f7f4fe057fcdffaef55f17983fb9998585ef9fa5d2b12c50852bdb6fd4974fcec1de60b8a11887f8fc36ef3e111809c9d679e8043e2 SHA512 77a9075fa4ad56a4f78bd0a44d352eac22c0ff02f167a08956cd65c1798b9c2e0eee82c50213d4e4bc3a651bf6ac398a6ae5db7ac90f4f6f8d988451ddac791b
+EBUILD vigra-9999.ebuild 3844 BLAKE2B 8a0a93277944dbf5c820162cd7881907f5ae043882639826cee6b56fb6c1d723d327ef021cd9ae59d9e2595913ac909571e0d9c0da55fe1db880f710668597bd SHA512 955ddba13948748776e1c715174a03dfb3973627f38d90c594b90bfb8ce58795c268b964a7b235a1ba22b4e1ce570527ce2e74672383acca88028941997ee995
MISC metadata.xml 413 BLAKE2B 985f005fa338d566dddb20126e0a83cb8e9ec5aa4ac9ed2d5ec6a42743eeb92f521375b74f8caaa94500c42450d68d0a4bf5c036c9a2909e13c922f50896824a SHA512 e5c2a32f7495cfceffc8da8464131b918134b7255fbcde9a10175a24698f5a6aff17630436935c6cda7d8a3cd8b182c299845a24528f3a9c40dff1022dce4f71
diff --git a/media-libs/vigra/vigra-9999.ebuild b/media-libs/vigra/vigra-9999.ebuild
index c445f2e401cf..9ffac6b73b01 100644
--- a/media-libs/vigra/vigra-9999.ebuild
+++ b/media-libs/vigra/vigra-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="threads(+),xml"
-inherit cmake-utils python-r1
+inherit cmake python-r1
DESCRIPTION="C++ computer vision library emphasizing customizable algorithms and structures"
HOMEPAGE="https://ukoethe.github.io/vigra/"
@@ -83,7 +83,7 @@ src_prepare() {
fi
}
- cmake-utils_src_prepare
+ cmake_src_prepare
if [[ ${PV} != *9999 ]]; then
rm -r doc || die "failed to remove shipped docs"
@@ -101,7 +101,7 @@ src_prepare() {
if ! use test; then
cmake_comment_add_subdirectory test
- sed -e "/ADD_SUBDIRECTORY.*test/s/^/#DONT /" -i vigranumpy/CMakeLists.txt || die
+ cmake_run_in vigranumpy cmake_comment_add_subdirectory test
fi
}
@@ -116,7 +116,7 @@ src_configure() {
-DWITH_VALGRIND=$(usex valgrind)
-DWITH_VIGRANUMPY=$(usex python)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
if use python; then
@@ -131,7 +131,7 @@ src_configure() {
src_compile() {
local VIGRA_BUILD_DIR
vigra_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
VIGRA_BUILD_DIR="${BUILD_DIR}"
}
if use python; then
@@ -150,17 +150,17 @@ src_compile() {
src_install() {
if use python; then
- python_foreach_impl cmake-utils_src_install
+ python_foreach_impl cmake_src_install
python_optimize
else
- cmake-utils_src_install
+ cmake_src_install
fi
}
src_test() {
# perhaps disable tests (see #390447)
vigra_test() {
- PYTHONPATH="${BUILD_DIR}/vigranumpy/vigra" cmake-utils_src_test
+ PYTHONPATH="${BUILD_DIR}/vigranumpy/vigra" cmake_src_test
}
if use python; then
python_foreach_impl vigra_test