summaryrefslogtreecommitdiff
path: root/media-libs/vigra/vigra-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/vigra/vigra-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/vigra/vigra-9999.ebuild')
-rw-r--r--media-libs/vigra/vigra-9999.ebuild37
1 files changed, 9 insertions, 28 deletions
diff --git a/media-libs/vigra/vigra-9999.ebuild b/media-libs/vigra/vigra-9999.ebuild
index 171eedd560f8..f842c53d7500 100644
--- a/media-libs/vigra/vigra-9999.ebuild
+++ b/media-libs/vigra/vigra-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="threads(+),xml"
inherit cmake flag-o-matic python-r1
@@ -23,15 +23,10 @@ SLOT="0"
IUSE="doc +fftw +hdf5 +jpeg mpi openexr +png +python test +tiff valgrind +zlib"
REQUIRED_USE="
- doc? ( hdf5 fftw ${PYTHON_REQUIRED_USE} )
python? ( hdf5 ${PYTHON_REQUIRED_USE} )
test? ( hdf5 python fftw )"
BDEPEND="
- doc? (
- app-doc/doxygen
- >=dev-python/sphinx-1.1.3-r5
- )
test? (
>=dev-python/nose-1.1.2-r1[${PYTHON_USEDEP}]
valgrind? ( dev-util/valgrind )
@@ -39,12 +34,12 @@ BDEPEND="
"
# runtime dependency on python is required by the vigra-config script
DEPEND="
- fftw? ( sci-libs/fftw:3.0 )
+ fftw? ( sci-libs/fftw:3.0= )
hdf5? ( >=sci-libs/hdf5-1.8.0:=[mpi=] )
jpeg? ( virtual/jpeg:0 )
openexr? (
- media-libs/ilmbase:=
- media-libs/openexr:=
+ >=dev-libs/imath-3.1.4-r2:=
+ >=media-libs/openexr-3:0=
)
png? ( media-libs/libpng:0= )
python? (
@@ -70,9 +65,7 @@ PATCHES=(
)
pkg_setup() {
- if use python || use doc; then
- python_setup
- fi
+ use python && python_setup
}
src_prepare() {
@@ -85,10 +78,6 @@ src_prepare() {
cmake_src_prepare
- if [[ ${PV} != *9999 ]]; then
- rm -r doc || die "failed to remove shipped docs"
- fi
-
vigra_disable fftw fftw3
vigra_disable fftw fftw3f
vigra_disable jpeg
@@ -99,6 +88,8 @@ src_prepare() {
# Don't use python_fix_shebang because we can't put this behind USE="python"
sed -i -e '/env/s:python:python3:' config/vigra-config.in || die
+ use doc || cmake_comment_add_subdirectory docsrc
+
if ! use test; then
cmake_comment_add_subdirectory test
cmake_run_in vigranumpy cmake_comment_add_subdirectory test
@@ -113,8 +104,7 @@ src_configure() {
vigra_configure() {
local mycmakeargs=(
-DAUTOEXEC_TESTS=OFF
- -DDOCDIR="${BUILD_DIR}/doc"
- -DDOCINSTALL="share/doc/${PF}"
+ -DDOCINSTALL="share/doc/${PF}/html"
-DWITH_HDF5=$(usex hdf5)
-DWITH_OPENEXR=$(usex openexr)
-DWITH_VALGRIND=$(usex valgrind)
@@ -126,8 +116,6 @@ src_configure() {
if use python; then
python_foreach_impl vigra_configure
else
- # required for docdir
- _cmake_check_build_dir init
vigra_configure
fi
}
@@ -143,13 +131,6 @@ src_compile() {
else
vigra_compile
fi
-
- if use doc; then
- einfo "Generating Documentation"
- doxygen -u ${VIGRA_BUILD_DIR}/docsrc/Doxyfile 2>/dev/null || die
- # use build dir from last compile command
- VARTEXFONTS="${T}/fonts" BUILD_DIR="${VIGRA_BUILD_DIR}" cmake-utils_src_make doc
- fi
}
src_install() {