summaryrefslogtreecommitdiff
path: root/media-libs/urt/urt-3.1b-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/urt/urt-3.1b-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/urt/urt-3.1b-r1.ebuild')
-rw-r--r--media-libs/urt/urt-3.1b-r1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/media-libs/urt/urt-3.1b-r1.ebuild b/media-libs/urt/urt-3.1b-r1.ebuild
new file mode 100644
index 000000000000..d25337bcbd08
--- /dev/null
+++ b/media-libs/urt/urt-3.1b-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="the Utah Raster Toolkit is a library for dealing with raster images"
+HOMEPAGE="http://www.cs.utah.edu/gdc/projects/urt/"
+SRC_URI="ftp://ftp.iastate.edu/pub/utah-raster/${P}.tar.Z"
+
+LICENSE="URT gif? ( free-noncomm )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="gif postscript tiff X"
+
+RDEPEND="X? ( x11-libs/libXext )
+ gif? ( media-libs/giflib )
+ tiff? ( media-libs/tiff )
+ postscript? ( app-text/ghostscript-gpl )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xextproto )"
+
+S=${WORKDIR}
+
+urt_config() {
+ use $1 && echo "#define $2" || echo "##define $2"
+}
+
+src_prepare() {
+ rm -f bin/README
+
+ epatch "${FILESDIR}"/${P}-rle-fixes.patch
+ epatch "${FILESDIR}"/${P}-compile-updates.patch
+ epatch "${FILESDIR}"/${P}-tempfile.patch
+ epatch "${FILESDIR}"/${P}-build-fixes.patch
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${P}-solaris.patch
+
+ # punt bogus manpage #109511
+ rm -f man/man1/template.1
+
+ # stupid OS X declares a stack_t type already #107428
+ sed -i -e 's:stack_t:_urt_stack:g' tools/clock/rleClock.c || die
+
+ sed -i -e '/^CFLAGS/s: -O : :' makefile.hdr
+ cp "${FILESDIR}"/gentoo-config config/gentoo
+ cat >> config/gentoo <<-EOF
+ $(urt_config X X11)
+ $(urt_config postscript POSTSCRIPT)
+ $(urt_config tiff TIFF)
+ ExtraCFLAGS = ${CFLAGS}
+ MFLAGS = ${MAKEOPTS}
+ # prevent circular depend #111455
+ $(has_version media-libs/giflib && urt_config gif GIF)
+ EOF
+}
+
+src_configure() {
+ ./Configure config/gentoo || die "config"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ mkdir -p man-dest/man{1,3,5}
+ # this just installs it into some local dirs
+ make install || die
+ dobin bin/*
+ dolib.a lib/librle.a
+ insinto /usr/include
+ doins include/rle*.h
+ doman man-dest/man?/*.[135]
+ dodoc *-changes CHANGES* README blurb
+}