summaryrefslogtreecommitdiff
path: root/media-libs/tremor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /media-libs/tremor
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'media-libs/tremor')
-rw-r--r--media-libs/tremor/Manifest4
-rw-r--r--media-libs/tremor/files/tremor-0_pre20130223-out-of-bounds-write.patch88
-rw-r--r--media-libs/tremor/tremor-0_pre20130223-r1.ebuild6
-rw-r--r--media-libs/tremor/tremor-0_pre20130223-r2.ebuild50
4 files changed, 144 insertions, 4 deletions
diff --git a/media-libs/tremor/Manifest b/media-libs/tremor/Manifest
index 1d3f7298804f..30f77d361010 100644
--- a/media-libs/tremor/Manifest
+++ b/media-libs/tremor/Manifest
@@ -1,3 +1,5 @@
+AUX tremor-0_pre20130223-out-of-bounds-write.patch 2721 BLAKE2B a9d254873d08d261c72197fbe44875aefe9f48f97464ccc5653e88e50fe3546d2426d80e62a67c0a595695737fb2b7c95df1a850b612688c02b2574a3b986fcc SHA512 022a8e813f42e3e9a0983cd2e948898dc36689433cc76d292b8b24bb3c7318bbe71a2618022a16025ee25dea0dab063266212499e5d84669603414b6c769f74e
DIST tremor-0_pre20130223.tar.xz 110096 BLAKE2B aec25548c971d2021a3b5f81469d3bf74434f2bcf215601e79a2663fd044085519fde449736f0513c949de5a79e297cac65a7abd50f5fcd8b940f655b966b164 SHA512 3fc109dfc6f9f33da9d2da7d5c1708d6fe4b22179048c4acd5b4b037eafbdda392d5ba74ffec5d8a225d56ebd860f67d28e4460f0b54cb170152a0b9fd89c514
-EBUILD tremor-0_pre20130223-r1.ebuild 1000 BLAKE2B 90e622cd700b341dc542e51f83ffefc425c5861ad18c7d6bb01b377a47c9b0302e3d06cf5ddca331ab5ae4a825d54cee7bc9024df98642d943b57d4688465a16 SHA512 58eeaeb1717ef61470ae07d240880a4b69496ad12ec916f9906d27d0402ae603be09c9d467f7b92c69275db2b58f06a788f42fd91a9fc974e07ca08d1ce02b32
+EBUILD tremor-0_pre20130223-r1.ebuild 1021 BLAKE2B 3108f32c7f520e7d5d6f51a47f536e26063d7d6e659dcada38617042a49f8a655589235acae7893607f9c9c5e7045a2f2398a82d60ab5b9276995948234d7fa8 SHA512 d249b0f034aa3ac15f9f496eac373f2918d02c43ca02c6c3803f617259bd15a2898c27277a6a45b7bca5ce83b94ff1129561f19f9c7a7cdd7c3a8ca64d5aff0d
+EBUILD tremor-0_pre20130223-r2.ebuild 1113 BLAKE2B 3f1457d36bc7016ed5163b806ffc75d7b0f17a936dc35742eac96ea44482b1d0d0b64316afec2634b12396a2a8e8b437878a240e672a54b515dccc5c37ee5494 SHA512 9f58d0cbe18db7b96243baea709e53cd71652f65b8f8b7cfb139bf3ecdfa68d970e5260e19bdecfe7586b611b0d8b4acaee6f9236ed8aaa077548acc9a52f3aa
MISC metadata.xml 341 BLAKE2B f36ce19410676996a1ea63ed668fc17bb9d6bd795f4cc83d3fe4a01c4fc71bb43ec4982474f549a87b7d38ddd08a8d24c049a9243c1adeee5da8dc59f1fb265b SHA512 d386b0e5f226a6459d41ef8ac18fb129ecff461db36e5b26faeabc52b8814535d669ba1cf816e921eabc8786c6d073ed1ce8c9dde57c91bc186f282706b0c7c0
diff --git a/media-libs/tremor/files/tremor-0_pre20130223-out-of-bounds-write.patch b/media-libs/tremor/files/tremor-0_pre20130223-out-of-bounds-write.patch
new file mode 100644
index 000000000000..403a89e670a9
--- /dev/null
+++ b/media-libs/tremor/files/tremor-0_pre20130223-out-of-bounds-write.patch
@@ -0,0 +1,88 @@
+From 562307a4a7082e24553f3d2c55dab397a17c4b4f Mon Sep 17 00:00:00 2001
+From: Thomas Daede <daede003@umn.edu>
+Date: Thu, 15 Mar 2018 21:47:09 -0700
+Subject: [PATCH] Prevent out-of-bounds write in codebook decoding.
+
+Codebooks that are not an exact divisor of the partition size are now
+truncated to fit within the partition.
+---
+ codebook.c | 18 +++++++++---------
+ 1 file changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/codebook.c b/codebook.c
+index f8b7983..1e1ae8a 100644
+--- a/codebook.c
++++ b/codebook.c
+@@ -258,7 +258,7 @@ long vorbis_book_decodevs_add(codebook *book,ogg_int32_t *a,
+ t[i] = book->valuelist+entry[i]*book->dim;
+ }
+ for(i=0,o=0;i<book->dim;i++,o+=step)
+- for (j=0;j<step;j++)
++ for (j=0;o+j<n && j<step;j++)
+ a[o+j]+=t[j][i]>>shift;
+ }else{
+ for (i = 0; i < step; i++) {
+@@ -267,7 +267,7 @@ long vorbis_book_decodevs_add(codebook *book,ogg_int32_t *a,
+ t[i] = book->valuelist+entry[i]*book->dim;
+ }
+ for(i=0,o=0;i<book->dim;i++,o+=step)
+- for (j=0;j<step;j++)
++ for (j=0;o+j<n && j<step;j++)
+ a[o+j]+=t[j][i]<<-shift;
+ }
+ }
+@@ -287,7 +287,7 @@ long vorbis_book_decodev_add(codebook *book,ogg_int32_t *a,
+ entry = decode_packed_entry_number(book,b);
+ if(entry==-1)return(-1);
+ t = book->valuelist+entry*book->dim;
+- for (j=0;j<book->dim;)
++ for (j=0;i<n && j<book->dim;)
+ a[i++]+=t[j++]>>shift;
+ }
+ }else{
+@@ -295,7 +295,7 @@ long vorbis_book_decodev_add(codebook *book,ogg_int32_t *a,
+ entry = decode_packed_entry_number(book,b);
+ if(entry==-1)return(-1);
+ t = book->valuelist+entry*book->dim;
+- for (j=0;j<book->dim;)
++ for (j=0;i<n && j<book->dim;)
+ a[i++]+=t[j++]<<-shift;
+ }
+ }
+@@ -352,15 +352,15 @@ long vorbis_book_decodevv_add(codebook *book,ogg_int32_t **a,\
+ long i,j,entry;
+ int chptr=0;
+ int shift=point-book->binarypoint;
+-
++ int m=offset+n;
+ if(shift>=0){
+
+- for(i=offset;i<offset+n;){
++ for(i=offset;i<m;){
+ entry = decode_packed_entry_number(book,b);
+ if(entry==-1)return(-1);
+ {
+ const ogg_int32_t *t = book->valuelist+entry*book->dim;
+- for (j=0;j<book->dim;j++){
++ for (j=0;i<m && j<book->dim;j++){
+ a[chptr++][i]+=t[j]>>shift;
+ if(chptr==ch){
+ chptr=0;
+@@ -371,12 +371,12 @@ long vorbis_book_decodevv_add(codebook *book,ogg_int32_t **a,\
+ }
+ }else{
+
+- for(i=offset;i<offset+n;){
++ for(i=offset;i<m;){
+ entry = decode_packed_entry_number(book,b);
+ if(entry==-1)return(-1);
+ {
+ const ogg_int32_t *t = book->valuelist+entry*book->dim;
+- for (j=0;j<book->dim;j++){
++ for (j=0;i<m && j<book->dim;j++){
+ a[chptr++][i]+=t[j]<<-shift;
+ if(chptr==ch){
+ chptr=0;
+--
+2.11.0
+
diff --git a/media-libs/tremor/tremor-0_pre20130223-r1.ebuild b/media-libs/tremor/tremor-0_pre20130223-r1.ebuild
index 856548ea2fb5..f1af3bd8b063 100644
--- a/media-libs/tremor/tremor-0_pre20130223-r1.ebuild
+++ b/media-libs/tremor/tremor-0_pre20130223-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=5
# svn export http://svn.xiph.org/trunk/Tremor tremor-${PV}
-inherit autotools eutils ltprune multilib-minimal
+inherit autotools eutils multilib-minimal
DESCRIPTION="A fixed-point version of the Ogg Vorbis decoder (also known as libvorbisidec)"
HOMEPAGE="https://wiki.xiph.org/Tremor"
@@ -13,7 +13,7 @@ SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
IUSE="low-accuracy static-libs"
RDEPEND=">=media-libs/libogg-1.3.0:=[${MULTILIB_USEDEP}]"
@@ -40,5 +40,5 @@ multilib_src_configure() {
multilib_src_install_all() {
einstalldocs
dohtml -r doc/*
- prune_libtool_files
+ find "${D}" -name '*.la' -type f -delete || die
}
diff --git a/media-libs/tremor/tremor-0_pre20130223-r2.ebuild b/media-libs/tremor/tremor-0_pre20130223-r2.ebuild
new file mode 100644
index 000000000000..4aa37c129b8c
--- /dev/null
+++ b/media-libs/tremor/tremor-0_pre20130223-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# svn export http://svn.xiph.org/trunk/Tremor tremor-${PV}
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="A fixed-point version of the Ogg Vorbis decoder (also known as libvorbisidec)"
+HOMEPAGE="https://wiki.xiph.org/Tremor"
+SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="low-accuracy static-libs"
+
+RDEPEND=">=media-libs/libogg-1.3.0:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( "CHANGELOG" "README" )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-out-of-bounds-write.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+
+ sed -i \
+ -e '/CFLAGS/s:-O2::' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ configure.in || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable low-accuracy)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dohtml -r doc/*
+ find "${D}" -name '*.la' -type f -delete || die
+}