summaryrefslogtreecommitdiff
path: root/media-libs/theoraplay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
commitb426a5cef3f0ebe3389686a1c145a834d3a1e120 (patch)
treeeee77f741af6979f620416c573e5203eab81c9c3 /media-libs/theoraplay
parent97b176c73aa78bd33234884388e3978f520161c3 (diff)
gentoo auto-resync : 09:09:2022 - 10:40:04
Diffstat (limited to 'media-libs/theoraplay')
-rw-r--r--media-libs/theoraplay/Manifest2
-rw-r--r--media-libs/theoraplay/theoraplay-0_pre20180524-r1.ebuild (renamed from media-libs/theoraplay/theoraplay-0_pre20180524.ebuild)25
2 files changed, 13 insertions, 14 deletions
diff --git a/media-libs/theoraplay/Manifest b/media-libs/theoraplay/Manifest
index 893b246cee85..f6bf897e0ebd 100644
--- a/media-libs/theoraplay/Manifest
+++ b/media-libs/theoraplay/Manifest
@@ -1,3 +1,3 @@
DIST theoraplay-0_pre20180524.tar.bz2 14504 BLAKE2B 99580d65574887c283c8d7d1a588783bdb91ea5570adb4e194919ed930be558d62ddbd10e451746aa47bd6996cc3102f0b1eee50308cc278c2c6368a2a76d244 SHA512 509815535f73efe3b1c602b425d4a0aa78ce744809e8242fdfdecbb74a3a765d80b8e565dbdd00cd2daaf122365ba5a8651d302c907c714eae97f64607b7d0b8
-EBUILD theoraplay-0_pre20180524.ebuild 982 BLAKE2B 243f8081623bb289008de66e5051ec01c47895c96e572ba70b0f3fc9533f37c6cd08d3da55591245bcdd4792a66ba3322bc8b1a4db9c78065cdf061287e57377 SHA512 74a900d1431d426b8b4f32da1e783a69ee748f355193455fa915f6cbe5550d8edb7cffb57adf2ce6f7f23fd9d80c2a6148079ed779031952602e69c061d89ffa
+EBUILD theoraplay-0_pre20180524-r1.ebuild 961 BLAKE2B 82bc57bc3f75960fc0a7ac7619665ac476736505cf3c1687e9367d1dee3f859b49c67ef8876fe68c9b1b4843f873e979d0119c6af103cecb3bc7a4cea23c16b7 SHA512 79a8081e017576ce9b730cffc2495f6c4e57b99926c4ee80b8d8f2e760183a2d678b7724cbb3b9d77e4667cf23a3ca4f2af23919c6f8796dfaa7ac0071852abf
MISC metadata.xml 254 BLAKE2B 4e6c8e1f126f76233a38aba6f5388488656795cb1d7d4767ccb1349772f5e78d59fc5663d4f1933dbe4633c2fbb90cd1d42d4b4d4f5ededc53653e7df13c7187 SHA512 2b82da849e3b0dec378f3fb497014f5d1dbc7aceb8a1f9d1638e83fe69448b1c5151eb4b1187154d828e4a296609ce5125b40977b2581d95b5588e353ca75135
diff --git a/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild b/media-libs/theoraplay/theoraplay-0_pre20180524-r1.ebuild
index 487a8f89eb15..dd50e14aae72 100644
--- a/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild
+++ b/media-libs/theoraplay/theoraplay-0_pre20180524-r1.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit multilib multilib-minimal toolchain-funcs
+inherit edo multilib toolchain-funcs
COMMIT="7d8701876294"
DESCRIPTION="Simple library to make decoding of Ogg Theora videos easier"
HOMEPAGE="https://icculus.org/projects/theoraplay/"
SRC_URI="https://hg.icculus.org/icculus/${PN}/archive/${COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -18,19 +20,16 @@ RDEPEND="
media-libs/libtheora
media-libs/libvorbis
"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/libtool"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-multilib_src_compile() {
- libtool --tag=CC --mode=compile $(tc-getCC) -shared ${CFLAGS} -pthread -c "${S}"/${PN}.c || die
- libtool --tag=CC --mode=link $(tc-getCC) -shared ${LDFLAGS} -pthread -Wl,-z,defs ${PN}.lo \
- -logg -ltheoradec -lvorbis -o lib${PN}.la -rpath "${EPREFIX}/usr/$(get_libdir)" || die
+src_compile() {
+ edo libtool --tag=CC --mode=compile $(tc-getCC) -shared ${CFLAGS} -pthread -c "${S}"/${PN}.c
+ edo libtool --tag=CC --mode=link $(tc-getCC) -shared ${LDFLAGS} -pthread -Wl,-z,defs ${PN}.lo \
+ -logg -ltheoradec -lvorbis -o lib${PN}.la -rpath "${EPREFIX}/usr/$(get_libdir)"
}
-multilib_src_install() {
+src_install() {
dolib.so .libs/lib${PN}$(get_libname)*
-}
-
-multilib_src_install_all() {
doheader ${PN}.h
}