summaryrefslogtreecommitdiff
path: root/media-libs/tg_owt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/tg_owt/files
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/tg_owt/files')
-rw-r--r--media-libs/tg_owt/files/tg_owt-0_pre20220209-allow-disabling-X11.patch (renamed from media-libs/tg_owt/files/tg_owt-0_pre20210626-allow-disabling-X11.patch)51
1 files changed, 30 insertions, 21 deletions
diff --git a/media-libs/tg_owt/files/tg_owt-0_pre20210626-allow-disabling-X11.patch b/media-libs/tg_owt/files/tg_owt-0_pre20220209-allow-disabling-X11.patch
index c6abf9660468..3d4acfd0d941 100644
--- a/media-libs/tg_owt/files/tg_owt-0_pre20210626-allow-disabling-X11.patch
+++ b/media-libs/tg_owt/files/tg_owt-0_pre20220209-allow-disabling-X11.patch
@@ -9,23 +9,23 @@ This setup is untested, but supported by the GNI build system, see:
Toggling the WEBRTC_USE_X11 define also affects some files under
src/modules/audio_device, but that falls under "X11 support", regardless...
---- tg_owt-91d836dc84a16584c6ac52b36c04c0de504d9c34.orig/CMakeLists.txt
-+++ tg_owt-91d836dc84a16584c6ac52b36c04c0de504d9c34/CMakeLists.txt
+--- tg_owt-4cba1acdd718b700bb33945c0258283689d4eac7.orig/CMakeLists.txt
++++ tg_owt-4cba1acdd718b700bb33945c0258283689d4eac7/CMakeLists.txt
@@ -21,11 +21,13 @@
- option(BUILD_SHARED_LIBS "Builds shared libraries instead of static." ${TG_OWT_PACKAGED_BUILD})
+ option(BUILD_SHARED_LIBS "Builds shared libraries instead of static." OFF)
option(TG_OWT_USE_PROTOBUF "Use protobuf to generate additional headers. Useful for packaged build." ${BUILD_SHARED_LIBS})
+option(TG_OWT_USE_X11 "Use X11 for desktop capture on non-Apple Unix." ON)
option(TG_OWT_USE_PIPEWIRE "Use pipewire for desktop capture on non-Apple Unix." ON)
option(TG_OWT_DLOPEN_PIPEWIRE "dlopen pipewire 0.3 for desktop capture on non-Apple Unix." ${not_packaged_build})
- option(TG_OWT_BUILD_AUDIO_BACKENDS "Build webrtc audio backends." ON)
+ option(TG_OWT_BUILD_AUDIO_BACKENDS "Build webrtc audio backends." OFF)
if (NOT UNIX OR APPLE)
+ set(TG_OWT_USE_X11 OFF)
set(TG_OWT_USE_PIPEWIRE OFF)
endif()
-@@ -87,6 +89,10 @@
+@@ -97,6 +99,10 @@
add_library(tg_owt)
init_target(tg_owt)
@@ -34,22 +34,26 @@ src/modules/audio_device, but that falls under "X11 support", regardless...
+endif()
+
if (TG_OWT_USE_PIPEWIRE)
- link_glib(tg_owt)
if (TG_OWT_DLOPEN_PIPEWIRE)
-@@ -169,7 +175,6 @@
+ include(cmake/generate_stubs.cmake)
+@@ -188,10 +194,6 @@
+ include(cmake/libwebrtcbuild.cmake)
target_link_libraries(tg_owt PUBLIC tg_owt::libwebrtcbuild)
- if (UNIX AND NOT APPLE)
+-if (UNIX AND NOT APPLE)
- link_x11(tg_owt)
- endif()
-
+-endif()
+-
function(add_sublibrary postfix)
-@@ -2161,6 +2166,37 @@
+ add_library(tg_owt_${postfix} OBJECT)
+ init_feature_target(tg_owt_${postfix} ${postfix})
+@@ -2258,6 +2260,39 @@
)
endif()
+if (NOT TG_OWT_USE_X11)
+ remove_target_sources(tg_owt ${webrtc_loc}
++ # src/modules/desktop_capture/BUILD.gn (rtc_use_x11_extensions)
+ modules/desktop_capture/linux/mouse_cursor_monitor_x11.cc
+ modules/desktop_capture/linux/mouse_cursor_monitor_x11.h
+ modules/desktop_capture/linux/screen_capturer_x11.cc
@@ -71,6 +75,7 @@ src/modules/audio_device, but that falls under "X11 support", regardless...
+ modules/desktop_capture/linux/x_window_property.cc
+ modules/desktop_capture/linux/x_window_property.h
+
++ # screen_drawer_linux.cc depends on x11, rest are revdeps
+ modules/desktop_capture/screen_drawer.cc
+ modules/desktop_capture/screen_drawer.h
+ modules/desktop_capture/screen_drawer_linux.cc
@@ -82,9 +87,9 @@ src/modules/audio_device, but that falls under "X11 support", regardless...
if (NOT TG_OWT_USE_PIPEWIRE)
remove_target_sources(tg_owt ${webrtc_loc}
modules/desktop_capture/linux/base_capturer_pipewire.cc
---- tg_owt-91d836dc84a16584c6ac52b36c04c0de504d9c34.orig/cmake/libwebrtcbuild.cmake
-+++ tg_owt-91d836dc84a16584c6ac52b36c04c0de504d9c34/cmake/libwebrtcbuild.cmake
-@@ -27,6 +27,13 @@
+--- tg_owt-4cba1acdd718b700bb33945c0258283689d4eac7.orig/cmake/libwebrtcbuild.cmake
++++ tg_owt-4cba1acdd718b700bb33945c0258283689d4eac7/cmake/libwebrtcbuild.cmake
+@@ -28,6 +28,13 @@
BWE_TEST_LOGGING_COMPILE_TIME_ENABLE=0
)
@@ -98,11 +103,15 @@ src/modules/audio_device, but that falls under "X11 support", regardless...
if (TG_OWT_USE_PIPEWIRE)
target_compile_definitions(libwebrtcbuild
INTERFACE
-@@ -63,7 +70,6 @@
- INTERFACE
- WEBRTC_POSIX
- WEBRTC_LINUX
-- WEBRTC_USE_X11
- )
- endif()
+@@ -64,11 +71,6 @@
+ INTERFACE
+ WEBRTC_MAC
+ )
+- else()
+- target_compile_definitions(libwebrtcbuild
+- INTERFACE
+- WEBRTC_USE_X11
+- )
+ endif()
+ if (CMAKE_SYSTEM_NAME STREQUAL "Linux")