summaryrefslogtreecommitdiff
path: root/media-libs/svt-hevc/svt-hevc-1.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-06 21:11:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-06 21:11:24 +0000
commitd479c9c5c724c7b1300a98e44975f31f4f2e51dd (patch)
treec2f5550bfe03e1b3f19014e1576dcf50e6bd818c /media-libs/svt-hevc/svt-hevc-1.5.1.ebuild
parentee8ad1509f726e8fa598472117e5bbffd241ebab (diff)
gentoo auto-resync : 06:12:2022 - 21:11:24
Diffstat (limited to 'media-libs/svt-hevc/svt-hevc-1.5.1.ebuild')
-rw-r--r--media-libs/svt-hevc/svt-hevc-1.5.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/svt-hevc/svt-hevc-1.5.1.ebuild b/media-libs/svt-hevc/svt-hevc-1.5.1.ebuild
new file mode 100644
index 000000000000..97889df141fc
--- /dev/null
+++ b/media-libs/svt-hevc/svt-hevc-1.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic cmake
+
+DESCRIPTION="Scalable Video Technology for HEVC (SVT-HEVC Encoder)"
+HOMEPAGE="https://github.com/OpenVisualCloud/SVT-HEVC"
+
+if [ ${PV} = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OpenVisualCloud/SVT-HEVC.git"
+else
+ SRC_URI="https://github.com/OpenVisualCloud/SVT-HEVC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/SVT-HEVC-${PV}"
+fi
+
+LICENSE="AOM BSD-2"
+SLOT="0"
+
+BDEPEND="dev-lang/nasm"
+
+src_prepare() {
+ append-ldflags -Wl,-z,noexecstack
+ cmake_src_prepare
+}