summaryrefslogtreecommitdiff
path: root/media-libs/suil/suil-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-11 17:17:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-11 17:17:51 +0100
commitab58e299fd6dae92ea274fe7d0ad685d888a51b7 (patch)
tree09492d0673a9efe01357ec18f634665a620eee44 /media-libs/suil/suil-0.10.0.ebuild
parent5b5704b62a0f04d93fd58986b426a31352fe2fd5 (diff)
gentoo resync : 11.10.2017
Diffstat (limited to 'media-libs/suil/suil-0.10.0.ebuild')
-rw-r--r--media-libs/suil/suil-0.10.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/suil/suil-0.10.0.ebuild b/media-libs/suil/suil-0.10.0.ebuild
new file mode 100644
index 000000000000..c45a05c2483f
--- /dev/null
+++ b/media-libs/suil/suil-0.10.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit flag-o-matic python-any-r1 waf-utils
+
+DESCRIPTION="Lightweight C library for loading and wrapping LV2 plugin UIs"
+HOMEPAGE="http://drobilla.net/software/suil/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk qt5"
+
+RDEPEND=">=media-libs/lv2-1.12.0
+ gtk? ( x11-libs/gtk+:2 )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ default
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --no-qt4 \
+ $(usex gtk '' --no-gtk) \
+ $(usex qt5 '' --no-qt5) \
+ $(usex doc --docs '')
+}