summaryrefslogtreecommitdiff
path: root/media-libs/stk/stk-4.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /media-libs/stk/stk-4.6.2.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'media-libs/stk/stk-4.6.2.ebuild')
-rw-r--r--media-libs/stk/stk-4.6.2.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/stk/stk-4.6.2.ebuild b/media-libs/stk/stk-4.6.2.ebuild
new file mode 100644
index 000000000000..725704b60639
--- /dev/null
+++ b/media-libs/stk/stk-4.6.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Synthesis ToolKit in C++"
+HOMEPAGE="https://ccrma.stanford.edu/software/stk/"
+SRC_URI="https://ccrma.stanford.edu/software/stk/release/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug doc jack oss static-libs"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.5.1"
+)
+
+HTML_DOCS=(
+ doc/html/.
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ #breaks with --disable-foo...uses as --enable-foo
+ local myconf
+ if use debug; then
+ myconf="${myconf} --enable-debug"
+ fi
+ if use oss; then
+ myconf="${myconf} --with-oss"
+ fi
+ if use alsa; then
+ myconf="${myconf} --with-alsa"
+ fi
+ if use jack; then
+ myconf="${myconf} --with-jack"
+ fi
+
+ econf ${myconf} \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ RAWWAVE_PATH=/usr/share/stk/rawwaves/
+}
+
+src_install() {
+ dodoc README.md
+
+ # install the lib
+ dolib.so src/libstk*
+ use static-libs && dolib.a src/libstk*
+
+ # install headers
+ insinto /usr/include/stk
+ doins include/*.h
+
+ # install rawwaves
+ insinto /usr/share/stk/rawwaves
+ doins rawwaves/*.raw
+
+ # install docs
+ if use doc; then
+ einstalldocs
+ fi
+}