summaryrefslogtreecommitdiff
path: root/media-libs/stk/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
commit4a74938e510c0dad732ae4c48f815dd0f0cabb46 (patch)
treee8c52cd3619bba6cf0a5c367f6c9d2cff0ac9d80 /media-libs/stk/files
parentebc282ef4dfa408accac685565b8ee5f6faec119 (diff)
gentoo auto-resync : 13:02:2023 - 08:16:09
Diffstat (limited to 'media-libs/stk/files')
-rw-r--r--media-libs/stk/files/stk-4.5.1/060_all_linux_pulse.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/stk/files/stk-4.5.1/060_all_linux_pulse.patch b/media-libs/stk/files/stk-4.5.1/060_all_linux_pulse.patch
new file mode 100644
index 000000000000..2e4ae36abd7e
--- /dev/null
+++ b/media-libs/stk/files/stk-4.5.1/060_all_linux_pulse.patch
@@ -0,0 +1,36 @@
+https://github.com/thestk/stk/commit/b3439132339fc0fc649b8e305d7872e60b9520bf
+
+From b3439132339fc0fc649b8e305d7872e60b9520bf Mon Sep 17 00:00:00 2001
+From: Tristan Matthews <tmatth@videolan.org>
+Date: Wed, 9 Feb 2022 17:20:26 -0500
+Subject: [PATCH] configure: fix build for --with-pulse
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -162,6 +162,14 @@ api="$api -D__UNIX_JACK__"
+ AC_MSG_RESULT(using ALSA)
+ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
+
++ # Look for PulseAudio flag
++ AC_ARG_WITH(pulse, [ --with-pulse = choose PulseAudio support (linux only)])
++ AS_IF([test "x$with_pulse" == "xyes"], [
++ api="$api -D__LINUX_PULSE__"
++ AC_MSG_RESULT(using PulseAudio)
++ AC_CHECK_LIB(pulse, pa_proplist_gets, , AC_MSG_ERROR(PulseAudio support requires the libpulse library!))
++ AC_CHECK_LIB(pulse-simple, pa_simple_new, , AC_MSG_ERROR(PulseAudio support requires the libpulse-simple library!))])
++
+ # Look for OSS flag
+ AC_ARG_WITH(oss, [ --with-oss = choose OSS API support (unixes only)])
+ AS_IF([test "x$with_oss" == "xyes"], [
+--- a/include/Stk.h
++++ b/include/Stk.h
+@@ -622,7 +622,7 @@ const StkFloat ONE_OVER_128 = 0.0078125;
+ #if defined(__WINDOWS_DS__) || defined(__WINDOWS_ASIO__) || defined(__WINDOWS_MM__)
+ #define __OS_WINDOWS__
+ #define __STK_REALTIME__
+-#elif defined(__LINUX_OSS__) || defined(__LINUX_ALSA__) || defined(__UNIX_JACK__)
++#elif defined(__LINUX_OSS__) || defined(__LINUX_ALSA__) || defined(__UNIX_JACK__) || defined(__LINUX_PULSE__)
+ #define __OS_LINUX__
+ #define __STK_REALTIME__
+ #elif defined(__IRIX_AL__)
+