summaryrefslogtreecommitdiff
path: root/media-libs/spandsp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /media-libs/spandsp
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'media-libs/spandsp')
-rw-r--r--media-libs/spandsp/Manifest1
-rw-r--r--media-libs/spandsp/spandsp-0.0.6-r1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/spandsp/Manifest b/media-libs/spandsp/Manifest
index 8cd289bf0de3..15729f2cc0f7 100644
--- a/media-libs/spandsp/Manifest
+++ b/media-libs/spandsp/Manifest
@@ -1,3 +1,4 @@
DIST spandsp-0.0.6.tar.gz 3309837 BLAKE2B 6ee95501473d5758c9ff96580bb51222f49a230dc6a5f52f5a852781cbb70079bb07f9d7224f5c7ea91c0dd617fa543a37518f68875c76a44b3be1415aece696 SHA512 16bb215ca89a39282e832403f69bc4c98ad3fe35ab3a6eb4731ee5029a6acd9b2df243c3701de845441cbdc16c88b3cd398ef15dc3502e45d5aeca8a161917d4
+EBUILD spandsp-0.0.6-r1.ebuild 1828 BLAKE2B 6448de7450b4927de3363b03a1282c285249bae2bd41932306d0bdf626a0071f47d6aa8a8de4e9be7b1fbe9e0a7cba5342039a27ca13a376e95ab6e7848ef239 SHA512 e0c9113f4b68d9990cef75a1413efb139422231b61cfdf93bf72a688e5c02ad2d570507ba9527fb98eceb9bb18717788ac2450cc913fb87679be61dfbc33363c
EBUILD spandsp-0.0.6.ebuild 1990 BLAKE2B 7665e0a1e4003e7f6c70331fdee881615df879f1f32272dbc8ff81ec53a4931a65cd458febf6e03ca700c4392f820858a7ca0b8f73f9f059e620266e3417a93e SHA512 9502da0b5fd038cdb6ed8e4f368ae1e6fc45d78ebe106f324653ed70b3be613da6f86a7b003050fcf920dcb52be4b6f63cf7a37662f12071fb0cdcf574a9af61
MISC metadata.xml 244 BLAKE2B 55f7bb21fa829b545045078abd465615b8e8d3ba8ce19e1acf7466d14d45d695d771d9d78983749f8e0290166f3eab703ea332169a4fda45427ad4baa6ff8512 SHA512 2dde78e90a526f069d855081163e58cbcd9cd9e0429eb1615c9ef8bc5af93bcea4d145333feedd8adcf8421e3417c7ebf0b03b98227cad03431f20cb014f080a
diff --git a/media-libs/spandsp/spandsp-0.0.6-r1.ebuild b/media-libs/spandsp/spandsp-0.0.6-r1.ebuild
new file mode 100644
index 000000000000..bbbf322e189f
--- /dev/null
+++ b/media-libs/spandsp/spandsp-0.0.6-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="SpanDSP is a library of DSP functions for telephony"
+HOMEPAGE="https://www.soft-switch.org/"
+SRC_URI="https://www.soft-switch.org/downloads/spandsp/${P/_}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc fixed-point cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3"
+
+RDEPEND="media-libs/tiff
+ virtual/jpeg"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? (
+ app-doc/doxygen
+ dev-libs/libxslt
+)"
+
+# Enabled implicitly by the build system. Really useless.
+REQUIRED_USE="
+ cpu_flags_x86_sse3? ( cpu_flags_x86_sse2 )
+ cpu_flags_x86_sse2? ( cpu_flags_x86_sse )
+ cpu_flags_x86_sse? ( cpu_flags_x86_mmx )"
+
+S=${WORKDIR}/${PN}-$(ver_cut 1-3)
+
+# TODO:
+# there are two tests options: tests and test-data
+# they need audiofile, fftw, libxml and probably more
+
+src_configure() {
+ # Note: flags over sse3 aren't really used -- they're only
+ # boilerplate. They also make some silly assumptions, e.g. that
+ # every CPU with SSE4* has SSSE3.
+ # Reference: https://bugs.funtoo.org/browse/FL-2069.
+ # If you want to re-add them, first check if the code started
+ # using them. If it did, figure out if the flags can be unbundled
+ # from one another. Otherwise, you'd have to do REQUIRED_USE.
+
+ econf \
+ $(use_enable doc) \
+ $(use_enable fixed-point) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_x86_sse3 sse3)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog DueDiligence NEWS README
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use doc; then
+ docinto html
+ dodoc -r doc/{api/html/*,t38_manual}
+ fi
+}