summaryrefslogtreecommitdiff
path: root/media-libs/simage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-22 04:04:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-22 04:04:46 +0100
commita15e8dc7444560123d7d4be1bccb19afd5b611d0 (patch)
tree6e26ee0323c09494a66d0f78c4b81e305bb0d096 /media-libs/simage
parent3dc4de6331223493015f198dc61854af604da86c (diff)
gentoo auto-resync : 22:10:2024 - 04:04:46
Diffstat (limited to 'media-libs/simage')
-rw-r--r--media-libs/simage/Manifest3
-rw-r--r--media-libs/simage/simage-1.8.3-r1.ebuild86
-rw-r--r--media-libs/simage/simage-9999.ebuild5
3 files changed, 90 insertions, 4 deletions
diff --git a/media-libs/simage/Manifest b/media-libs/simage/Manifest
index 8773dff6d410..3d95108384a1 100644
--- a/media-libs/simage/Manifest
+++ b/media-libs/simage/Manifest
@@ -1,5 +1,6 @@
AUX simage-1.8.1-0001-Gentoo-specific-remove-RELEASE-flag-from-pkg-config.patch 1175 BLAKE2B 6533dde5a029fef8bf3804855f11e703beb3e02c36f193343c3337590659e5562539fbe853914ad7287ca6cd840b432d0c71d2847da7c6884b714b5512af49c0 SHA512 1dc17b023ba8a9e07a9ae971d99d9200ce14374b106e648b4a6b62e06e0ebb34e01a635c9cacd6579b3606cf62448953e459c5b1ca45a21ede9e5c0c19b8812f
DIST simage-1.8.3.tar.gz 829994 BLAKE2B 794ee3a1c71727af7e92839542470a4732584715b01cbfd5be7b34d8ea8295ca65f5634e10027e0e7e4eb36a024d31704ad31d9aa0a6ad6b66c08612879a1603 SHA512 193137bd00a322fe6c170d3ff318ac81e4cc685bdfa40a0415c5bb95802b6290174fea630eb79956f362b4e79fa0b60916976c63ef26d6a65a6a51d5d9f7de03
+EBUILD simage-1.8.3-r1.ebuild 2175 BLAKE2B e1ecf50ae26d882d1be0d70b2b8daa1d91d3675394a18f67ba6bf31fce759e40ba541a01bfc97114787923dcb473200d80367cfd8cfeea4723382a3fd4859503 SHA512 0ff7d96d095897f12ff23af0ac8ca356cb3554aa823528acdc28a0bdd3d2c258125535b6bfc701fcb476c90ed14acdeefd3857a8503ad9499f593bdb0a159cb8
EBUILD simage-1.8.3.ebuild 2335 BLAKE2B d7c97ee33cf75a66034abbc477bd01e87a66d163250e3178a6946f1581104e400dbad04db35056df125b947012cecfbd9cc437cf468fafe2ecb905ebac41b5ff SHA512 1bf68cc9a4e303f08a43317c5ea3d3e00e2bf960dbdb19b52865f8cebf89cbf791553cfc2a46665f14cc6e96846feb5d79c078a858d434c0469f06c25ad12877
-EBUILD simage-9999.ebuild 2195 BLAKE2B 618de67f99e1dd788a0deb7e841855bab3668e4645b82aba660400f254e1ad98a339901fd527558fdfa64cf2d0825f519d0595fea368530a8c70296f9870b46c SHA512 9ee520ed02d22469ff31ec572a3343d8499fe92f90a8b20879b97721089c155bc8a9b46ddd194772ab1ca015c8e0ad471b684408e82fa200dc33b91312f3aab5
+EBUILD simage-9999.ebuild 2175 BLAKE2B e1ecf50ae26d882d1be0d70b2b8daa1d91d3675394a18f67ba6bf31fce759e40ba541a01bfc97114787923dcb473200d80367cfd8cfeea4723382a3fd4859503 SHA512 0ff7d96d095897f12ff23af0ac8ca356cb3554aa823528acdc28a0bdd3d2c258125535b6bfc701fcb476c90ed14acdeefd3857a8503ad9499f593bdb0a159cb8
MISC metadata.xml 298 BLAKE2B bbb65357f89a126895f808f22a14211302edac1ef368ceea547a0cb8b0a4d62e50e61572a47a2d9a123d22f33f384cd7fe6b0604d78ce83701608db0725a076d SHA512 70fe0d52216ae4902962671d07b6667c1aad035e9d6a737700a44d3f0ef08670e965cf692dcb3fe106a0dd62125b9fd433bd980cc46a3be4d34cfef7d79da06e
diff --git a/media-libs/simage/simage-1.8.3-r1.ebuild b/media-libs/simage/simage-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..73fd53ca3009
--- /dev/null
+++ b/media-libs/simage/simage-1.8.3-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Image and video texturing library"
+HOMEPAGE="https://github.com/coin3d/simage/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/coin3d/simage.git"
+else
+ SRC_URI="https://github.com/coin3d/simage/releases/download/v${PV}/${P}-src.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}"
+fi
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="gif jpeg png qt6 sndfile test tiff vorbis zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ gif? ( media-libs/giflib:= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( media-libs/libpng:= )
+ qt6? ( dev-qt/qtbase:6[gui] )
+ sndfile? (
+ media-libs/libsndfile
+ media-libs/flac:=
+ )
+ tiff? (
+ media-libs/tiff:=[lzma,zstd]
+ app-arch/xz-utils
+ app-arch/zstd:=
+ )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/opus
+ )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( media-libs/libsndfile )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.1-0001-Gentoo-specific-remove-RELEASE-flag-from-pkg-config.patch
+)
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ local mycmakeargs=(
+ -DSIMAGE_BUILD_SHARED_LIBS=ON
+ -DSIMAGE_BUILD_EXAMPLES=OFF
+ -DSIMAGE_BUILD_TESTS=$(usex test)
+ -DSIMAGE_BUILD_DOCUMENTATION=OFF
+ -DSIMAGE_USE_AVIENC=OFF # Windows only
+ -DSIMAGE_USE_GDIPLUS=OFF # Windows
+ -DSIMAGE_USE_CGIMAGE=OFF # OS X only
+ -DSIMAGE_USE_QUICKTIME=OFF # OS X only
+ -DSIMAGE_USE_QIMAGE=$(usex qt6)
+ -DSIMAGE_USE_QT5=OFF
+ -DSIMAGE_USE_QT6=$(usex qt6)
+ -DSIMAGE_USE_CPACK=OFF
+ -DSIMAGE_USE_STATIC_LIBS=OFF
+ -DSIMAGE_LIBJASPER_SUPPORT=OFF
+ -DSIMAGE_LIBSNDFILE_SUPPORT=$(usex sndfile)
+ -DSIMAGE_OGGVORBIS_SUPPORT=$(usex vorbis)
+ -DSIMAGE_EPS_SUPPORT=ON
+ -DSIMAGE_MPEG2ENC_SUPPORT=ON
+ -DSIMAGE_PIC_SUPPORT=ON
+ -DSIMAGE_RGB_SUPPORT=ON
+ -DSIMAGE_TGA_SUPPORT=ON
+ -DSIMAGE_XWD_SUPPORT=ON
+ -DSIMAGE_ZLIB_SUPPORT=$(usex zlib)
+ -DSIMAGE_GIF_SUPPORT=$(usex gif)
+ -DSIMAGE_JPEG_SUPPORT=$(usex jpeg)
+ -DSIMAGE_PNG_SUPPORT=$(usex png)
+ -DSIMAGE_TIFF_SUPPORT=$(usex tiff)
+ )
+ cmake_src_configure
+}
diff --git a/media-libs/simage/simage-9999.ebuild b/media-libs/simage/simage-9999.ebuild
index fce11a8bd619..73fd53ca3009 100644
--- a/media-libs/simage/simage-9999.ebuild
+++ b/media-libs/simage/simage-9999.ebuild
@@ -8,7 +8,7 @@ inherit cmake
DESCRIPTION="Image and video texturing library"
HOMEPAGE="https://github.com/coin3d/simage/"
-if [[ ${PV} = *9999 ]]; then
+if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/coin3d/simage.git"
else
@@ -50,7 +50,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.8.1-0001-Gentoo-specific-remove-RELEASE-flag-from-pkg-config.patch
)
-DOCS=(AUTHORS ChangeLog NEWS README)
+DOCS=( AUTHORS ChangeLog NEWS README )
src_configure() {
local mycmakeargs=(
@@ -63,7 +63,6 @@ src_configure() {
-DSIMAGE_USE_CGIMAGE=OFF # OS X only
-DSIMAGE_USE_QUICKTIME=OFF # OS X only
-DSIMAGE_USE_QIMAGE=$(usex qt6)
- -DSIMAGE_USE_QT4=OFF
-DSIMAGE_USE_QT5=OFF
-DSIMAGE_USE_QT6=$(usex qt6)
-DSIMAGE_USE_CPACK=OFF