summaryrefslogtreecommitdiff
path: root/media-libs/sdl_audiolib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /media-libs/sdl_audiolib
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'media-libs/sdl_audiolib')
-rw-r--r--media-libs/sdl_audiolib/Manifest4
-rw-r--r--media-libs/sdl_audiolib/metadata.xml17
-rw-r--r--media-libs/sdl_audiolib/sdl_audiolib-0_pre20220410.ebuild59
-rw-r--r--media-libs/sdl_audiolib/sdl_audiolib-9999.ebuild59
4 files changed, 139 insertions, 0 deletions
diff --git a/media-libs/sdl_audiolib/Manifest b/media-libs/sdl_audiolib/Manifest
new file mode 100644
index 000000000000..694d9709f00d
--- /dev/null
+++ b/media-libs/sdl_audiolib/Manifest
@@ -0,0 +1,4 @@
+DIST sdl_audiolib-0_pre20220410.tar.xz 223932 BLAKE2B 09f35684b64b2b96fd0230612cc8458a8c7b0b94860c9d616c90141cd6d8088048e783170180191ed9998b2601676892686dc7d8373c8507d71db59b919c178b SHA512 01ef7f4d8987e1e27b4413d21eefbb8a83ab720f64ed76fd6314244d0d53bed5a061f4a22d4967e21cc9f6086532d33fea233f3e72e8a7abc5a80108f74710c1
+EBUILD sdl_audiolib-0_pre20220410.ebuild 1595 BLAKE2B baf2f56c4dd09145cf8d4a2f9d024c1677d6fdcd6f8d7d6bbd26e743c481fa2417d934973daf96bb74d66227518125450a912eb09b51a713c442421c74952c13 SHA512 4762073f00aaf4d08bca24d10280d045fb2b52babb05df5d23379820eb9bc1e5d0af6df6055acd29088f679c3ff222bed6a043a73b23890df5918129c2decb93
+EBUILD sdl_audiolib-9999.ebuild 1595 BLAKE2B baf2f56c4dd09145cf8d4a2f9d024c1677d6fdcd6f8d7d6bbd26e743c481fa2417d934973daf96bb74d66227518125450a912eb09b51a713c442421c74952c13 SHA512 4762073f00aaf4d08bca24d10280d045fb2b52babb05df5d23379820eb9bc1e5d0af6df6055acd29088f679c3ff222bed6a043a73b23890df5918129c2decb93
+MISC metadata.xml 716 BLAKE2B 0dcc948edf254f51677cc0d771aa5cb746fb6c64998be5a67eccde1d39730fc768375afe3510ef27b80b903bd41397479736fa431d9b933c2c32567f4d1e8417 SHA512 3d202f15e58075f6ea33b6837c82eca413f99c6b953ec8eca92c7aa8244dd25af76eefc57d56e9bd6bd21c66cb4e9744d6b6c59933964363ec5bfa979e39bf3a
diff --git a/media-libs/sdl_audiolib/metadata.xml b/media-libs/sdl_audiolib/metadata.xml
new file mode 100644
index 000000000000..d76fa399a830
--- /dev/null
+++ b/media-libs/sdl_audiolib/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <use>
+ <flag name="fluidsynth">use <pkg>media-sound/fluidsynth</pkg> for MIDI</flag>
+ <flag name="mpg123">Enable support for mp3 decoding via <pkg>media-sound/mpg123</pkg></flag>
+ <flag name="openmpt">OpenMPT decoder via <pkg>media-libs/libopenmpt</pkg></flag>
+ <flag name="soxr">Enable SoX Resampler support via <pkg>media-libs/soxr</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">realnc/SDL_audiolib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/sdl_audiolib/sdl_audiolib-0_pre20220410.ebuild b/media-libs/sdl_audiolib/sdl_audiolib-0_pre20220410.ebuild
new file mode 100644
index 000000000000..d993c84aa88b
--- /dev/null
+++ b/media-libs/sdl_audiolib/sdl_audiolib-0_pre20220410.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="audio decoding, resampling and mixing library"
+HOMEPAGE="https://github.com/realnc/SDL_audiolib"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/realnc/SDL_audiolib.git"
+else
+ # No official releases from upstream yet
+ SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="LGPL-3"
+SLOT="0"
+
+IUSE="fluidsynth libsamplerate modplug mpg123 musepack openmpt opus sndfile soxr vorbis"
+
+RDEPEND="
+ media-libs/libsdl2
+ fluidsynth? ( media-sound/fluidsynth )
+ libsamplerate? ( media-libs/libsamplerate )
+ modplug? ( media-libs/libmodplug )
+ mpg123? ( media-sound/mpg123 )
+ musepack? ( media-sound/musepack-tools )
+ openmpt? ( media-libs/libopenmpt )
+ opus? ( media-libs/opusfile )
+ sndfile? ( media-libs/libsndfile )
+ soxr? ( media-libs/soxr )
+ vorbis? ( media-libs/libvorbis )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_DEC_ADLMIDI=OFF
+ -DUSE_DEC_BASSMIDI=OFF
+ -DUSE_DEC_FLUIDSYNTH="$(usex fluidsynth)"
+ -DUSE_DEC_MODPLUG="$(usex modplug)"
+ -DUSE_DEC_MPG123="$(usex mpg123)"
+ -DUSE_DEC_MUSEPACK="$(usex musepack)"
+ -DUSE_DEC_OPENMPT="$(usex openmpt)"
+ -DUSE_DEC_LIBOPUSFILE="$(usex opus)"
+ -DUSE_DEC_SNDFILE="$(usex sndfile)"
+ -DUSE_DEC_LIBVORBIS="$(usex vorbis)"
+ -DUSE_DEC_WILDMIDI=OFF
+ -DUSE_DEC_XMP=OFF
+ -DUSE_RESAMP_SOXR="$(usex soxr)"
+ -DUSE_RESAMP_SRC="$(usex libsamplerate)"
+ )
+ cmake_src_configure
+}
diff --git a/media-libs/sdl_audiolib/sdl_audiolib-9999.ebuild b/media-libs/sdl_audiolib/sdl_audiolib-9999.ebuild
new file mode 100644
index 000000000000..d993c84aa88b
--- /dev/null
+++ b/media-libs/sdl_audiolib/sdl_audiolib-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="audio decoding, resampling and mixing library"
+HOMEPAGE="https://github.com/realnc/SDL_audiolib"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/realnc/SDL_audiolib.git"
+else
+ # No official releases from upstream yet
+ SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="LGPL-3"
+SLOT="0"
+
+IUSE="fluidsynth libsamplerate modplug mpg123 musepack openmpt opus sndfile soxr vorbis"
+
+RDEPEND="
+ media-libs/libsdl2
+ fluidsynth? ( media-sound/fluidsynth )
+ libsamplerate? ( media-libs/libsamplerate )
+ modplug? ( media-libs/libmodplug )
+ mpg123? ( media-sound/mpg123 )
+ musepack? ( media-sound/musepack-tools )
+ openmpt? ( media-libs/libopenmpt )
+ opus? ( media-libs/opusfile )
+ sndfile? ( media-libs/libsndfile )
+ soxr? ( media-libs/soxr )
+ vorbis? ( media-libs/libvorbis )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_DEC_ADLMIDI=OFF
+ -DUSE_DEC_BASSMIDI=OFF
+ -DUSE_DEC_FLUIDSYNTH="$(usex fluidsynth)"
+ -DUSE_DEC_MODPLUG="$(usex modplug)"
+ -DUSE_DEC_MPG123="$(usex mpg123)"
+ -DUSE_DEC_MUSEPACK="$(usex musepack)"
+ -DUSE_DEC_OPENMPT="$(usex openmpt)"
+ -DUSE_DEC_LIBOPUSFILE="$(usex opus)"
+ -DUSE_DEC_SNDFILE="$(usex sndfile)"
+ -DUSE_DEC_LIBVORBIS="$(usex vorbis)"
+ -DUSE_DEC_WILDMIDI=OFF
+ -DUSE_DEC_XMP=OFF
+ -DUSE_RESAMP_SOXR="$(usex soxr)"
+ -DUSE_RESAMP_SRC="$(usex libsamplerate)"
+ )
+ cmake_src_configure
+}