summaryrefslogtreecommitdiff
path: root/media-libs/sdl2-mixer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /media-libs/sdl2-mixer
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'media-libs/sdl2-mixer')
-rw-r--r--media-libs/sdl2-mixer/Manifest2
-rw-r--r--media-libs/sdl2-mixer/sdl2-mixer-2.0.4.ebuild111
2 files changed, 113 insertions, 0 deletions
diff --git a/media-libs/sdl2-mixer/Manifest b/media-libs/sdl2-mixer/Manifest
index 65e3e0d5dee1..8f71272ff5f2 100644
--- a/media-libs/sdl2-mixer/Manifest
+++ b/media-libs/sdl2-mixer/Manifest
@@ -1,4 +1,6 @@
AUX sdl2-mixer-2.0.2-smpeg.patch 698 BLAKE2B 04f58b64a190c22636c8d0f8218e3070707d9ce75e3be7846baafcbcc36223784c367da111f481377a319562c622d27a3b67b27a32bffc515a32c4e119e65f79 SHA512 78c02a15384e98f846ff9448205da3a43c1e1e39ae9ae33c14651076d5659a83ccd840d67b1044dc19a0da66a07fb98793a78044ae0afa089a26cfbf8951db82
DIST SDL2_mixer-2.0.2.tar.gz 9620763 BLAKE2B 9257f7f3dc3453b600075011f1879391c4a4def2c67709a883a8803f752928d3883fbe11371609cd5e690647a33b43bfd38f152aa620f63af12e1b7b72fa0ec4 SHA512 c40b5ac93933df1cc932e7afe796ad6765aafb24077601a23f98ac625a83341079ad903c164eafd022aff6011872e7a7956eebd8e3d3edad1bf5dc7eb9c306b7
+DIST SDL2_mixer-2.0.4.tar.gz 11125077 BLAKE2B ccb55020e360fa000e82807b8c4e2371228291943d2dc7371606834ca0f781d4e82581b5427e9902156bf3072208db4ec07e95a06f206e40ff530f432dd9e491 SHA512 98c56069640668aaececa63748de21fc8f243c7d06386c45c43d0ee472bbb2595ccda644d9886ce5b95c3a3dee3c0a96903cf9a89ddc18d38f041133470699a3
EBUILD sdl2-mixer-2.0.2-r1.ebuild 3258 BLAKE2B d5962eba570d4b2a42589d498118977cbfdb7baf83c1422c3614920612a7cc6fdb5c3d0623fc74c9a24b5120beffd3ee2409cf8b19380cee0f13c54f879f3fe4 SHA512 5de83350d6b84e8b2cc6db63a786a9495b6d5b4b864634916b69c18ecbb0c2b46dfd14d881a14755c4483f3b1eae5f0b15f5e2a420a7b4cef69d8f6115c4124a
+EBUILD sdl2-mixer-2.0.4.ebuild 3236 BLAKE2B a6eddaeedb5ae8ef3f9b2a811a4ffc6639a874da5f29099e502455d76fb08d26f69e5085ed5461250de218fc3963581edda5f239d4455429782330b23733dafa SHA512 41cd4d0afcfaf8a1275b060ba3587f7063ac1b651c3deb7e76ae11d24d06cc8b968a2a8af0d33e5e1edd7a88fdd3a9477b04336be7ed2e77797cfaafa31070ea
MISC metadata.xml 751 BLAKE2B 7bc41a1afbb031953f9621d7f9059fc27bb588fc813c4dc68fbc760824a0a1c301997803712b6bc96d9814439fd8274ad388d18d54c2b125b71002247253ea7e SHA512 2376560d848b86e6d3b1728f581cd43bd812b8bfa4e89eb839f2505dfd3f75cfbc3c82bd9a91e571f6021e6ce7ea39df99d964fd29d0159f241539e86d65ce4b
diff --git a/media-libs/sdl2-mixer/sdl2-mixer-2.0.4.ebuild b/media-libs/sdl2-mixer/sdl2-mixer-2.0.4.ebuild
new file mode 100644
index 000000000000..97b58879c407
--- /dev/null
+++ b/media-libs/sdl2-mixer/sdl2-mixer-2.0.4.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="SDL2_mixer-${PV}"
+inherit multilib-minimal
+
+DESCRIPTION="Simple Direct Media Layer Mixer Library"
+HOMEPAGE="https://www.libsdl.org/projects/SDL_mixer/"
+SRC_URI="https://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE="flac fluidsynth mad midi mikmod mod modplug mp3 opus playtools static-libs timidity tremor vorbis +wav"
+REQUIRED_USE="
+ midi? ( || ( timidity fluidsynth ) )
+ timidity? ( midi )
+ fluidsynth? ( midi )
+ mad? ( mp3 )
+ mod? ( || ( mikmod modplug ) )
+ mikmod? ( mod )
+ modplug? ( mod )
+ tremor? ( vorbis )
+"
+
+RDEPEND="
+ >=media-libs/libsdl2-2.0.7[${MULTILIB_USEDEP}]
+ flac? ( >=media-libs/flac-1.2.1-r5[${MULTILIB_USEDEP}] )
+ midi? (
+ fluidsynth? ( >=media-sound/fluidsynth-1.1.6-r1[${MULTILIB_USEDEP}] )
+ timidity? ( media-sound/timidity++ )
+ )
+ mod? (
+ mikmod? ( >=media-libs/libmikmod-3.3.6-r1[${MULTILIB_USEDEP}] )
+ modplug? ( >=media-libs/libmodplug-0.8.8.4-r1[${MULTILIB_USEDEP}] )
+ )
+ mp3? (
+ mad? ( >=media-libs/libmad-0.15.1b-r8[${MULTILIB_USEDEP}] )
+ !mad? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
+ )
+ opus? ( >=media-libs/opusfile-0.2 )
+ vorbis? (
+ tremor? ( >=media-libs/tremor-0_pre20130223[${MULTILIB_USEDEP}] )
+ !tremor? (
+ >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}]
+ >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )
+ )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --disable-sdltest
+ --enable-music-cmd
+ $(use_enable wav music-wave)
+ $(use_enable mod music-mod)
+ $(use_enable modplug music-mod-modplug)
+ --disable-music-mod-modplug-shared
+ $(use_enable mikmod music-mod-mikmod)
+ --disable-music-mod-mikmod-shared
+ $(use_enable midi music-midi)
+ $(use_enable timidity music-midi-timidity)
+ $(use_enable fluidsynth music-midi-fluidsynth)
+ --disable-music-midi-fluidsynth-shared
+ $(use_enable vorbis music-ogg)
+ $(use_enable tremor music-ogg-tremor)
+ --disable-music-ogg-shared
+ $(use_enable flac music-flac)
+ --disable-music-flac-shared
+ $(use_enable mp3 music-mp3)
+ $(use_enable !mad music-mp3-mpg123)
+ --disable-music-mp3-mpg123-shared
+ $(use_enable mad music-mp3-mad-gpl)
+ $(use_enable opus music-opus)
+ --disable-music-opus-shared
+ LIBMIKMOD_CONFIG=${EPREFIX}/usr/bin/${CHOST}-libmikmod-config
+ )
+ ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use playtools ; then
+ emake DESTDIR="${D}" install-bin
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ # bug 412035
+ # https://bugs.gentoo.org/show_bug.cgi?id=412035
+ if use midi && use fluidsynth; then
+ ewarn "FluidSynth support requires you to set the SDL_SOUNDFONTS"
+ ewarn "environment variable to the location of a SoundFont file"
+ ewarn "unless the game or application happens to do this for you."
+ if use timidity; then
+ ewarn "Failing to do so will result in Timidity being used instead."
+ else
+ ewarn "Failing to do so will result in silence."
+ fi
+ fi
+}