summaryrefslogtreecommitdiff
path: root/media-libs/sdl2-gfx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-libs/sdl2-gfx
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-libs/sdl2-gfx')
-rw-r--r--media-libs/sdl2-gfx/Manifest2
-rw-r--r--media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild13
2 files changed, 9 insertions, 6 deletions
diff --git a/media-libs/sdl2-gfx/Manifest b/media-libs/sdl2-gfx/Manifest
index 9e47deedb18a..8aec9b1582f5 100644
--- a/media-libs/sdl2-gfx/Manifest
+++ b/media-libs/sdl2-gfx/Manifest
@@ -1,4 +1,4 @@
AUX sdl2-gfx-1.0.4-slibtool.patch 560 BLAKE2B 421170fe30fc7ba46867cfe111fd7366b68caa5a33e9e3ed27a47ef1350858a08a3c7f05aeb79219696d428b8409dabaec339a1f7169b7d3847ca037c05804f7 SHA512 f8266c0e43f77471c8ac28e6b3815c07a3dc36fe1a05a89fa578551f038ea48839dc9602294626f7b3030e9e8aeeaa6df98b28beee15baf5a81bcb3ebfc5fbc6
DIST SDL2_gfx-1.0.4.tar.gz 1230588 BLAKE2B a14cf8433aa171b8185aab765c934262fd4ecde4e45e9c8bdfb4aa7feb97676cd8fb5274ad0452bcf77fcc8f268254184fedc73f1c791ff42305d518d01a8cc7 SHA512 81a100d3c8c3a7c6bd37a23f1290ff10685f8e62fbecd83b0086aae4edc721483e2153cd4219fbd9168f115eea0ea6b25f9be375faf5761f0babdfb1b52fe482
-EBUILD sdl2-gfx-1.0.4.ebuild 1125 BLAKE2B 66d7bfcd52ae2ad4175269d5425727f0b5c2f3636e4b5bcd9c64e3791dbc328c417dbbf1af63b6bcdd3834a89ce7bf748f29e732c59ae8d8018dc318863156f3 SHA512 ab6a0f04d27f929dc1d11e92a35303d801441d82a142cc42312d4bea43ad834fb12fe6311989a3f85b9ad86d730af462065a32aa6c3f2d1e2308769c29c95399
+EBUILD sdl2-gfx-1.0.4.ebuild 1102 BLAKE2B 2b1a29385ed96ebda541748d17ee1921b03ad1e233226a555c8368df6f12767abc56a0036e1232ae2f292fd85997f7089d6656637bfaa20f0441a19f715389a9 SHA512 11a361005f6f4936f05a1b20fa289492d9abdf2c2568ec0b0ae515b89b9ffa847e01110811afff11eaa1564775b6e2ff72fd034700b92a57118e1cb7e62790ad
MISC metadata.xml 801 BLAKE2B f50f493cdd14251d398a3cd92dc0b282fb7cfeb631998e70654c8c2132a698b375be5bd778cce89944b1ddf98161961e54dcf7db0442ba0b09b61c675a36c9d6 SHA512 9ea5f88ee86ff482c56e86b0e83d4f7c56ec17c46824eac8273981c7f6988df4f83299c98972036551a2bfe96b9b099a9f943de77f3586e9db99dd99909085d4
diff --git a/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild b/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild
index 494a39f77f5a..7208220ba2c4 100644
--- a/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild
+++ b/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild
@@ -2,27 +2,27 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit autotools multilib-minimal
MY_P="${P/sdl2-/SDL2_}"
DESCRIPTION="Graphics drawing primitives library for SDL2"
HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
SRC_URI="http://www.ferzkopp.net/Software/SDL2_gfx/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="amd64 ~ppc64 x86"
-IUSE="doc cpu_flags_x86_mmx static-libs"
+IUSE="doc cpu_flags_x86_mmx"
DEPEND=">=media-libs/libsdl2-2.0.1-r1[video,${MULTILIB_USEDEP}]"
RDEPEND="${DEPEND}"
DOCS=( AUTHORS ChangeLog README )
-S=${WORKDIR}/${MY_P}
-
PATCHES=(
- "${FILESDIR}/${PN}-1.0.4-slibtool.patch"
+ "${FILESDIR}"/${PN}-1.0.4-slibtool.patch
)
src_prepare() {
@@ -37,16 +37,19 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
$(use_enable cpu_flags_x86_mmx mmx)
- $(use_enable static-libs static)
+ --disable-static
)
+
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
einstalldocs
+
if use doc ; then
docinto html
dodoc -r Docs/html/*
fi
+
find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
}