summaryrefslogtreecommitdiff
path: root/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild')
-rw-r--r--media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild b/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild
new file mode 100644
index 000000000000..50a8e683dc38
--- /dev/null
+++ b/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools multilib-minimal
+
+MY_P="${P/sdl2-/SDL2_}"
+DESCRIPTION="Graphics drawing primitives library for SDL2"
+HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
+SRC_URI="http://www.ferzkopp.net/Software/SDL2_gfx/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc cpu_flags_x86_mmx static-libs"
+
+DEPEND=">=media-libs/libsdl2-2.0.1-r1[video,${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README )
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ sed -i \
+ -e 's/ -O / /' \
+ configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use doc ; then
+ docinto html
+ dodoc -r Docs/html/*
+ fi
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}