summaryrefslogtreecommitdiff
path: root/media-libs/raspberrypi-userland-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /media-libs/raspberrypi-userland-bin
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'media-libs/raspberrypi-userland-bin')
-rw-r--r--media-libs/raspberrypi-userland-bin/Manifest2
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201201.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland-bin/Manifest b/media-libs/raspberrypi-userland-bin/Manifest
index 3defca2d3a7b..26183f780035 100644
--- a/media-libs/raspberrypi-userland-bin/Manifest
+++ b/media-libs/raspberrypi-userland-bin/Manifest
@@ -1,4 +1,6 @@
AUX 04raspberrypi-userland-bin 21 BLAKE2B c494bde8627a6068bf924d722cbc7ccb48e4d49cf9b875f0420e621018b61d83fc27de0017586f21cb839414e4aa49118bf3e2ab90e049e47a7a9e15658d2f87 SHA512 15fc252a183d45f0d80cc27edc93c40a7b577abed3e2f664c8bf635178e73875245835e770b82fda0e983c7c5878975ffe3008a937fbb7656fc01860c2219854
DIST raspberrypi-firmware-1.20201022.tar.gz 189827375 BLAKE2B 94c38f60d688c8e3ebab830912daccbb6c04bdd3d88f6ca0d07d85be0a6b12c53f0266b4c258ed4694f30bad5db30fb6d30feabfd0b7668735a9a806b820d325 SHA512 876758179df27109984b6c3f4849fdcdc6bdcc2769495fcc83c97fc3ff4d07b9f3cd58086be877503f72c9e5417d2be6d6c33bce4cbb3b862055117c9cc26db8
+DIST raspberrypi-firmware-1.20201201.tar.gz 189332299 BLAKE2B b3ec91f07b4713d26c29be5412d018a220129eef7ddf7c5c09d85e645c2c5754a95f13be7e690ab40648a982e3974cc760aa5b33c76612da836227d38c4ee3a5 SHA512 a7f4591552718956bd7f2d0d377234277e2e6f18cc9714ea30fe13f26d5ae1164b982f39dcf72ae4a18663369ef06d0187d8182713763262371c13107aac4c65
EBUILD raspberrypi-userland-bin-1.20201022.ebuild 863 BLAKE2B 93a8fb6979dc8916f73a103f2591382f541fef829f8cff70e11f3d0dc99ade47a2a2aa67dbc6a87dcfb16633ff0f8e7d7468d5c08ee10e9f2ac69b80841c8d12 SHA512 2731ce73606bd16a94903d4a44adc5f1f13f231c70e7616195e19403bd3eb8c6b8177a933772095bfa507d190f2f131b850062c10a91f90fe68a95fadbd67f67
+EBUILD raspberrypi-userland-bin-1.20201201.ebuild 864 BLAKE2B f0136b2b79a2bb8d2a5e189bba7b513f36c641e7f4ff65536b9d43c8191ad51f45d5aa46ad0b8f416fa53b4b9088bc1d267bfcae90e02f7fcdf1fc28bf252071 SHA512 01e962b667b3ab4516f75cdaf4e1f66c54b7b80204fd89af81fef5a35f73ed78122041cbdb569c926f627c97395f350d0113c15987f8b9a734d923b39e5cff11
MISC metadata.xml 389 BLAKE2B d3577d29c94a74d9cc3cbf749fe2cdc46e37ffc5aeed828e280e04fec248f71a1dcbea5aee4c1e178c9699771c88bbb03228aba956069be5f07818d21ea65a67 SHA512 83074595bc89f763ca63b370aeaf44ca973ddfe6cd411de09dc89bc90f986078a7e2af98354f5ed7442a2b526d41851e8312d6b70e131d13377a69daf32e4f54
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201201.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201201.ebuild
new file mode 100644
index 000000000000..9ce4a8fd7918
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201201.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="raspberrypi-firmware-${PV}"
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/firmware-${PV}"
+
+LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="-* ~arm"
+IUSE="+hardfp examples"
+
+RDEPEND="!media-libs/raspberrypi-userland"
+DEPEND="${DEPEND}"
+RESTRICT="binchecks strip"
+
+src_install() {
+ cd $(usex hardfp hardfp/ "")opt/vc || die
+
+ insinto /opt/vc
+ doins -r include
+
+ into /opt
+ dobin bin/*
+
+ insopts -m 0755
+ insinto "/opt/vc/lib"
+ doins -r lib/*
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ if use examples ; then
+ insopts -m 0644
+ docinto examples
+ dodoc -r src/hello_pi
+ fi
+}