summaryrefslogtreecommitdiff
path: root/media-libs/raptor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /media-libs/raptor
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'media-libs/raptor')
-rw-r--r--media-libs/raptor/Manifest1
-rw-r--r--media-libs/raptor/raptor-2.0.15-r4.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/media-libs/raptor/Manifest b/media-libs/raptor/Manifest
index d8283ff2c368..dc05bfbdc169 100644
--- a/media-libs/raptor/Manifest
+++ b/media-libs/raptor/Manifest
@@ -3,4 +3,5 @@ AUX raptor-2.0.15-dont_use_curl-config.patch 1681 BLAKE2B 5c3b241836e04dabbcd6fd
AUX raptor-2.0.15-heap-overflow.patch 1708 BLAKE2B cea8df63861760fe55f1320cbc0833d814c38148b3d5f2b7163348de48bd95a37ee3000d312ce76879c798182f74d60f49fcef89f5f051bd40febc0c1da68099 SHA512 f7df0ec3123ac8ec9f2852dfb54e380d210446a36ab2f74aa9d2dcb8346162046d239b4db9a0747b18e3d19f4dc1ce41d194557c5e53027a3618e81b7b251d3d
DIST raptor2-2.0.15.tar.gz 1886657 BLAKE2B 0a39c7b5705bfbf2daa0ca633f79693953b4dfe24c144008d1646a9840a36d4d7ce153b527450647127ec2522047dbd0a6e71f307ee5656951f7e4b610adfd22 SHA512 563dd01869eb4df8524ec12e2c0a541653874dcd834bd1eb265bc2943bb616968f624121d4688579cdce11b4f00a8ab53b7099f1a0850e256bb0a2c16ba048ee
EBUILD raptor-2.0.15-r3.ebuild 1713 BLAKE2B 9c61a997c410dc4600384ec53b8995ea4782dd2169179c49073b0812953ef399a9ce360b8b6c4d626aae7351e80d50763abe76ea2c85eb9c482bbef04817ec6b SHA512 bb56a414bd06bcf3ee8a656e87e1e7171e2e7fd4bf3c690995d97e3aedd7a99418083f19a0ab2da8772ea6d985a888757e8ba393d02a1c9298c1eaabd7f06ad5
+EBUILD raptor-2.0.15-r4.ebuild 1887 BLAKE2B 56199b0bdce95b0419b691370517fc8c689835f9f04db78e046c9137589d155af1fc8cd4ceac8e32855690a4c527792b87999bf5869f87f3231bbede34513b76 SHA512 2ebdadef2c14f9fe445ba574a870e40f193c49de1eab96a0243b1d468308a1fad5d0cbed6c39e37d5b1932e715d2185f7f2adc1e49693c6e296656eae7015998
MISC metadata.xml 337 BLAKE2B 6244cd4ab5d8d13437590c4bbb672cb9b5ad47f7e70d30adda368737d745daf4df249eb2166d2ab8335fe0a0fec5b8d3afa9ec091cc6ddcaaf0f2d05f9425741 SHA512 3a2c420495274cfca80f0103066b282b9f1301786a8cbde76b894fac721030bee949fc468c92841698038b991b07fa66f15891392784041a87f655d1860fd11c
diff --git a/media-libs/raptor/raptor-2.0.15-r4.ebuild b/media-libs/raptor/raptor-2.0.15-r4.ebuild
new file mode 100644
index 000000000000..f32b2698b01d
--- /dev/null
+++ b/media-libs/raptor/raptor-2.0.15-r4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools libtool multilib-minimal
+
+MY_PN=${PN}2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="The RDF Parser Toolkit"
+HOMEPAGE="http://librdf.org/raptor/"
+SRC_URI="http://download.librdf.org/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+curl debug json static-libs unicode"
+
+DEPEND="
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ dev-libs/libxslt[${MULTILIB_USEDEP}]
+ curl? ( net-misc/curl[${MULTILIB_USEDEP}] )
+ json? ( dev-libs/yajl[${MULTILIB_USEDEP}] )
+ unicode? ( dev-libs/icu:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}
+ !media-libs/raptor:0
+"
+BDEPEND="
+ >=sys-devel/bison-3
+ >=sys-devel/flex-2.5.36
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS ChangeLog NEWS NOTICE README )
+HTML_DOCS=( {NEWS,README,RELEASE,UPGRADING}.html )
+
+PATCHES=(
+ "${FILESDIR}/${P}-heap-overflow.patch"
+ "${FILESDIR}/${P}-dont_use_curl-config.patch" #552474
+ "${FILESDIR}/0001-CVE-2020-25713-raptor2-malformed-input-file-can-lead.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf #552474
+ elibtoolize # Keep this for ~*-fbsd
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ # FIXME: It should be possible to use net-nntp/inn for libinn.h and -linn!
+
+ local myeconfargs=(
+ --with-html-dir="${EPREFIX}"/usr/share/gtk-doc/html
+ $(usex curl --with-www=curl --with-www=xml)
+ $(use_enable debug)
+ $(use_with json yajl)
+ $(use_enable static-libs static)
+ $(usex unicode --with-icu-config="${EPREFIX}"/usr/bin/icu-config '')
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ emake -j1 test
+}
+
+multilib_src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}