summaryrefslogtreecommitdiff
path: root/media-libs/raptor/raptor-2.0.15-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /media-libs/raptor/raptor-2.0.15-r1.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'media-libs/raptor/raptor-2.0.15-r1.ebuild')
-rw-r--r--media-libs/raptor/raptor-2.0.15-r1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/media-libs/raptor/raptor-2.0.15-r1.ebuild b/media-libs/raptor/raptor-2.0.15-r1.ebuild
deleted file mode 100644
index 2710505b2740..000000000000
--- a/media-libs/raptor/raptor-2.0.15-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit libtool
-
-MY_PN=${PN}2
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="The RDF Parser Toolkit"
-HOMEPAGE="http://librdf.org/raptor/"
-SRC_URI="http://download.librdf.org/source/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
-SLOT="2"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+curl debug json static-libs unicode"
-
-DEPEND="
- dev-libs/libxml2
- dev-libs/libxslt
- curl? ( net-misc/curl )
- json? ( dev-libs/yajl )
- unicode? ( dev-libs/icu:= )
-"
-RDEPEND="${DEPEND}
- !media-libs/raptor:0
-"
-BDEPEND="
- >=sys-devel/bison-3
- >=sys-devel/flex-2.5.36
- virtual/pkgconfig
-"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( AUTHORS ChangeLog NEWS NOTICE README )
-HTML_DOCS=( {NEWS,README,RELEASE,UPGRADING}.html )
-
-PATCHES=( "${FILESDIR}/${P}-heap-overflow.patch" )
-
-src_prepare() {
- default
- elibtoolize # Keep this for ~*-fbsd
-}
-
-src_configure() {
- # FIXME: It should be possible to use net-nntp/inn for libinn.h and -linn!
-
- local myeconfargs=(
- --with-html-dir="${EPREFIX}"/usr/share/gtk-doc/html
- $(usex curl --with-www=curl --with-www=xml)
- $(use_enable debug)
- $(use_with json yajl)
- $(use_enable static-libs static)
- $(usex unicode --with-icu-config="${EPREFIX}"/usr/bin/icu-config '')
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- emake -j1 test
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}