summaryrefslogtreecommitdiff
path: root/media-libs/phonon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
commit90a3be9d71a22834f9bc82c072f1b993f9a10e31 (patch)
tree7f86c1f37e857df29494ec91436ca76bed49441a /media-libs/phonon
parenta597364520b9291d0b2a23bb007ced022e821d95 (diff)
gentoo auto-resync : 20:08:2023 - 21:42:17
Diffstat (limited to 'media-libs/phonon')
-rw-r--r--media-libs/phonon/Manifest3
-rw-r--r--media-libs/phonon/files/phonon-4.11.1-clang-16.patch38
-rw-r--r--media-libs/phonon/phonon-4.11.1-r2.ebuild4
3 files changed, 43 insertions, 2 deletions
diff --git a/media-libs/phonon/Manifest b/media-libs/phonon/Manifest
index 9a34c87143c2..77b145289e05 100644
--- a/media-libs/phonon/Manifest
+++ b/media-libs/phonon/Manifest
@@ -1,3 +1,4 @@
+AUX phonon-4.11.1-clang-16.patch 1356 BLAKE2B 2adbe00797db0efab8a065c455b8122bea99ffdca9317939c85e54c65cf9292f1de7531bff89fbed227cdab035547680291c6d20d02a374bfe7e28ef9ec9706d SHA512 5ef9e3bcefd607036e47cd6578be5bb98a384bb4cd4820aab90cd7adf1eb0ae54ad001550909a93513e1d622ef4101f95fce733e3fa7a95d5df8454290ef92aa
DIST phonon-4.11.1.tar.xz 314732 BLAKE2B 9be341f8df643b352392a208c7f24d799edcc94146b71c73d93974a7ef02cc75b5baa1e2ddd037e7e2d3afeb52347d96caaa8b3a2319631802261735a3a751df SHA512 858b2b0d7b0336af76d226b30f3acd1914e7297e0879d5a417fa1b87b13c812f9aab7e20adcad33ce1a03624ce78323dd9968b4b277caf85f800ca60aa134f74
-EBUILD phonon-4.11.1-r2.ebuild 1240 BLAKE2B 5a6e9d1e80d9660983aeb0b59b87eb0392f837b7befef55be09abc332463c398c08bc443609e28a9577bc8c98c6b3fb2e6d778e780c14dd31351496843848deb SHA512 0c116c52f1224d03493999b24d291feef80d39ff3bde8e10ea31bfb534a3037fac4f9a4398415277ca2e337fa12eae47ca4d57a2090497023e7972dd88f3e8c7
+EBUILD phonon-4.11.1-r2.ebuild 1300 BLAKE2B bd742c33d458e597f9c6273122391d11c05f28a1f98527eba46c9ac28f5b671b75f90b9e26de827e5958422f64a75058ad8b0647bbf0fe49f871a31cb5ba87be SHA512 1bbaea58c18915fb2e51906eda45a923593b690600906b571497df9c1b185c93242347cd59e7dcb9ebbfcdc20d6664e04409ff10fdc4cffa861113244f252005
MISC metadata.xml 463 BLAKE2B 856a539bfa489dac4d6550f9fb4104b419dc6dd12a5d6ec67ac7d9f743fa31d96c3323937558704b7941a914c1ca342b5a6030e9f16b7d84f2339f93d2a1fb9f SHA512 c6aa1e0f8f11e813c228619f9c857bfa3e15d3278a1b5af3910f8f789a7d93f889a9adb9121f19b4b52abbfa0b4a67d89a037679ae0eab00b0db04ed5e16526e
diff --git a/media-libs/phonon/files/phonon-4.11.1-clang-16.patch b/media-libs/phonon/files/phonon-4.11.1-clang-16.patch
new file mode 100644
index 000000000000..a3fe704bba0d
--- /dev/null
+++ b/media-libs/phonon/files/phonon-4.11.1-clang-16.patch
@@ -0,0 +1,38 @@
+From 069d5a3eb81bcbc730e44c27a0d060a85cf9213d Mon Sep 17 00:00:00 2001
+From: Dimitry Andric <dimitry@andric.com>
+Date: Sun, 16 Jul 2023 15:17:39 +0200
+Subject: [PATCH] Future-proof build fix for clang > 16
+
+Clang is intending to remove the `-Wno-enum-constexpr-conversion` flag
+in the future, because it can invoke undefined behavior.
+
+To avoid the "integer value NNNN is outside the valid range of values
+[0, 7] for the enumeration type 'ObjectDescriptionType'" warnings,
+explicitly specify that the `ObjectDescriptionType` enum uses `unsigned`
+as the underlying type.
+
+This also allows to remove the CMake patch that added the
+`-Wno-enum-constexpr-conversion` flag.
+
+* asturm 2023-08-20: Drop adding of -Wno-enum-constexpr-conversion in
+ commit f685bdfdf30deeea2d1db01c1edf0c60cbda652e in the first place.
+
+---
+ phonon/objectdescription.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/phonon/objectdescription.h b/phonon/objectdescription.h
+index 97fec2e79..6ce92de54 100644
+--- a/phonon/objectdescription.h
++++ b/phonon/objectdescription.h
+@@ -43,7 +43,7 @@ namespace Phonon
+ *
+ * \ingroup Backend
+ */
+- enum ObjectDescriptionType
++ enum ObjectDescriptionType : unsigned
+ {
+ /**
+ * Audio output devices. This can be soundcards (with different drivers), soundservers or
+--
+GitLab
diff --git a/media-libs/phonon/phonon-4.11.1-r2.ebuild b/media-libs/phonon/phonon-4.11.1-r2.ebuild
index da2281950bf6..0fd2db131a67 100644
--- a/media-libs/phonon/phonon-4.11.1-r2.ebuild
+++ b/media-libs/phonon/phonon-4.11.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,6 +36,8 @@ PDEPEND="
vlc? ( >=media-libs/phonon-vlc-0.9.60 )
"
+PATCHES=( "${FILESDIR}/${P}-clang-16.patch" ) # bug 894346
+
src_configure() {
local mycmakeargs=(
-DPHONON_BUILD_DESIGNER_PLUGIN=$(usex designer)