summaryrefslogtreecommitdiff
path: root/media-libs/partio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-10 13:02:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-10 13:02:42 +0000
commit8c8f1cfd2aa9e839aad7dad6fd43b370cfbc0a1e (patch)
treef7b0f94c13a0454ed75b614028f1455e894f28d2 /media-libs/partio
parent47f05d092ef8c19b3e973f62648e58c0e1a18631 (diff)
gentoo auto-resync : 10:01:2024 - 13:02:42
Diffstat (limited to 'media-libs/partio')
-rw-r--r--media-libs/partio/Manifest2
-rw-r--r--media-libs/partio/partio-1.17.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/partio/Manifest b/media-libs/partio/Manifest
index 482a57b364fc..ff2522e78331 100644
--- a/media-libs/partio/Manifest
+++ b/media-libs/partio/Manifest
@@ -1,3 +1,5 @@
DIST partio-1.14.6.tar.gz 336527 BLAKE2B 60c9c6ad9d5a7b58967e7633180d4f8d399bd129cc7b76fc4329b3d191ce0d381df7f977d5ec11ccedbdbcd8afa0fde2f946960f08a242338c2f674b4c94343e SHA512 5479d00b3124e8e06abbc65b1cdc01cdac37b9207c0615029e488baa0835e4ad545be2fb07dda5b4541dd846115059aaca5950ff904bddec6bb1fd72180ebcc0
+DIST partio-1.17.1.tar.gz 338461 BLAKE2B 6c08d5b74db34ce114206ab92332e42e827d537d83e65597ba777344e1b9dc69f9b57153f716e87df6955b9898cedcd7e6da353db111463d7c8bd47f648cca6a SHA512 5dbbd988c76a26ac6f3024e29ed12f37f7995daf211e065b9ffaf185c6203be7d9de48bd62b5955d2f5444af72fb3306ea5a0f3501cb0a49a26f157bb09ec6bc
EBUILD partio-1.14.6.ebuild 1001 BLAKE2B d37ada07456e2dab3cd0e20debdf92da2ffe7bd4839b0b206cc663debb4cf170a6b4e97d39435fb6832546dcfc8e635e6dcf417a462dd17aa22d4c197198f471 SHA512 938e8aba20ac4e921ebe12c3f158d550f77ce76cfadccb839852da5ca576a4125371922fa548f9ceb12728ced746d51e3b15a334b91abfaa8b4df7c815e654fe
+EBUILD partio-1.17.1.ebuild 1005 BLAKE2B b317ed70d4beba059b3b9227cbb861dcb3f39b00de039c39af22af5dca4522b071b218864d5a5f4eb1488186c62bf3879058f04fd06737f0cd284a3e606bf2b5 SHA512 c07841225d7ce595366591b7503a2032f23db7f8cb9590ecc8d8366593ba88a3a3008c51b9294292f8d8c95af53fe97d59fbc27fe78a661cd1567f84882e30f0
MISC metadata.xml 475 BLAKE2B c8260e899b75f38caf77d3742e752758705e5cfb937fb7e8cc8f925cead54d97bd5d308b2cd3bd74fd63b87060f27be27adafa2a70c28991802abdfd2273cc24 SHA512 a67d143e48e71c2d0c649d66e348177d843f7a3607c4da92e0da98d9228a3a16c8c7e12b9d26df03175ff9c4a2082c71c19f91f3d13b91cb2337a6bb0ed6ce8c
diff --git a/media-libs/partio/partio-1.17.1.ebuild b/media-libs/partio/partio-1.17.1.ebuild
new file mode 100644
index 000000000000..69d97eac7f7c
--- /dev/null
+++ b/media-libs/partio/partio-1.17.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake python-single-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wdas/partio.git"
+else
+ SRC_URI="https://github.com/wdas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library for particle IO and manipulation"
+HOMEPAGE="https://partio.us/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/freeglut
+ media-libs/glu
+ sys-libs/zlib
+ virtual/opengl
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-lang/swig
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package doc Doxygen)
+ )
+ cmake_src_configure
+}