summaryrefslogtreecommitdiff
path: root/media-libs/opusfile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-22 07:05:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-22 07:05:54 +0000
commit13ec12ad28bc2ce6e2902be1d571befcca2b3f60 (patch)
tree7c606c326ffa4095258ba77370fe2cad7aff49a8 /media-libs/opusfile
parentb7819d03d7312d3d8d12b49738aa417f35f6e18a (diff)
gentoo auto-resync : 22:11:2022 - 07:05:54
Diffstat (limited to 'media-libs/opusfile')
-rw-r--r--media-libs/opusfile/Manifest2
-rw-r--r--media-libs/opusfile/files/opusfile-0.12-configure-clang16.patch77
-rw-r--r--media-libs/opusfile/opusfile-0.12-r1.ebuild54
3 files changed, 133 insertions, 0 deletions
diff --git a/media-libs/opusfile/Manifest b/media-libs/opusfile/Manifest
index fce51316c790..f641244b9cb7 100644
--- a/media-libs/opusfile/Manifest
+++ b/media-libs/opusfile/Manifest
@@ -1,3 +1,5 @@
+AUX opusfile-0.12-configure-clang16.patch 2946 BLAKE2B 7eab443d03a08136e55329c87e5f084724c205f6789db5747f40318153fbcc4d413024fac6abb5441dbfcca3ece893b82714e0d5ec6d2cced9f94fbbd944c7e4 SHA512 2e7a2c9594f0eda9ed9486e621c932660cd2b86694e4fb5c166da05fd90949a7e74d627ee49ffb516525bf0d5fcfeb2407834d9163da0b46f0c9625362c2f550
DIST opusfile-0.12.tar.gz 471354 BLAKE2B d54d9b8ed011c018dc6de77afab524d2e47ba6cca69b911efacf361b41f3b59a31424cb15a778db14166815ba5e2352f33f8aa7987c30e5e14339c652558d18d SHA512 e25e6968a3183ac0628ce1000840fd6f9f636e92ba984d6a72b76fb2a98ec632d2de4c66a8e4c05ef30655c2a4a13ab35f89606fa7d79a54cfa8506543ca57af
+EBUILD opusfile-0.12-r1.ebuild 1063 BLAKE2B 069a792494a5e536f2380ec01624670d8c4f9ff5326b959c1fdf92b7a9bc4bbead1c2d584f1d1376404d00fad8b0d21e7065f7589d0e89bbb549114c87d3a5a9 SHA512 9fce2b84f753315c45220cc86238a88e06223058314b5f354e2beb6739041eca035b957bf3d321e4975220a98fe6d3abbbbc59c5403803ff290e52cb8defa8a8
EBUILD opusfile-0.12.ebuild 886 BLAKE2B 547609972d72c4ec6cd637761feeff75a273b488ec2890c6605384bb97dcb3f9419e00c065921906dab4736ceb7355887a267ba7db9a00a7a5d48734f91acda5 SHA512 85a2ec759b60938e28bf04cce2e83e5d5550f2b1ffccfc51621bb07c5994b05087db573650ec652e6811886eae4adda8d4c3353790f3f98d2c6c8b0afc265c02
MISC metadata.xml 575 BLAKE2B 2e91403f82dd5a8a772db511f2473ae4d7ae318163107d0ff6a9710e62521cd510a129eae38cd1afabbcc88af225b0a3035382c3130a838dac0f6850be255389 SHA512 6d15ee03dcdfc53a581d70e43a0884b0c4a52de9691fcacd9bc7ad80967c775d3f8f7636e112b4893964d6dea3be02bfbb825bc467003dd8de1bc987485e9a4c
diff --git a/media-libs/opusfile/files/opusfile-0.12-configure-clang16.patch b/media-libs/opusfile/files/opusfile-0.12-configure-clang16.patch
new file mode 100644
index 000000000000..2319b06e652b
--- /dev/null
+++ b/media-libs/opusfile/files/opusfile-0.12-configure-clang16.patch
@@ -0,0 +1,77 @@
+https://gitlab.xiph.org/xiph/opusfile/-/merge_requests/42
+https://bugs.gentoo.org/879707
+
+From 9c7915c120c399a6a001c2a34e9040c9c5c9d340 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 22 Nov 2022 02:59:20 +0000
+Subject: [PATCH] m4: fix -Wstrict-protoypes
+
+In preparation for C23. Fixes the following error if Clang 16 is
+cranked up to be stricter:
+```
+-warning: a function declaration without a prototype is deprecated in all versions of C [-Wstrict-prototypes]
++error: a function declaration without a prototype is deprecated in all versions of C [-Werror,-Wstrict-prototypes]
+```
+
+Bug: https://bugs.gentoo.org/879701
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/m4/attributes.m4
++++ b/m4/attributes.m4
+@@ -39,7 +39,7 @@ AC_DEFUN([CC_CHECK_CFLAGS_SILENT], [
+ AC_CACHE_VAL(AS_TR_SH([cc_cv_cflags_$1]),
+ [ac_save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $1"
+- AC_LINK_IFELSE([AC_LANG_SOURCE([int main() { return 0; }])],
++ AC_LINK_IFELSE([AC_LANG_SOURCE([int main(void) { return 0; }])],
+ [eval "AS_TR_SH([cc_cv_cflags_$1])='yes'"],
+ [eval "AS_TR_SH([cc_cv_cflags_$1])='no'"])
+ CFLAGS="$ac_save_CFLAGS"
+@@ -89,7 +89,7 @@ AC_DEFUN([CC_CHECK_LDFLAGS], [
+ AS_TR_SH([cc_cv_ldflags_$1]),
+ [ac_save_LDFLAGS="$LDFLAGS"
+ LDFLAGS="$LDFLAGS $1"
+- AC_LINK_IFELSE([AC_LANG_SOURCE([int main() { return 1; }])],
++ AC_LINK_IFELSE([AC_LANG_SOURCE([int main(void) { return 1; }])],
+ [eval "AS_TR_SH([cc_cv_ldflags_$1])='yes'"],
+ [eval "AS_TR_SH([cc_cv_ldflags_$1])="])
+ LDFLAGS="$ac_save_LDFLAGS"
+@@ -165,16 +165,16 @@ AC_DEFUN([CC_CHECK_ATTRIBUTE], [
+ AC_DEFUN([CC_ATTRIBUTE_CONSTRUCTOR], [
+ CC_CHECK_ATTRIBUTE(
+ [constructor],,
+- [extern void foo();
+- void __attribute__((constructor)) ctor() { foo(); }],
++ [extern void foo(void);
++ void __attribute__((constructor)) ctor(void) { foo(); }],
+ [$1], [$2])
+ ])
+
+ AC_DEFUN([CC_ATTRIBUTE_DESTRUCTOR], [
+ CC_CHECK_ATTRIBUTE(
+ [destructor],,
+- [extern void foo();
+- void __attribute__((destructor)) dtor() { foo(); }],
++ [extern void foo(void);
++ void __attribute__((destructor)) dtor(void) { foo(); }],
+ [$1], [$2])
+ ])
+
+@@ -195,7 +195,7 @@ AC_DEFUN([CC_ATTRIBUTE_FORMAT_ARG], [
+ AC_DEFUN([CC_ATTRIBUTE_VISIBILITY], [
+ CC_CHECK_ATTRIBUTE(
+ [visibility_$1], [visibility("$1")],
+- [void __attribute__((visibility("$1"))) $1_function() { }],
++ [void __attribute__((visibility("$1"))) $1_function(void) { }],
+ [$2], [$3])
+ ])
+
+@@ -306,7 +306,7 @@ AC_DEFUN([CC_ATTRIBUTE_ALIGNED], [
+ CFLAGS="$CFLAGS $cc_cv_werror"
+ for cc_attribute_align_try in 64 32 16 8 4 2; do
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+- int main() {
++ int main(void) {
+ static char c __attribute__ ((aligned($cc_attribute_align_try))) = 0;
+ return c;
+ }])], [cc_cv_attribute_aligned=$cc_attribute_align_try; break])
+GitLab
diff --git a/media-libs/opusfile/opusfile-0.12-r1.ebuild b/media-libs/opusfile/opusfile-0.12-r1.ebuild
new file mode 100644
index 000000000000..0aab5f8e89cc
--- /dev/null
+++ b/media-libs/opusfile/opusfile-0.12-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A high-level decoding and seeking API for .opus files"
+HOMEPAGE="https://www.opus-codec.org/"
+SRC_URI="https://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc fixed-point +float +http static-libs"
+
+RDEPEND="
+ media-libs/libogg
+ media-libs/opus
+ http? (
+ dev-libs/openssl:=
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="^^ ( fixed-point float )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12-configure-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ # Drop once configure patch merged
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc)
+ $(use_enable fixed-point)\
+ $(use_enable float)
+ $(use_enable http)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}