summaryrefslogtreecommitdiff
path: root/media-libs/openpgl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-03 14:14:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-03 14:14:17 +0100
commita1d3b28d34c46d8e93a8286b1d3706a3e6c75fcc (patch)
treef67485eb22ea082a20dd18959601bfc77581195e /media-libs/openpgl
parent2df2e0ebc717aa53904c920c1a361423dfc3a5f7 (diff)
gentoo auto-resync : 03:04:2024 - 14:14:17
Diffstat (limited to 'media-libs/openpgl')
-rw-r--r--media-libs/openpgl/Manifest4
-rw-r--r--media-libs/openpgl/openpgl-0.5.0-r1.ebuild (renamed from media-libs/openpgl/openpgl-0.5.0.ebuild)25
-rw-r--r--media-libs/openpgl/openpgl-0.6.0.ebuild48
3 files changed, 66 insertions, 11 deletions
diff --git a/media-libs/openpgl/Manifest b/media-libs/openpgl/Manifest
index 3e7bcb1c95b4..43f0adb0b3a7 100644
--- a/media-libs/openpgl/Manifest
+++ b/media-libs/openpgl/Manifest
@@ -1,3 +1,5 @@
DIST openpgl-0.5.0.tar.gz 10767365 BLAKE2B 051b26c17300506dd20989ba9dc1aa83b0baf77c5f24650c74518ae56081b5a0ecca88c13d5d79a71cb0b6fa4a5b4841ee03e5223ec91ab16bb5655f2e52a9d7 SHA512 9b992ffa17ad6f9fcde48add5d9cc1e58be2daacd40478fb1babe0741a6c7a64f12f36c9c1f7d5ec6f79cdd847c082d39e03e58cfd9af1a903adca56f1ac19e1
-EBUILD openpgl-0.5.0.ebuild 1182 BLAKE2B 40fc93a5719594cc55eed9eed8755e2693af6a8e2235629752a3998cfe4f68187045ba37c1b37a6d07d55a68644571f3d436b771ed8da44794d871844d3c915f SHA512 347ef4d8905378fdf5ba76a18a8a680fc4425a50aee17087e9896f34206ec29a03755f1215077f5f513b49d98771cd3d0c7632feffa205cd69e495ed686e8689
+DIST openpgl-0.6.0.tar.gz 10824550 BLAKE2B a08f5469cce808c51eb64a619621de31923318a230e49ababad2140d00b53d3ad688e095c4f7aba1ac6ebfd874ed1357e4a501bee5f45a826c39cddbab4fa3cd SHA512 a40161d79e9f340e631eda9dedbabd9c71fb0184c65f45e0abcb64ce53289a65b7434c11678f845f76006a0ce579c4458a39200dc8caca1c455f18739488e173
+EBUILD openpgl-0.5.0-r1.ebuild 1332 BLAKE2B a4201721d7f5031bd47623f3f1d1c558f73532b85dcd1c1fba404a90687d7fd371b53af8d806fd8e26b589c3b2b7efb4cde805cb201cf6921a6abc278e60f0ad SHA512 5d1c71176e7b1bcfacb21f8f788347eaad8593f9535f1b63a582451adbf06e9b39ef10d5364fc1157e709ad156c9ee275bfda35d281f0838fbcdcc158fea42ae
+EBUILD openpgl-0.6.0.ebuild 1332 BLAKE2B a4201721d7f5031bd47623f3f1d1c558f73532b85dcd1c1fba404a90687d7fd371b53af8d806fd8e26b589c3b2b7efb4cde805cb201cf6921a6abc278e60f0ad SHA512 5d1c71176e7b1bcfacb21f8f788347eaad8593f9535f1b63a582451adbf06e9b39ef10d5364fc1157e709ad156c9ee275bfda35d281f0838fbcdcc158fea42ae
MISC metadata.xml 1011 BLAKE2B c88245ac6d49bf09e2a96754713dcf088ec1ba4700713d2551a8af4f9c509553edbde8e9775fb1bc410b2eec742df26527b07d5cd36194ae5a2b4c5c018b51b1 SHA512 ff6c48d3db9dfd2737410f5d689d08fcb49a062bc291eb0e5442851037723a701629c13d44929b6812df5098adda7695b1edbd1bae9ed3cca63cf04b710cfdf2
diff --git a/media-libs/openpgl/openpgl-0.5.0.ebuild b/media-libs/openpgl/openpgl-0.5.0-r1.ebuild
index 2ee1fc5e7840..79487e34b3a1 100644
--- a/media-libs/openpgl/openpgl-0.5.0.ebuild
+++ b/media-libs/openpgl/openpgl-0.5.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,13 +10,17 @@ HOMEPAGE="https://github.com/OpenPathGuidingLibrary/openpgl"
SRC_URI="https://github.com/OpenPathGuidingLibrary/openpgl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
-SLOT="0"
+SLOT="0/$(ver_cut 1-2)"
KEYWORDS="-* ~amd64 ~arm64"
X86_CPU_FLAGS=( sse4_2 avx2 avx512dq )
-CPU_FLAGS=( cpu_flags_arm_neon ${X86_CPU_FLAGS[@]/#/cpu_flags_x86_} )
-IUSE="${CPU_FLAGS[@]} debug"
-REQUIRED_USE="|| ( ${CPU_FLAGS[@]} )"
+CPU_FLAGS=( cpu_flags_arm_neon "${X86_CPU_FLAGS[@]/#/cpu_flags_x86_}" )
+IUSE="${CPU_FLAGS[*]} debug"
+
+REQUIRED_USE="
+ amd64? ( || ( ${X86_CPU_FLAGS[*]/#/cpu_flags_x86_} ) )
+ arm64? ( cpu_flags_arm_neon )
+"
RDEPEND="
media-libs/embree:=
@@ -26,18 +30,19 @@ DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(
- -DOPENPGL_ISA_AVX2=$(usex cpu_flags_x86_avx2)
- -DOPENPGL_ISA_AVX512=$(usex cpu_flags_x86_avx512dq)
- -DOPENPGL_ISA_SSE4=$(usex cpu_flags_x86_sse4_2)
+ -DOPENPGL_ISA_SSE4="$(usex cpu_flags_x86_sse4_2)"
+ -DOPENPGL_ISA_AVX2="$(usex cpu_flags_x86_avx2)"
+ -DOPENPGL_ISA_AVX512="$(usex cpu_flags_x86_avx512dq)"
+ -DOPENPGL_ISA_NEON="$(usex cpu_flags_arm_neon)"
# TODO look into neon 2x support
- -DOPENPGL_ISA_NEON=$(usex cpu_flags_arm_neon)
+ # -DOPENPGL_ISA_NEON2X="$(usex cpu_flags_arm_neon2x)"
)
# This is currently needed on arm64 to get the NEON SIMD wrapper to compile the code successfully
use cpu_flags_arm_neon && append-flags -flax-vector-conversions
# Disable asserts
- append-cppflags $(usex debug '' '-DNDEBUG')
+ append-cppflags "$(usex debug '' '-DNDEBUG')"
cmake_src_configure
}
diff --git a/media-libs/openpgl/openpgl-0.6.0.ebuild b/media-libs/openpgl/openpgl-0.6.0.ebuild
new file mode 100644
index 000000000000..79487e34b3a1
--- /dev/null
+++ b/media-libs/openpgl/openpgl-0.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Open Path Guiding Library"
+HOMEPAGE="https://github.com/OpenPathGuidingLibrary/openpgl"
+SRC_URI="https://github.com/OpenPathGuidingLibrary/openpgl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="-* ~amd64 ~arm64"
+
+X86_CPU_FLAGS=( sse4_2 avx2 avx512dq )
+CPU_FLAGS=( cpu_flags_arm_neon "${X86_CPU_FLAGS[@]/#/cpu_flags_x86_}" )
+IUSE="${CPU_FLAGS[*]} debug"
+
+REQUIRED_USE="
+ amd64? ( || ( ${X86_CPU_FLAGS[*]/#/cpu_flags_x86_} ) )
+ arm64? ( cpu_flags_arm_neon )
+"
+
+RDEPEND="
+ media-libs/embree:=
+ dev-cpp/tbb:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENPGL_ISA_SSE4="$(usex cpu_flags_x86_sse4_2)"
+ -DOPENPGL_ISA_AVX2="$(usex cpu_flags_x86_avx2)"
+ -DOPENPGL_ISA_AVX512="$(usex cpu_flags_x86_avx512dq)"
+ -DOPENPGL_ISA_NEON="$(usex cpu_flags_arm_neon)"
+ # TODO look into neon 2x support
+ # -DOPENPGL_ISA_NEON2X="$(usex cpu_flags_arm_neon2x)"
+ )
+
+ # This is currently needed on arm64 to get the NEON SIMD wrapper to compile the code successfully
+ use cpu_flags_arm_neon && append-flags -flax-vector-conversions
+
+ # Disable asserts
+ append-cppflags "$(usex debug '' '-DNDEBUG')"
+
+ cmake_src_configure
+}