summaryrefslogtreecommitdiff
path: root/media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild')
-rw-r--r--media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild b/media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..b80235b948aa
--- /dev/null
+++ b/media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="OpenEXR CTL libraries"
+HOMEPAGE="https://sourceforge.net/projects/ampasctl"
+SRC_URI="mirror://sourceforge/ampasctl/${P}.tar.gz"
+
+LICENSE="AMPAS"
+SLOT="0"
+KEYWORDS="amd64 hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/ilmbase-2.0.1:=
+ >=media-libs/openexr-2.0.1:=
+ media-libs/ctl:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-{,configure_}gcc43.patch \
+ "${FILESDIR}"/${P}-pkgconfig.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-namespace.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}