summaryrefslogtreecommitdiff
path: root/media-libs/mutagen/mutagen-1.43.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-libs/mutagen/mutagen-1.43.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-libs/mutagen/mutagen-1.43.0.ebuild')
-rw-r--r--media-libs/mutagen/mutagen-1.43.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/mutagen/mutagen-1.43.0.ebuild b/media-libs/mutagen/mutagen-1.43.0.ebuild
new file mode 100644
index 000000000000..43af0777006e
--- /dev/null
+++ b/media-libs/mutagen/mutagen-1.43.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
+inherit distutils-r1
+
+DESCRIPTION="Audio metadata tag reader and writer implemented in pure Python"
+HOMEPAGE="https://github.com/quodlibet/mutagen https://pypi.org/project/mutagen/"
+SRC_URI="https://github.com/quodlibet/mutagen/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# TODO: Missing support for >=dev-python/eyeD3-0.7 API
+# test? ( >=dev-python/eyeD3-0.7 )
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+python_test() {
+ esetup.py test --no-quality
+}
+
+python_install_all() {
+ local DOCS=( NEWS README.rst )
+ use doc && local HTML_DOCS=( docs/_build/. )
+ distutils-r1_python_install_all
+}