summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /media-libs/mesa/mesa-9999.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild33
1 files changed, 20 insertions, 13 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index de737e259d61..b28120fdcc83 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -38,7 +38,7 @@ done
IUSE="${IUSE_VIDEO_CARDS}
+classic d3d9 debug +dri3 +egl +gallium +gbm gles1 +gles2 +libglvnd +llvm
lm_sensors opencl osmesa pax_kernel selinux test unwind vaapi valgrind
- vdpau vulkan vulkan-overlay wayland xa xvmc"
+ vdpau vulkan vulkan-overlay wayland +X xa xvmc"
REQUIRED_USE="
d3d9? ( dri3 || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
@@ -68,6 +68,8 @@ REQUIRED_USE="
video_cards_virgl? ( gallium )
video_cards_vivante? ( gallium gbm )
video_cards_vmware? ( gallium )
+ xa? ( X )
+ xvmc? ( X )
"
LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.99"
@@ -75,13 +77,6 @@ RDEPEND="
!app-eselect/eselect-mesa
>=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2:=[${MULTILIB_USEDEP}]
- >=x11-libs/libxshmfence-1.1:=[${MULTILIB_USEDEP}]
- >=x11-libs/libXdamage-1.1.4-r1:=[${MULTILIB_USEDEP}]
- >=x11-libs/libXext-1.3.2:=[${MULTILIB_USEDEP}]
- >=x11-libs/libXxf86vm-1.1.3:=[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.13:=[${MULTILIB_USEDEP}]
- x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
libglvnd? (
media-libs/libglvnd[${MULTILIB_USEDEP}]
!app-eselect/eselect-opengl
@@ -126,6 +121,15 @@ RDEPEND="
)
video_cards_i915? ( ${LIBDRM_DEPSTRING}[video_cards_intel] )
vulkan-overlay? ( dev-util/glslang:0=[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libX11-1.6.2:=[${MULTILIB_USEDEP}]
+ >=x11-libs/libxshmfence-1.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/libXdamage-1.1.4-r1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2:=[${MULTILIB_USEDEP}]
+ >=x11-libs/libXxf86vm-1.1.3:=[${MULTILIB_USEDEP}]
+ >=x11-libs/libxcb-1.13:=[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
+ )
"
for card in ${RADEON_CARDS}; do
RDEPEND="${RDEPEND}
@@ -144,9 +148,10 @@ RDEPEND="${RDEPEND}
# 1. List all the working slots (with min versions) in ||, newest first.
# 2. Update the := to specify *max* version, e.g. < 10.
# 3. Specify LLVM_MAX_SLOT, e.g. 9.
-LLVM_MAX_SLOT="9"
+LLVM_MAX_SLOT="10"
LLVM_DEPSTR="
|| (
+ sys-devel/llvm:10[${MULTILIB_USEDEP}]
sys-devel/llvm:9[${MULTILIB_USEDEP}]
sys-devel/llvm:8[${MULTILIB_USEDEP}]
sys-devel/llvm:7[${MULTILIB_USEDEP}]
@@ -212,8 +217,10 @@ unset {LLVM,CLANG}_DEPSTR{,_AMDGPU}
DEPEND="${RDEPEND}
valgrind? ( dev-util/valgrind )
- x11-libs/libXrandr[${MULTILIB_USEDEP}]
- x11-base/xorg-proto
+ X? (
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-base/xorg-proto
+ )
"
BDEPEND="
${PYTHON_DEPS}
@@ -349,7 +356,7 @@ multilib_src_configure() {
fi
fi
- emesonargs+=( -Dplatforms=x11,surfaceless$(use wayland && echo ",wayland")$(use gbm && echo ",drm") )
+ emesonargs+=( -Dplatforms=surfaceless$(use X && echo ",x11")$(use wayland && echo ",wayland")$(use gbm && echo ",drm") )
if use gallium; then
emesonargs+=(
@@ -471,7 +478,7 @@ multilib_src_configure() {
emesonargs+=(
$(meson_use test build-tests)
- -Dglx=dri
+ -Dglx=$(usex X dri disabled)
-Dshared-glapi=true
$(meson_use dri3)
$(meson_use egl)