summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /media-libs/mesa/mesa-9999.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild38
1 files changed, 8 insertions, 30 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 2fd5700404f0..c50d8550e51c 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -67,7 +67,7 @@ REQUIRED_USE="
video_cards_vmware? ( gallium )
"
-LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.93"
+LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.96"
RDEPEND="
!app-eselect/eselect-mesa
>=app-eselect/eselect-opengl-1.3.0
@@ -95,7 +95,7 @@ RDEPEND="
)
lm_sensors? ( sys-apps/lm_sensors:=[${MULTILIB_USEDEP}] )
opencl? (
- app-eselect/eselect-opencl
+ dev-libs/ocl-icd[khronos-headers]
dev-libs/libclc
virtual/libelf:0=[${MULTILIB_USEDEP}]
)
@@ -424,14 +424,12 @@ multilib_src_configure() {
fi
gallium_enable video_cards_freedreno freedreno
- # opencl stuff
- if use opencl; then
- emesonargs+=(
- -Dgallium-opencl="$(usex opencl standalone disabled)"
- )
- fi
-
gallium_enable video_cards_virgl virgl
+
+ # opencl stuff
+ emesonargs+=(
+ -Dgallium-opencl="$(usex opencl icd disabled)"
+ )
fi
if use vulkan; then
@@ -488,21 +486,6 @@ multilib_src_compile() {
multilib_src_install() {
meson_src_install
-
- if use opencl; then
- ebegin "Moving Gallium/Clover OpenCL implementation for dynamic switching"
- local cl_dir="/usr/$(get_libdir)/OpenCL/vendors/mesa"
- dodir ${cl_dir}/{lib,include}
- if [ -f "${ED}/usr/$(get_libdir)/libOpenCL.so" ]; then
- mv -f "${ED}"/usr/$(get_libdir)/libOpenCL.so* \
- "${ED}"${cl_dir}
- fi
- if [ -f "${ED}/usr/include/CL/opencl.h" ]; then
- mv -f "${ED}"/usr/include/CL \
- "${ED}"${cl_dir}/include
- fi
- eend $?
- fi
}
multilib_src_install_all() {
@@ -517,11 +500,6 @@ pkg_postinst() {
# Switch to the xorg implementation.
echo
eselect opengl set --use-old ${OPENGL_DIR}
-
- # Switch to mesa opencl
- if use opencl; then
- eselect opencl set --use-old ${PN}
- fi
}
# $1 - VIDEO_CARDS flag (check skipped for "--")