summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
commit0706fc6986773f4e4d391deff4ad5143c464ea4e (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /media-libs/mesa/mesa-9999.ebuild
parentaa3411e241a201d53a2689766fe419f2756819f3 (diff)
Revert "gentoo resync : 24.03.2019"
This reverts commit aa3411e241a201d53a2689766fe419f2756819f3.
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 802aa20c7f78..ae4a7c1da5f8 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -30,7 +30,7 @@ RESTRICT="
"
RADEON_CARDS="r100 r200 r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 intel iris nouveau vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 imx intel iris nouveau vc4 virgl vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -54,6 +54,7 @@ REQUIRED_USE="
video_cards_i915? ( || ( classic gallium ) )
video_cards_i965? ( classic )
video_cards_iris? ( gallium )
+ video_cards_imx? ( gallium video_cards_vivante )
video_cards_nouveau? ( || ( classic gallium ) )
video_cards_radeon? ( || ( classic gallium )
gallium? ( x86? ( llvm ) amd64? ( llvm ) ) )
@@ -399,16 +400,11 @@ multilib_src_configure() {
emesonargs+=(-Dgallium-xvmc=false)
fi
- if use video_cards_freedreno ||
- use video_cards_vc4 ||
- use video_cards_vivante; then
- gallium_enable -- kmsro
- fi
-
gallium_enable video_cards_vc4 vc4
gallium_enable video_cards_vivante etnaviv
gallium_enable video_cards_vmware svga
gallium_enable video_cards_nouveau nouveau
+ gallium_enable video_cards_imx imx
# Only one i915 driver (classic vs gallium). Default to classic.
if ! use classic; then