summaryrefslogtreecommitdiff
path: root/media-libs/lv2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-09 23:42:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-09 23:42:15 +0100
commit12de738b83927a4b71c3ad067edbb6279d15b368 (patch)
tree87b2ef3927262a0aba7a923512909bdbadd71b8b /media-libs/lv2
parent7b7a5ff63901698b7b993201e07bcaf8d0e5db2f (diff)
gentoo auto-resync : 09:05:2023 - 23:42:14
Diffstat (limited to 'media-libs/lv2')
-rw-r--r--media-libs/lv2/Manifest3
-rw-r--r--media-libs/lv2/files/lv2-1.18.10-tests-optional.patch53
-rw-r--r--media-libs/lv2/lv2-1.18.10.ebuild10
3 files changed, 64 insertions, 2 deletions
diff --git a/media-libs/lv2/Manifest b/media-libs/lv2/Manifest
index 1e9de2ec6db4..14d24f3e3db3 100644
--- a/media-libs/lv2/Manifest
+++ b/media-libs/lv2/Manifest
@@ -1,4 +1,5 @@
+AUX lv2-1.18.10-tests-optional.patch 1245 BLAKE2B 1b77b64a9b613bf2299cb4bfc8f53f360a2c4b12754809ea38dca5f4d40c0a3cc636ce16131f50fbb1730af535de96749873cde7e34ecceb1c055ef614aad70c SHA512 000fe518c276d3e25558ccf76a9fd34ac4fb8c5222b94a8d47fb517496a5020963b02136b398116776e66d25920672dd57f1c3d88cbc7cfc7bc26107367aea93
AUX lv2-1.18.6-add-missing-lv2.h.patch 401 BLAKE2B 36380468184705a7f0076e293af0c69c60815676046749f2c6bf41c8e0ad747115c673671d67bfc2882d9782288f9b7627b9dafadb023063bc478bbfa0c7c86d SHA512 bdc404792a522c2bca25ca243c469a4d109b253a761d32981055469314b23e3bb470c60b46d75b6ee1f077c7d978b51dfb2d95671cdb1eb6fd83aad01c6df4d6
DIST lv2-1.18.10.tar.xz 237380 BLAKE2B 72f9bc50ebac5d71279e0616bb1eb3c2a6748a28ff68988294135b18c7adc68c46a52b4698faf79f633768bf850d5052128a9f84b90aa9b5f9a56721acaf04c3 SHA512 ab4bcf593f633b1ed16c0eb6aa4525458a00655ef9c87619bf85eaa966f8fd094a8e871b825f679e0d97923f8bbbf11841ff467022390ca2f1a5b5f66ccd5d1b
-EBUILD lv2-1.18.10.ebuild 1451 BLAKE2B 8204f177dd7b532c74afc318518e9d57a89a1a2524438eba108cde294db393cb806d731dc251c1fde48af05fd615a0f63505263e2889d1c8012cf55a3c9fa6e9 SHA512 845a099e1efa87d8de80312760a24dfdd668bcbb3b3504c4f341b8973f9e5b9dac4e5f325fd2c7aff9c8e05198cb35f1c6f96db4343f0379827b5c5b1c00c576
+EBUILD lv2-1.18.10.ebuild 1625 BLAKE2B 5bdfd43023662c9f7d3dff6a7eef4fe7d7577ee9e54aedcc2f3251396b8637a2cfcf72e09172b9376e65f590a146c3ff5476200487480b6156c6f21d05373012 SHA512 91916d26365ac0c3494d4f84bc9f3c7934a768de1f9aca3de97facc3bb8b69409583333664fa874c5320e44623ad068d2a1635d74549fbf27ee4258ad8ef533d
MISC metadata.xml 466 BLAKE2B dadec1c479bf528c62768913e86892f085a1879288abe0b55dcab28ec54583629445c38efce1deb20cfcfdeeb1d6989e10295c8c2014874b83e742e08db26089 SHA512 bfa47b7b47c935f8d2ff2f9d99fd56bb1cc5e98467d18636e73dc59e4ed7f0fa795c05e0bfd27a3146bfe615b4254c67960b06465989dd3d9524894b1063c63c
diff --git a/media-libs/lv2/files/lv2-1.18.10-tests-optional.patch b/media-libs/lv2/files/lv2-1.18.10-tests-optional.patch
new file mode 100644
index 000000000000..dca3540cf171
--- /dev/null
+++ b/media-libs/lv2/files/lv2-1.18.10-tests-optional.patch
@@ -0,0 +1,53 @@
+https://gitlab.com/lv2/lv2/-/commit/8726bffa337e6374b04d0739df2812798b2c8858
+
+From 8726bffa337e6374b04d0739df2812798b2c8858 Mon Sep 17 00:00:00 2001
+From: David Robillard <d@drobilla.net>
+Date: Sat, 19 Nov 2022 17:49:14 -0500
+Subject: [PATCH] Avoid test directory entirely if tests are disabled
+
+--- a/meson.build
++++ b/meson.build
+@@ -346,7 +346,9 @@ endif
+ subdir('util')
+
+ # Data and build tests
+-subdir('test')
++if not get_option('tests').disabled()
++ subdir('test')
++endif
+
+ if not meson.is_subproject()
+ summary('Tests', not get_option('tests').disabled(), bool_yn: true)
+--- a/test/meson.build
++++ b/test/meson.build
+@@ -122,17 +122,15 @@ test_names = [
+ ]
+
+ # Build and run tests
+-if not get_option('tests').disabled()
+- foreach test_name : test_names
+- test(
++foreach test_name : test_names
++ test(
++ test_name,
++ executable(
+ test_name,
+- executable(
+- test_name,
+- files('test_@0@.c'.format(test_name)),
+- c_args: c_suppressions,
+- dependencies: lv2_dep,
+- ),
+- suite: 'unit',
+- )
+- endforeach
+-endif
++ files('test_@0@.c'.format(test_name)),
++ c_args: c_suppressions,
++ dependencies: lv2_dep,
++ ),
++ suite: 'unit',
++ )
++endforeach
+--
+GitLab
diff --git a/media-libs/lv2/lv2-1.18.10.ebuild b/media-libs/lv2/lv2-1.18.10.ebuild
index 4ebd59a52b56..575c13e2e43e 100644
--- a/media-libs/lv2/lv2-1.18.10.ebuild
+++ b/media-libs/lv2/lv2-1.18.10.ebuild
@@ -15,7 +15,8 @@ SRC_URI="https://lv2plug.in/spec/${P}.tar.xz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
-IUSE="doc plugins"
+IUSE="doc plugins test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
BDEPEND="
@@ -24,6 +25,11 @@ BDEPEND="
app-doc/doxygen
dev-python/rdflib
)
+ test? (
+ dev-libs/serd
+ dev-libs/sord[tools]
+ dev-python/rdflib
+ )
"
CDEPEND="
${PYTHON_DEPS}
@@ -48,6 +54,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-1.18.6-add-missing-lv2.h.patch"
+ "${FILESDIR}/${P}-tests-optional.patch"
)
src_prepare() {
@@ -62,6 +69,7 @@ multilib_src_configure() {
-Dlv2dir="${EPREFIX}"/usr/$(get_libdir)/lv2
$(meson_native_use_feature doc docs)
$(meson_feature plugins)
+ $(meson_feature test tests)
)
meson_src_configure