summaryrefslogtreecommitdiff
path: root/media-libs/lilv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-15 08:27:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-15 08:27:50 +0100
commit49d7633bbfe37c8e50c9cd1815c4210ca0a38d49 (patch)
treedf979468a5560d697f1ce8da51e8fa9b5defae4d /media-libs/lilv
parent152a6bc119e05c6c6da85b2fce57feb8c31d80b1 (diff)
gentoo auto-resync : 15:08:2022 - 08:27:50
Diffstat (limited to 'media-libs/lilv')
-rw-r--r--media-libs/lilv/Manifest2
-rw-r--r--media-libs/lilv/lilv-0.24.18.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/media-libs/lilv/Manifest b/media-libs/lilv/Manifest
index 0b2b5d249bd1..9bb760d6d3b3 100644
--- a/media-libs/lilv/Manifest
+++ b/media-libs/lilv/Manifest
@@ -1,5 +1,7 @@
DIST lilv-0.24.14.tar.bz2 428004 BLAKE2B bc84fe5a4bf34f88ea7f9c09cb3168186f7f0fd2f3f23b08f55100502d959fd74fe7e1c6d9307772b1983fbeedde100f75d6751e9bf92a9663aaaa115ca0770c SHA512 f266e91f3cbc325c25dd7d08bde5033091cb3072c2dcb1490e9474f562b798dbc71c45ca7d971ed4dfd6bb16f5f6725ae242a58c4486684b71350e73f1469f47
DIST lilv-0.24.16.tar.xz 117928 BLAKE2B c3e7e9c55f2c2ebe8a02181cd2e11d3413e69a7327e36f6a00b8598174da9f1a8187bd093bc6734cf8057f89b66d8b88bdca8b0e740bbd99b279d9d94ef8da33 SHA512 0e66411a5130771c6440f02ecaf33284ece55ac525d7487436936bca576fa5f5a51a358e50a4b354a927132bdc2b372d6919879514e7c6a679e18f7c0af0178e
+DIST lilv-0.24.18.tar.xz 118216 BLAKE2B c1d191a8513776b4e783f05076b8a8d5a20866e734527ff84e04d970d190b26d2c922aa6f7ba346632caea47daa265c1008d9295c3f0e41f85227103337ccd1f SHA512 eece846338403ba3e7c366024511d33bd5e399d3b1e6871d04ec3907540a9e3541ab7b0445bf17cf61c5779c5263f1ef23eadefb6411a2e4be8d79464a5b873e
EBUILD lilv-0.24.14.ebuild 1776 BLAKE2B 1cd04755b543809c7ec44ec4e3295784398d86213a9dc99fd26fdabea8ee0e72ba11eb1d56105a11360151d0cd83203ae86e590590b29d192701c71ef5c2dfb8 SHA512 a836bdb1fe475aab2664c3fb46889b1b24846396abb08a3e396928afa3579ca6daf6126f1e6a85f75209c65525fa195cfea8182f83f6161b430187d7959126cc
EBUILD lilv-0.24.16.ebuild 1778 BLAKE2B b5675fbd17c3253e19eb84e4c24df336e7520c8208406f4764639ae5c67435f8a3c350db37fc2e75630e3937716175badcfdd2837c18b585362267eee0199365 SHA512 193ab65ac1a39678a63bf4283afa8690d527cabdcbb2f9669430edf5728cb1d2e484a565637b688ea888ddb6d0b0dcb3913ea603ce1c1a8f24643e17f9823cfc
+EBUILD lilv-0.24.18.ebuild 1778 BLAKE2B b5675fbd17c3253e19eb84e4c24df336e7520c8208406f4764639ae5c67435f8a3c350db37fc2e75630e3937716175badcfdd2837c18b585362267eee0199365 SHA512 193ab65ac1a39678a63bf4283afa8690d527cabdcbb2f9669430edf5728cb1d2e484a565637b688ea888ddb6d0b0dcb3913ea603ce1c1a8f24643e17f9823cfc
MISC metadata.xml 684 BLAKE2B 82fdd1a88f5487cfa131221c915a77c19e04d3643fab9c8a9ea702920bbfce881c93f727e560e68532f583060a876407a412e3632a8f84cd30457a6c578f0524 SHA512 e1788982d4cc5c782cad4a3efbc93f7bc4560d45c72809f7c28df377ab7e38774844e013c6bc4859ecabf2cb654d0a89d1f7823d7712ab493c559f9ee4955ee0
diff --git a/media-libs/lilv/lilv-0.24.18.ebuild b/media-libs/lilv/lilv-0.24.18.ebuild
new file mode 100644
index 000000000000..4ef4e590a74d
--- /dev/null
+++ b/media-libs/lilv/lilv-0.24.18.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit meson-multilib python-single-r1 bash-completion-r1
+
+DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://drobilla.net/software/lilv/"
+SRC_URI="http://download.drobilla.net/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc python test tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ dev-python/sphinx_lv2_theme
+ )
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/serd[${MULTILIB_USEDEP}]
+ dev-libs/sord[${MULTILIB_USEDEP}]
+ media-libs/libsndfile
+ media-libs/lv2[${MULTILIB_USEDEP}]
+ media-libs/sratom[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ default
+
+ # fix doc installation path
+ sed -iE "s%install_dir: docdir / 'lilv-0',%install_dir: docdir / '${PF}',%g" doc/c/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_feature doc docs)
+ $(meson_feature python bindings_py)
+ $(meson_feature test tests)
+ $(meson_feature tools)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+ python_optimize
+}
+
+mutlilib_src_install_all() {
+ local DOCS=( AUTHORS NEWS README.md )
+ einstalldocs
+
+ sed -i "/lv2jack/d" utils/lilv.bash_completion
+ newbashcomp utils/lilv.bash_completion lv2info
+
+ dodir /etc/env.d
+ echo "LV2_PATH=${EPREFIX}/usr/$(get_libdir)/lv2" > "${ED}/etc/env.d/60lv2"
+}