summaryrefslogtreecommitdiff
path: root/media-libs/lilv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-24 10:45:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-24 10:45:40 +0000
commit1804d2ae908b26fe4e3d3a38646c7d6ffa733d92 (patch)
tree6f5cdff53cb2fde48a01817379124dc476b3742d /media-libs/lilv
parent2fa0c8dbba3b2455531e5616eed64f2fe66cb58b (diff)
gentoo auto-resync : 24:01:2024 - 10:45:40
Diffstat (limited to 'media-libs/lilv')
-rw-r--r--media-libs/lilv/Manifest2
-rw-r--r--media-libs/lilv/lilv-0.24.24.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/lilv/Manifest b/media-libs/lilv/Manifest
index 3e5d1827cf28..62da57494aae 100644
--- a/media-libs/lilv/Manifest
+++ b/media-libs/lilv/Manifest
@@ -1,3 +1,5 @@
DIST lilv-0.24.22.tar.xz 105504 BLAKE2B bd9df20d95ffa921615fb21deed4bc354158219aa51125fc00351aa5ca2f480f9d10d8c867003a373b47eea145c21bb8d0bfc86d53eb1d04d281e1df2fc4a0f2 SHA512 cd771db89919a11e258d12b43674d7174645a4369f5d3a5168b1217c0a87795926dd7db5304e81cb27eb30477198ac42e6e4931d40fcda833bf70ef75acc558f
+DIST lilv-0.24.24.tar.xz 105684 BLAKE2B 4228248e8dbee228cee193e259d95b2e66f9f2e3516702dfad0dc126273076230274538c32a857ae9ad8a58545bbf48e7791254441dd4d6e537715de9e5e5be6 SHA512 93a3842a5e000a9c59bf3493c2c10df35a803a7edf6cff09f43e155a7e83d0c7c81bc24a6243828dc141d30187c3f60ef9799f319f72e5b6c3e2d022de757185
EBUILD lilv-0.24.22-r1.ebuild 1709 BLAKE2B a70c20e79d74d576f170d2a77498ce44112992cdec9d27732b44ef252b3db65e29585c39aa5e0ce7733d67c953787e82e5cd90e0cd8124fd3d9b21ff0ccb87e4 SHA512 ceffb9ebfb25acd45981643f3a07847a225a5bc440b889d00f9a16efe07955b0ad1f3f2e1d0b2307ceacc8e0d5e35b35715c79fa309fe10edeb1df5fd145ed9e
+EBUILD lilv-0.24.24.ebuild 1715 BLAKE2B 360dcdf4dd279f337b4e0ad79f2c2983f5a49cda04d1c84b7a26d02afde2ddd6d0dcb07acd49f702f429cb720e5ba15408bf1444bfe1d66aefcf7e9ddda99a40 SHA512 d4f0a658f798bb81940b39984ecca276779288b97ce52aa247e6378009d4b081df8e99d6fab336b08c3436dccddc6e323750dcc216dbc06408ee898115972c30
MISC metadata.xml 694 BLAKE2B 95d755914e68f4f5f1a3b5e04bea2cdb2cb2068d03e83f5d4dfba74e72b124e3db964c634c9f092e1f7201798ad405724a9d29190ce2086f39a9e674bdab8d2e SHA512 671fc5f358b6e5bf4ea212af706ea6c4695f399866050d9822c05dea0f8467c8b8f207887615397a7e686f399be809ab31367dfeb1a6ad62ff2680480d591f47
diff --git a/media-libs/lilv/lilv-0.24.24.ebuild b/media-libs/lilv/lilv-0.24.24.ebuild
new file mode 100644
index 000000000000..15218dd469f1
--- /dev/null
+++ b/media-libs/lilv/lilv-0.24.24.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit meson-multilib python-single-r1
+
+DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="https://drobilla.net/software/lilv.html"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc python test tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-text/doxygen
+ dev-python/sphinx
+ dev-python/sphinx-lv2-theme
+ dev-python/sphinxygen
+ )
+"
+# Take care on bumps to check minimum versions!
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/serd-0.30.10[${MULTILIB_USEDEP}]
+ >=dev-libs/sord-0.16.16[${MULTILIB_USEDEP}]
+ >=dev-libs/zix-0.4.0[${MULTILIB_USEDEP}]
+ media-libs/libsndfile
+ >=media-libs/lv2-1.18.2[${MULTILIB_USEDEP}]
+ >=media-libs/sratom-0.6.10[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ default
+
+ # fix doc installation path
+ sed -iE "s/versioned_name/'${PF}'/g" doc/html/meson.build doc/singlehtml/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_feature doc docs)
+ $(meson_feature python bindings_py)
+ $(meson_feature test tests)
+ $(meson_feature tools)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+ python_optimize
+}
+
+multilib_src_install_all() {
+ local DOCS=( AUTHORS NEWS README.md )
+ einstalldocs
+
+ newenvd - 60lv2 <<-EOF
+ LV2_PATH=${EPREFIX}/usr/$(get_libdir)/lv2
+ EOF
+}