summaryrefslogtreecommitdiff
path: root/media-libs/lilv/lilv-0.24.18-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 09:13:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 09:13:50 +0000
commit0bb8253b38dc8638a46b66ba909c1bfd1054e1ef (patch)
treed408176c81eb4f81d8b3e95a66abc8eedec620e4 /media-libs/lilv/lilv-0.24.18-r1.ebuild
parent1f709ed82b8014b4c156f87c66cee7d0d1d3905d (diff)
gentoo auto-resync : 04:11:2022 - 09:13:50
Diffstat (limited to 'media-libs/lilv/lilv-0.24.18-r1.ebuild')
-rw-r--r--media-libs/lilv/lilv-0.24.18-r1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/media-libs/lilv/lilv-0.24.18-r1.ebuild b/media-libs/lilv/lilv-0.24.18-r1.ebuild
deleted file mode 100644
index c413f9e975f5..000000000000
--- a/media-libs/lilv/lilv-0.24.18-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE='threads(+)'
-
-inherit meson-multilib python-single-r1
-
-DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
-HOMEPAGE="https://drobilla.net/software/lilv.html"
-SRC_URI="https://download.drobilla.net/${P}.tar.xz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE="doc python test tools"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-python/sphinx
- dev-python/sphinx_lv2_theme
- )
-"
-RDEPEND="
- ${PYTHON_DEPS}
- dev-libs/serd[${MULTILIB_USEDEP}]
- dev-libs/sord[${MULTILIB_USEDEP}]
- media-libs/libsndfile
- media-libs/lv2[${MULTILIB_USEDEP}]
- media-libs/sratom[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- python_setup
-}
-
-src_prepare() {
- default
-
- # fix doc installation path
- sed -iE "s%install_dir: docdir / 'lilv-0',%install_dir: docdir / '${PF}',%g" doc/c/meson.build || die
-}
-
-multilib_src_configure() {
- local emesonargs=(
- $(meson_native_use_feature doc docs)
- $(meson_feature python bindings_py)
- $(meson_feature test tests)
- $(meson_feature tools)
- )
-
- meson_src_configure
-}
-
-multilib_src_install() {
- meson_src_install
- python_optimize
-}
-
-multilib_src_install_all() {
- local DOCS=( AUTHORS NEWS README.md )
- einstalldocs
-
- newenvd - 60lv2 <<-EOF
- LV2_PATH=${EPREFIX}/usr/$(get_libdir)/lv2
- EOF
-}