summaryrefslogtreecommitdiff
path: root/media-libs/libxspf/libxspf-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libxspf/libxspf-1.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libxspf/libxspf-1.2.0.ebuild')
-rw-r--r--media-libs/libxspf/libxspf-1.2.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/libxspf/libxspf-1.2.0.ebuild b/media-libs/libxspf/libxspf-1.2.0.ebuild
new file mode 100644
index 000000000000..a7c71fb4d12b
--- /dev/null
+++ b/media-libs/libxspf/libxspf-1.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Playlist handling library"
+HOMEPAGE="http://libspiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libspiff/${P}.tar.bz2"
+
+LICENSE="BSD LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc static-libs test"
+
+RDEPEND=">=dev-libs/expat-2
+ >=dev-libs/uriparser-0.7.5"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.5.8
+ media-gfx/graphviz
+ dev-qt/qthelp:4
+ )
+ test? ( >=dev-util/cpptest-1.1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ export XDG_CONFIG_HOME="${T}" #398881#c2
+
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable static-libs static) \
+ $(use_enable test) \
+ $(use_enable doc)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}