summaryrefslogtreecommitdiff
path: root/media-libs/libvorbis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-18 04:54:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-18 04:54:42 +0000
commit5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (patch)
treec968fff3108e2b4d88e4e564a56bfd066f170573 /media-libs/libvorbis
parent1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (diff)
gentoo resync : 18.03.2018
Diffstat (limited to 'media-libs/libvorbis')
-rw-r--r--media-libs/libvorbis/Manifest2
-rw-r--r--media-libs/libvorbis/libvorbis-1.3.6.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/libvorbis/Manifest b/media-libs/libvorbis/Manifest
index 3dcb39d29bc6..244fdb097e9c 100644
--- a/media-libs/libvorbis/Manifest
+++ b/media-libs/libvorbis/Manifest
@@ -1,3 +1,5 @@
DIST libvorbis-1.3.5.tar.xz 1193144 BLAKE2B 8f1b7dc9e25147fdb6304e2630a0f90a8766338b4566e9ad2f288f8e6cbcfa98b9d471dbd33e98882711319c74d5ebe78728b4c7376e07b2ab5b08a3b67c74a1 SHA512 f18f32edc43f65fea2dd4133e2828a0ced9e5b0797c4569bd26989fc1409ad599359e7c796bffc082ad36189f9722c7b38837384cea66d217beac8b425299ef8
+DIST libvorbis-1.3.6.tar.xz 1195388 BLAKE2B 9fc1dd125fdecb95687ea159b75cd66eed21329ec0795a3050e52e6cc58e1aac7b084ca25c4e52ca6f251ff474f6d71a716c0fbb2367beda8eb6a51a8fa9049a SHA512 a5d990bb88db2501b16f8eaee9f2ecb599cefd7dab2134d16538d8905263a972157c7671867848c2a8a358bf5e5dbc7721205ece001032482f168be7bda4f132
EBUILD libvorbis-1.3.5.ebuild 1142 BLAKE2B 2740755716c6975599af41c8038cf11eebe2d83e1ebe3733acecea604849cf538a68728fe21efd85b1c690e62c0c003f51840b2a500e34c5beb01e1baa9335bd SHA512 e3b701b9ca57bb7600791721b06af1586614416011ba8bcefd55f2b556eda41e936ab8991f904f98190e9972dbd1bf897a20243dada0e0fb341bb9c7d205ba40
+EBUILD libvorbis-1.3.6.ebuild 1151 BLAKE2B 218f38dd9fb2ef1d1dfeedfe31329a84783b862c4f0fdd97a523e7807d6ebfab1fccab35925818b83c1c494125f23efd3ee844f9e5e576b5bfe5283e70cd8995 SHA512 ae33ddbdae75dc16c970e711a4d0f446c33ca24826109347d3fdf9b6535040b452e2b352b9db0dadbd6cc36a9f438f1861ec470474a9f952b3251453626179ad
MISC metadata.xml 249 BLAKE2B f7f8f071ecba933f3d39b0b60983281d59299b92de9375a60ab4109d7202800cb790bce0c426227f04b3e2624b1adb20876145741355abc6a4938b8b9698d144 SHA512 9a100fb26586365eda99724330a03a512f4d0be18d39c3a195ba02c2fc841edeee99d22512acf5a058a3b978d3a74f4d963a5aff9aa343b6cb4086cdfefe6343
diff --git a/media-libs/libvorbis/libvorbis-1.3.6.ebuild b/media-libs/libvorbis/libvorbis-1.3.6.ebuild
new file mode 100644
index 000000000000..92e37324f12b
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.3.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib
+
+DESCRIPTION="The Ogg Vorbis sound file format library"
+HOMEPAGE="https://xiph.org/vorbis/"
+SRC_URI="https://downloads.xiph.org/releases/vorbis/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS/s:-O20::' \
+ -e '/CFLAGS/s:-mcpu=750::' \
+ -e '/CFLAGS/s:-mno-ieee-fp::' \
+ configure.ac || die
+
+ # Un-hack docdir redefinition.
+ find -name 'Makefile.am' \
+ -exec sed -i \
+ -e 's:$(datadir)/doc/$(PACKAGE)-$(VERSION):@docdir@/html:' \
+ {} + || die
+
+ AT_M4DIR="m4" \
+ autotools-multilib_src_prepare
+}