summaryrefslogtreecommitdiff
path: root/media-libs/libvorbis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libvorbis
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libvorbis')
-rw-r--r--media-libs/libvorbis/Manifest5
-rw-r--r--media-libs/libvorbis/libvorbis-1.3.5.ebuild40
-rw-r--r--media-libs/libvorbis/metadata.xml8
3 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/libvorbis/Manifest b/media-libs/libvorbis/Manifest
new file mode 100644
index 000000000000..b6ae4053662f
--- /dev/null
+++ b/media-libs/libvorbis/Manifest
@@ -0,0 +1,5 @@
+DIST libvorbis-1.3.5.tar.xz 1193144 SHA256 54f94a9527ff0a88477be0a71c0bab09a4c3febe0ed878b24824906cd4b0e1d1 SHA512 f18f32edc43f65fea2dd4133e2828a0ced9e5b0797c4569bd26989fc1409ad599359e7c796bffc082ad36189f9722c7b38837384cea66d217beac8b425299ef8 WHIRLPOOL e179e8b52eadcf19d8b93816778c650a0b595846c5bf9593a9ee8b2e06a702cfee64d8e0c6cd82eb1c48211d7f0f34103ad6855033376eb664b34f73aeb01b62
+EBUILD libvorbis-1.3.5.ebuild 1142 SHA256 b6e38f7403d629cb09188f893195bfee08b2f98c2cc8e31089085d85dee7e358 SHA512 e3b701b9ca57bb7600791721b06af1586614416011ba8bcefd55f2b556eda41e936ab8991f904f98190e9972dbd1bf897a20243dada0e0fb341bb9c7d205ba40 WHIRLPOOL 47dfb4b4e9f25830cf5cabdc8d3c25c56ebaa34c1881e08e5f9a400770f645f2a0f8b482ef238c141ada3e50abf501f7d329a29ff2f99018cf2cdfd9f188d784
+MISC ChangeLog 3201 SHA256 cdf01eeaced75c5cd1fb75329e02fe14c563590a28c2449f369c2f18a39162d3 SHA512 e589e5bc39279e48e9825075aea80a5c3ec260670b5226a9eec95c57e49bfb306cccb3cdc01f0cd711fa5f13cc58d6fa473cffb473050723811cd4d8e2dda342 WHIRLPOOL 138d7fa3a0d30f0843c4197ed62bd283470337d3081ae401d5796b2baa195ed12c0dccff905990760b8f8bc51839436c2040473799536708b3ecd81e00491b58
+MISC ChangeLog-2015 22733 SHA256 7439798c47fc3727376508f5726dae482783ef78f5ff9e397d0364a55e284eda SHA512 0ccdf699508d1245d1d28fb41ddfba7950f4b9ac9ab73322b7b68ff40b33f3c261635f7d1f6136ab42e40d6ca2c626f49425c6616a4e4784e47ae9dc06c82f29 WHIRLPOOL c79592d03703cb6e49caa211691276ea831771a71a4e108ea15a0b019ccd2997c8600cb10272ba90d1f8f003e4b6b6386890ec3c7d0e93b6172a32d9f5e3e727
+MISC metadata.xml 249 SHA256 a591aa91a9c413e7f7e24fd25b924ce2dfef686da8b4ce38bebb088ebfdba9db SHA512 9a100fb26586365eda99724330a03a512f4d0be18d39c3a195ba02c2fc841edeee99d22512acf5a058a3b978d3a74f4d963a5aff9aa343b6cb4086cdfefe6343 WHIRLPOOL ae5b0c583f3a07ed1ccf651b5b9c8d6c8c637fba2d505fc4b028ea60239fc0a84e37a169b5114f879712ae74f7f41960a2cc6b59e67cacc7f964b105b5fb8723
diff --git a/media-libs/libvorbis/libvorbis-1.3.5.ebuild b/media-libs/libvorbis/libvorbis-1.3.5.ebuild
new file mode 100644
index 000000000000..447efabfe35a
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.3.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib
+
+DESCRIPTION="The Ogg Vorbis sound file format library"
+HOMEPAGE="https://xiph.org/vorbis/"
+SRC_URI="https://downloads.xiph.org/releases/vorbis/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS/s:-O20::' \
+ -e '/CFLAGS/s:-mcpu=750::' \
+ -e '/CFLAGS/s:-mno-ieee-fp::' \
+ configure.ac || die
+
+ # Un-hack docdir redefinition.
+ find -name 'Makefile.am' \
+ -exec sed -i \
+ -e 's:$(datadir)/doc/$(PACKAGE)-$(VERSION):@docdir@/html:' \
+ {} + || die
+
+ AT_M4DIR="m4" \
+ autotools-multilib_src_prepare
+}
diff --git a/media-libs/libvorbis/metadata.xml b/media-libs/libvorbis/metadata.xml
new file mode 100644
index 000000000000..c870d0eef0ab
--- /dev/null
+++ b/media-libs/libvorbis/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+</maintainer>
+</pkgmetadata>