summaryrefslogtreecommitdiff
path: root/media-libs/libva-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-16 07:52:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-16 07:52:23 +0100
commitc7c046a33897c533b949ee76326d620f5e07f2e9 (patch)
tree9cefb49f93bb8be42c9129fdf95d7ab846751826 /media-libs/libva-compat
parent6144cd2e90f8e3623912112050c8d2025de44f0a (diff)
gentoo auto-resync : 16:10:2022 - 07:52:23
Diffstat (limited to 'media-libs/libva-compat')
-rw-r--r--media-libs/libva-compat/Manifest3
-rw-r--r--media-libs/libva-compat/libva-compat-1.8.3-r2.ebuild66
-rw-r--r--media-libs/libva-compat/metadata.xml15
3 files changed, 84 insertions, 0 deletions
diff --git a/media-libs/libva-compat/Manifest b/media-libs/libva-compat/Manifest
new file mode 100644
index 000000000000..4d146b008632
--- /dev/null
+++ b/media-libs/libva-compat/Manifest
@@ -0,0 +1,3 @@
+DIST libva-1.8.3.tar.gz 186915 BLAKE2B 10713e3bd7aaefc033490fc9ef6485ec50774f274f09e9e06fd1479b882b221791375533a6826e5db9a758f2acd74f913a478da61fe32250a3e2d9c0062739fc SHA512 f2f360876d8443a22a3434aa1ac7ec5aa6d4b3cc1f13f475ef74e716f5937acc43e02f9a8b858b5b7b6539da3731f763843d45664cc19c70e81d8b87e93659ea
+EBUILD libva-compat-1.8.3-r2.ebuild 1665 BLAKE2B 67c0d68b8e85eafab1746394f89b56ed66813e2aff7920d28f7c6a536aaf54fe3723c647054ddc9e72ff0205ac78f7fbd5b1a9c4ce074fcf1b400c43b8fbb771 SHA512 f4d3987d1ac86d84baf45b97794c660d09812ba25fe489ad2d58e27e096fadbd307c84b0a1fc4bd8985e0a1e72b1c96ebe728e5ec2f64c0fcb53eee0724e27ab
+MISC metadata.xml 440 BLAKE2B e8071d75c17e53b38897201da353284933b04c5337f01404b2c80c6edf571d47b2e2b92f85451097aba5db421f5dca1a254d24425e096067c270b8aa0e732ae3 SHA512 eafd1feaee7adcd7903c26d9efd0cdadb118c2af683d3158a68a7f931eba83367d8702253b6ebfbea45001009f225a6b15f0cca8d8a2b303f757fb0d7d499541
diff --git a/media-libs/libva-compat/libva-compat-1.8.3-r2.ebuild b/media-libs/libva-compat/libva-compat-1.8.3-r2.ebuild
new file mode 100644
index 000000000000..618ec9f2bc42
--- /dev/null
+++ b/media-libs/libva-compat/libva-compat-1.8.3-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal optfeature
+
+MY_PN="${PN%-compat}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+SRC_URI="https://github.com/01org/libva/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="amd64 arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="+drm egl opengl wayland X"
+
+RDEPEND=">=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ )
+ egl? ( >=media-libs/mesa-9.1.6[egl(+),${MULTILIB_USEDEP}] )
+ opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
+ !media-libs/libva:0/0"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE="|| ( drm wayland X )
+ opengl? ( X )"
+
+S="${WORKDIR}/${MY_P}"
+DOCS=( NEWS )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable egl)
+ $(use_enable drm)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake -C va DESTDIR="${D}" install-libLTLIBRARIES
+ rm -vf "${ED}"/usr/$(get_libdir)/*.{la,so} || die
+}
+
+pkg_postinst() {
+ optfeature_header
+ optfeature "Older Intel GPU support" media-libs/libva-intel-driver
+ optfeature "Newer Intel GPU support" media-libs/libva-intel-media-driver
+}
diff --git a/media-libs/libva-compat/metadata.xml b/media-libs/libva-compat/metadata.xml
new file mode 100644
index 000000000000..e454a2831910
--- /dev/null
+++ b/media-libs/libva-compat/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <use>
+ <flag name="egl">Enables EGL support.</flag>
+ <flag name="drm">Enables VA/DRM API support.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">intel/libva</remote-id>
+ </upstream>
+</pkgmetadata>