summaryrefslogtreecommitdiff
path: root/media-libs/libuninameslist/libuninameslist-20211114.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-libs/libuninameslist/libuninameslist-20211114.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-libs/libuninameslist/libuninameslist-20211114.ebuild')
-rw-r--r--media-libs/libuninameslist/libuninameslist-20211114.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/libuninameslist/libuninameslist-20211114.ebuild b/media-libs/libuninameslist/libuninameslist-20211114.ebuild
new file mode 100644
index 000000000000..8b737b8c494e
--- /dev/null
+++ b/media-libs/libuninameslist/libuninameslist-20211114.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library of unicode annotation data"
+HOMEPAGE="https://github.com/fontforge/libuninameslist"
+SRC_URI="https://github.com/fontforge/libuninameslist/releases/download/${PV}/${PN}-dist-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+PATCHES=(
+ "${FILESDIR}/${P}-slibtool.patch" # 792474
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-frenchlib
+}
+
+src_install() {
+ default
+ find "${ED}"/usr -name '*.la' -delete || die
+}