summaryrefslogtreecommitdiff
path: root/media-libs/libsoundtouch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
commitb1c81de4fadbd00897700a7321f03b390d952b2e (patch)
treee6cc812351d4f105c110cfc363ebb497e996f47a /media-libs/libsoundtouch
parent7c59acba5699c9c58090a7a738669669a7307023 (diff)
gentoo resync : 26.08.2021
Diffstat (limited to 'media-libs/libsoundtouch')
-rw-r--r--media-libs/libsoundtouch/Manifest2
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-2.3.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/libsoundtouch/Manifest b/media-libs/libsoundtouch/Manifest
index df72a764d09c..cab4c30ddae5 100644
--- a/media-libs/libsoundtouch/Manifest
+++ b/media-libs/libsoundtouch/Manifest
@@ -1,3 +1,5 @@
DIST soundtouch-2.2.tar.bz2 527571 BLAKE2B 0ed67604f0996a9112cbabad9eda39c314aa1f3b1b70aac2a014f76880cb5ad06aeb697f44e9229ad197c9245ce8f684f5fb9b31ce31ae631400a17fe825679f SHA512 8bc1b9aa60031145e8be7ab48d10d93da84b0f5032eb2d8cf46291d4267b6810513f284f6fa72dd6f343e30eeec03070a7485cd933f30bace2ebf995bc843143
+DIST soundtouch-2.3.0.tar.bz2 528840 BLAKE2B e76627c323c223a067db6fd65a08661f39c9b55e0eb8ead7d643f92707dc56b8d235eded27a95d5eb1ea751d15336d4cb4b757c4abb2f6780258d81899484241 SHA512 f85974d7afd010bd874a4ffc51abf4013694334bfb09071f1c4d478641d34b5eecb9efc6ac41d8f0e6a5d1cb4095289316c124c522b4ca3fbd6a91b6cfc83083
EBUILD libsoundtouch-2.2.ebuild 1520 BLAKE2B 705d5129d3a63288122abea8678e54ef1e390dd5ff7257eec7843b4e1f41e3eeaf121922d30fac9ce0c231fd864eb6c441a2dc735d04db5786797427941cfe17 SHA512 78764152c7b4cc941422515013cc82c63c4fe992de1dfbea87213fbf81fec3122405905837ec26da80d93d7ba4dbfdf75453d0427acfa37d5a51c3bc858a39f5
+EBUILD libsoundtouch-2.3.0.ebuild 1524 BLAKE2B 5dfeb54696c03bcc4d95d28798230ffd4dd60c63a40abfcf1498ff5dfd10300e84e568aff4ed7a01715d315b953f92d935182550c8cfb0d9570894837039ed08 SHA512 d8b236a447e751fbf04d45069748260efb46db7628b4e5e9e0fffcc8d86f2c8088ebecb830b6155780214bbe97ffda2bf4079d1c2398b15cd89909b0b38c5fe3
MISC metadata.xml 253 BLAKE2B 6426153a5fa5bbad2aaffd28a6460f87a35678319768c57ac8dfae02b2229f6278dead4f564e6bc2bfd54d7143aed95c382abc2ee16c1073e9fbaf4f84cc0fef SHA512 78b724be3e1dbd6fc3c2e92cdbacc15ea4b0e8ee6fa22f76ebdd882b3a7bbedeaf8f80a29e36ec67e0432d2dfad3f57de4bc46480f92c8e544322755292df894
diff --git a/media-libs/libsoundtouch/libsoundtouch-2.3.0.ebuild b/media-libs/libsoundtouch/libsoundtouch-2.3.0.ebuild
new file mode 100644
index 000000000000..05a3b1ff14d0
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-2.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib-minimal toolchain-funcs
+
+MY_PN=${PN/lib}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
+HOMEPAGE="https://www.surina.net/soundtouch/ https://gitlab.com/soundtouch/soundtouch"
+SRC_URI="https://gitlab.com/${MY_PN}/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+# subslot = libSoundTouch.so soname
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="cpu_flags_x86_sse openmp static-libs"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+ sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --disable-integer-samples
+ $(use_enable cpu_flags_x86_sse x86-optimizations)
+ $(use_enable openmp)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}