summaryrefslogtreecommitdiff
path: root/media-libs/libsoundtouch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 12:50:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 12:50:42 +0000
commit7d58bf45ea7b2d8f188fd2aa40484a8c9a3381a7 (patch)
tree74a135cfbc172935bc5b36a9e7c29915932b5445 /media-libs/libsoundtouch
parentafa8da78d8135ca28150730e9c60af9d875f0a5b (diff)
gentoo auto-resync : 14:11:2022 - 12:50:41
Diffstat (limited to 'media-libs/libsoundtouch')
-rw-r--r--media-libs/libsoundtouch/Manifest2
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/libsoundtouch/Manifest b/media-libs/libsoundtouch/Manifest
index 9f8ec085421d..75558cba6e41 100644
--- a/media-libs/libsoundtouch/Manifest
+++ b/media-libs/libsoundtouch/Manifest
@@ -1,3 +1,5 @@
DIST soundtouch-2.3.1.tar.bz2 529126 BLAKE2B f8ba587ac199cd1e91f3d3487b81457b7c7bb2b4dca8867376ae47f92bf4d5e60aef3d310eab56510995d5ce72e94ce55ecc4e601bfb3b4eba52c40982032d6b SHA512 9fac7484aead1a20aae019b29847ea13ad6d8cb72272313fcffd859b31479d2ab2fe2f69cfef2b3fd35e9b03923d095bf44a67b46f2b313ac711aa31df0fdd59
+DIST soundtouch-2.3.2.tar.gz 583373 BLAKE2B cd3c8fffaa81a2ed867f5a564dd7ff3047b4de576536c3c116162981261bf3789d16def1c94e5be2450373be3f61fd67fa44e3552e19cad7b7d5d56500b98255 SHA512 72cd38f3e11f3c55ff7ed3691fd9a749a5f8d072e08ed03f2fd43a8664962138afaf3e4647116940e86f6ae374a1ba3bcd4b108280da29f3ffa6091cf383ea35
EBUILD libsoundtouch-2.3.1.ebuild 1580 BLAKE2B 96f5f32e57f59fab94d6f23183c6349c47c2153dc8cdff58e52170422227b60057e1537240daff4820bf55da3e11a89078a9f870ebfa42e76d3f247e18d3ee63 SHA512 f89fdadddf1a75cc14d5cd3faf0a5ca0b94f62756cf825b24e82eaa9f897913e6ee5f4cb4fdb54e51a120082914154044a86a7dda6c86439d6ac80a0c34b9f68
+EBUILD libsoundtouch-2.3.2.ebuild 1563 BLAKE2B 56c9b033767c7464b1a3cfa00615ec34ed42c0301a509ad98836b82d7eefe4e98936c11df870fb04382b5670d41faf5220cf6f044cf3934566c4b123965d6d1f SHA512 5753ad168d9cd49674e9a45eb144eb89a4c2e68688afe80968cd65354bd4f0ca13c64a63d8b549d7edb5be472f65c1bfb69962870eb085eb45305ddbc9d50c1b
MISC metadata.xml 254 BLAKE2B 7f76152858fde96b9de5250e4cba30bfe0c5f2aa6ec7c84316072d84e4b664ecd6485642d3d184b1f2ddde8d9e03a94dd47dd00c5b8d82f80c5c0993d5627593 SHA512 7ed31d18221f55928f798dbf095166f535f7c0f5a1c3010b5113fd6b0d275af283f3d2e6839591335ec93bcd50aab5d0f104ad76eefda4d7a6b64d41af183f0b
diff --git a/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild b/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild
new file mode 100644
index 000000000000..0b26840141e7
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal toolchain-funcs
+
+MY_PN=${PN/lib}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
+HOMEPAGE="https://www.surina.net/soundtouch/ https://gitlab.com/soundtouch/soundtouch"
+SRC_URI="https://www.surina.net/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+# subslot = libSoundTouch.so soname
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="cpu_flags_x86_sse openmp static-libs"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --disable-integer-samples
+ $(use_enable cpu_flags_x86_sse x86-optimizations)
+ $(use_enable openmp)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}