summaryrefslogtreecommitdiff
path: root/media-libs/libsoundtouch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-libs/libsoundtouch
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-libs/libsoundtouch')
-rw-r--r--media-libs/libsoundtouch/Manifest2
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-2.2.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/libsoundtouch/Manifest b/media-libs/libsoundtouch/Manifest
index fb633d8a2a97..94ba50d344bf 100644
--- a/media-libs/libsoundtouch/Manifest
+++ b/media-libs/libsoundtouch/Manifest
@@ -1,3 +1,5 @@
DIST soundtouch-2.1.2.tar.bz2 526281 BLAKE2B f15f004fd6abdf4cd6fdb842c650480c670a517c6d94365633a7cc4beb95447d7a8bee965d4b258da6c31630e370e3c1c1fc73abfe8568ace465ce41a87397cf SHA512 d45cb0f94e3df32e9c76722a148f201277b2ddc3e390394c1f4ae1263f13557c6b664e90301b5f62d7561d743ab4903a44a34ab7248880b343d581cebd5f0cd9
+DIST soundtouch-2.2.tar.bz2 527571 BLAKE2B 0ed67604f0996a9112cbabad9eda39c314aa1f3b1b70aac2a014f76880cb5ad06aeb697f44e9229ad197c9245ce8f684f5fb9b31ce31ae631400a17fe825679f SHA512 8bc1b9aa60031145e8be7ab48d10d93da84b0f5032eb2d8cf46291d4267b6810513f284f6fa72dd6f343e30eeec03070a7485cd933f30bace2ebf995bc843143
EBUILD libsoundtouch-2.1.2.ebuild 1520 BLAKE2B 1201cd8926d9a18249cc31bf7a59a4f2fcc7069fc4288ded072c0186c4d7e1494311080d8dec1574d0449b8b90117b8d0bc7569135cf03265a8aa08853883499 SHA512 2d8ca9157fb7e2a360a106231adf089c01ac804b0804d8197500c32e97aee60dde3289867ef7d9e0ff71b0db538dd640ec38e185256c524d39c8a0b8c70e6683
+EBUILD libsoundtouch-2.2.ebuild 1524 BLAKE2B 5dfeb54696c03bcc4d95d28798230ffd4dd60c63a40abfcf1498ff5dfd10300e84e568aff4ed7a01715d315b953f92d935182550c8cfb0d9570894837039ed08 SHA512 d8b236a447e751fbf04d45069748260efb46db7628b4e5e9e0fffcc8d86f2c8088ebecb830b6155780214bbe97ffda2bf4079d1c2398b15cd89909b0b38c5fe3
MISC metadata.xml 253 BLAKE2B 6426153a5fa5bbad2aaffd28a6460f87a35678319768c57ac8dfae02b2229f6278dead4f564e6bc2bfd54d7143aed95c382abc2ee16c1073e9fbaf4f84cc0fef SHA512 78b724be3e1dbd6fc3c2e92cdbacc15ea4b0e8ee6fa22f76ebdd882b3a7bbedeaf8f80a29e36ec67e0432d2dfad3f57de4bc46480f92c8e544322755292df894
diff --git a/media-libs/libsoundtouch/libsoundtouch-2.2.ebuild b/media-libs/libsoundtouch/libsoundtouch-2.2.ebuild
new file mode 100644
index 000000000000..05a3b1ff14d0
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib-minimal toolchain-funcs
+
+MY_PN=${PN/lib}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
+HOMEPAGE="https://www.surina.net/soundtouch/ https://gitlab.com/soundtouch/soundtouch"
+SRC_URI="https://gitlab.com/${MY_PN}/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+# subslot = libSoundTouch.so soname
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="cpu_flags_x86_sse openmp static-libs"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+ sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --disable-integer-samples
+ $(use_enable cpu_flags_x86_sse x86-optimizations)
+ $(use_enable openmp)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}