summaryrefslogtreecommitdiff
path: root/media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild')
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild b/media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild
index fd181f34ded2..04978df25d43 100644
--- a/media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild
+++ b/media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,11 +21,16 @@ BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
src_prepare() {
default
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
eautoreconf