summaryrefslogtreecommitdiff
path: root/media-libs/libshumate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
commit5a1e5a6812ca9c9555657cce48fe09d2ffa44401 (patch)
tree5c040bbee9184b24f26b05031a2448e62f6df38a /media-libs/libshumate
parent2c4066122b66fa1eb3e37846f9a6e14529a553d8 (diff)
gentoo auto-resync : 02:12:2022 - 08:55:37
Diffstat (limited to 'media-libs/libshumate')
-rw-r--r--media-libs/libshumate/Manifest2
-rw-r--r--media-libs/libshumate/libshumate-1.0.3.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/libshumate/Manifest b/media-libs/libshumate/Manifest
index 224f22138a1e..eafc6bcec6d0 100644
--- a/media-libs/libshumate/Manifest
+++ b/media-libs/libshumate/Manifest
@@ -1,5 +1,7 @@
DIST libshumate-1.0.1.tar.xz 109884 BLAKE2B b1a4838b3f43df00ded7973e78acaceaa1c2fa6bb3a67214e475026a980c03f610e68b8d2a992093f091731e8d8e48e954d1ba917e93071f63a984f45a3142bc SHA512 19bf8a563d9b5c9cca3adfc337ec8843c7d8b891fcdd789adecfb79a46c3ba6f674795d39199ce154c5a3f6b95eac5d6e56ba73066f2ab18c8a95d3646b9ad25
DIST libshumate-1.0.2.tar.xz 110656 BLAKE2B 75abbfd9b4e1e7eb1044a33ff1b46391024005487f01aa4401552727322f92f28120104af4c2f90bb91c70ada6282882b9ee7f50ac62542aab8c88cc227799f8 SHA512 15539ce50462b345e4329fc27f52a5d1fb143e82821a990ce818a576fec94d1fe1fbef9926d0251d169f22394f3f21c62e56fe4d97bbdd4482429c70f22c6b2d
+DIST libshumate-1.0.3.tar.xz 110868 BLAKE2B 56d2304208dd41e1c6dc14b76bd6c5cadfb3359576c1c74405851e63be06deaa92bce4fae7bb91855fee53f561dfa84ccbb7ff61eed2f3195d6a93f76e3e2668 SHA512 dc72955bdbe6eee3d4d82dd884c5e74341fa5de25af388d3cc41a368170e4d8f5edf32acdf320e7dde9bc6ace94694e166eafb864887f66a60fb4053d12e1462
EBUILD libshumate-1.0.1.ebuild 1441 BLAKE2B aafe203c13f50943bb4bddfc0350471c3838cb0981d86ab0fd0b49c678dd1d7d653463c734804e7fec8a7f7828a97d5928bcb7e96d52531cf6ad891f990ab6f7 SHA512 2df30a99fcd43784f78da8d6bf4e2d59b430020c8c0ab36d5db766c411945eb4bdcba8d7c8e541cbcb8508e439d3a8f88240d76ffddc2d0912d852b614334d91
EBUILD libshumate-1.0.2.ebuild 1472 BLAKE2B 44fc3b38717f1916e9e717eada46d55051d160c0da872dc19f7b78311dedff0f3714f05222c9bed2131062d5124c5112556b4607ac965af16308863ecfdff9c1 SHA512 83a52d565a8351a22dbe7a566ad2a656e1290d08430b70b854aea7a349abc8d406d1384d2fb8fe2065fc9c200f22f13ab23581235d83b9e489e5896ceedaa78a
+EBUILD libshumate-1.0.3.ebuild 1578 BLAKE2B 1e8f71b91f0c236ce7be07b87ae1266b87885c10e5db7e00116a27fb8160aa27ccdd23ad1f47dd8cdd952022485bc25207cc3d9a4891a34ef872a8b74ce19e1b SHA512 023d3c1cf44bd4730ead0422168f6dfe96e734a4d63da951ef2585daa340d07e04f4945007fd898ec51c8249d56f68047f37534ea555e528d216c66a08d11a53
MISC metadata.xml 351 BLAKE2B 0156fcc6cd262dc795ba78bf80f0ff69452458d8fe7116f2e3712f46c31b232cdc4a10a7d1b2fbf566a723ca7bc8a7c61b8299730e702c3bb40c6fa94c2647d7 SHA512 a4944c1629f135d09bc2d49fa0ff8d674076d669d312d7650113b2f5f89704faf67ff34ae0392684aa97459c6117b99ec8fd822817c99a6a02e4959c59dea095
diff --git a/media-libs/libshumate/libshumate-1.0.3.ebuild b/media-libs/libshumate/libshumate-1.0.3.ebuild
new file mode 100644
index 000000000000..8da598a7cdb6
--- /dev/null
+++ b/media-libs/libshumate/libshumate-1.0.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala virtualx
+
+DESCRIPTION="Shumate is a GTK toolkit providing widgets for embedded maps"
+HOMEPAGE="https://wiki.gnome.org/Projects/libshumate https://gitlab.gnome.org/GNOME/libshumate"
+
+SLOT="1.0/1"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+IUSE="gtk-doc +introspection vala" # vector-renderer is still experimental, maybe put in at a later release
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=x11-libs/cairo-1.4
+ >=dev-db/sqlite-1.12:3
+ >=gui-libs/gtk-4:4
+ >=net-libs/libsoup-3.0:3.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3:= )
+"
+# vector-renderer? (
+# >=dev-libs/json-glib-1.6.0[introspection?]
+# dev-libs/protobuf-c
+# )
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+
+ sed -i -e 's/^valgrind =.*/valgrind = disabler()/' tests/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection gir)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ -Ddemos=false # only built, not installed
+ # $(meson_use vector-renderer vector_renderer)
+ -Dvector_renderer=false
+ -Dlibsoup3=true
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/libshumate-1.0 "${ED}"/usr/share/gtk-doc/libshumate-1.0 || die
+ fi
+}