summaryrefslogtreecommitdiff
path: root/media-libs/libshumate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-28 03:11:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-28 03:11:19 +0100
commit1bc9c3b9d5a8c51b67f6ea2f57bdd76ff5073097 (patch)
tree8ff3b237086572800bda4afb971fc61617aa941e /media-libs/libshumate
parent3ca7a521e79841f7247feb67780a70722c997d55 (diff)
gentoo auto-resync : 28:09:2022 - 03:11:19
Diffstat (limited to 'media-libs/libshumate')
-rw-r--r--media-libs/libshumate/Manifest3
-rw-r--r--media-libs/libshumate/libshumate-1.0.1.ebuild60
-rw-r--r--media-libs/libshumate/metadata.xml8
3 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/libshumate/Manifest b/media-libs/libshumate/Manifest
new file mode 100644
index 000000000000..50cc9554f756
--- /dev/null
+++ b/media-libs/libshumate/Manifest
@@ -0,0 +1,3 @@
+DIST libshumate-1.0.1.tar.xz 109884 BLAKE2B b1a4838b3f43df00ded7973e78acaceaa1c2fa6bb3a67214e475026a980c03f610e68b8d2a992093f091731e8d8e48e954d1ba917e93071f63a984f45a3142bc SHA512 19bf8a563d9b5c9cca3adfc337ec8843c7d8b891fcdd789adecfb79a46c3ba6f674795d39199ce154c5a3f6b95eac5d6e56ba73066f2ab18c8a95d3646b9ad25
+EBUILD libshumate-1.0.1.ebuild 1441 BLAKE2B aafe203c13f50943bb4bddfc0350471c3838cb0981d86ab0fd0b49c678dd1d7d653463c734804e7fec8a7f7828a97d5928bcb7e96d52531cf6ad891f990ab6f7 SHA512 2df30a99fcd43784f78da8d6bf4e2d59b430020c8c0ab36d5db766c411945eb4bdcba8d7c8e541cbcb8508e439d3a8f88240d76ffddc2d0912d852b614334d91
+MISC metadata.xml 254 BLAKE2B de7a97001e5947704f42973c8a0c3a23c2d80afb976254f5fd21e9d372a946e055d4cdc3c0eaed010505f87929b56e8b1e650c945e2a302644adbc9440833be8 SHA512 c81da4f9b80e5691a167f4590906952e25356604ec17689c005be14efb394c0634776bbe84df936edde239480bdf46db41216b00da4a3a45f670e9ca18ab0132
diff --git a/media-libs/libshumate/libshumate-1.0.1.ebuild b/media-libs/libshumate/libshumate-1.0.1.ebuild
new file mode 100644
index 000000000000..e3f5bb4d13fb
--- /dev/null
+++ b/media-libs/libshumate/libshumate-1.0.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala virtualx
+
+DESCRIPTION="Shumate is a GTK toolkit providing widgets for embedded maps"
+HOMEPAGE="https://wiki.gnome.org/Projects/libshumate https://gitlab.gnome.org/GNOME/libshumate"
+
+SLOT="1.0/1"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+IUSE="gtk-doc +introspection vala" # vector-renderer is still experimental, maybe put in at a later release
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=x11-libs/cairo-1.4
+ >=dev-db/sqlite-1.12:3
+ >=gui-libs/gtk-4:4
+ >=net-libs/libsoup-3.0:3.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3:= )
+"
+# vector-renderer? (
+# >=dev-libs/json-glib-1.6.0[introspection?]
+# dev-libs/protobuf-c
+# )
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection gir)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ -Ddemos=false # only built, not installed
+ # $(meson_use vector-renderer vector_renderer)
+ -Dvector_renderer=false
+ -Dlibsoup3=true
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/libshumate-1.0 "${ED}"/usr/share/gtk-doc/libshumate-1.0 || die
+ fi
+}
diff --git a/media-libs/libshumate/metadata.xml b/media-libs/libshumate/metadata.xml
new file mode 100644
index 000000000000..f453528b934f
--- /dev/null
+++ b/media-libs/libshumate/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>