summaryrefslogtreecommitdiff
path: root/media-libs/libsdl2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-18 06:58:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-18 06:58:04 +0000
commit070c77515d1406e762e9e344856546f0a15765b6 (patch)
treee9c59800869ff27454b82c6afa378a4fee0ef935 /media-libs/libsdl2
parent6330245077f9f298a785e17756a8f59a843361a5 (diff)
gentoo auto-resync : 18:11:2022 - 06:58:04
Diffstat (limited to 'media-libs/libsdl2')
-rw-r--r--media-libs/libsdl2/Manifest2
-rw-r--r--media-libs/libsdl2/libsdl2-2.24.2.ebuild227
2 files changed, 229 insertions, 0 deletions
diff --git a/media-libs/libsdl2/Manifest b/media-libs/libsdl2/Manifest
index 83a2fa528282..6622aa8c97ab 100644
--- a/media-libs/libsdl2/Manifest
+++ b/media-libs/libsdl2/Manifest
@@ -3,5 +3,7 @@ AUX libsdl2-2.24.0-clang-15-configure.patch 768 BLAKE2B f21f01da86fed778f5ef88cf
AUX libsdl2-2.24.0-cmake-target-fixes.patch 6489 BLAKE2B 3703cae1f4220d6ca7899a2a1b61c083f560db30996f032eb6570f80e7b0bb3969b2c929ec104d461297502d5e46a8ae0a34d38f04d76b274894d124aa486905 SHA512 43710fa7d5321b688b2bd65460fff77d16943ff25280b7ba25c2676112db8e1ce9daeb2c144d41ed5473dcb4b38ad0a91686859949ff4a10ed4bea8769188b15
AUX libsdl2-2.24.0-fix-build-without-joystick.patch 1263 BLAKE2B 9421e7056496fb46393b53e0d7da85ae0169e5dc769fc5b2be045127eaab13d69ab5d5e00f1a4f2c2223e03bc2cf58fe17f377dad39f35afcccd7ef4f69a94df SHA512 2c24c90503b62c30bd3aa47285d4cbb6372beacc5561390ad998a44fd5342a50ade2983e0731a3a63696c03f5b348ae711ea6e8ab59d5ada64afd0079e5d6d22
DIST SDL2-2.24.0.tar.gz 7520541 BLAKE2B 9d5bf061a66dc6443f3c6bcdd1be15926fcb4e4c0ec99497b409e84c78027c14059338d482bced3bf16b22b9b268e263b718ad3fbcd5642d247d9dc98a601602 SHA512 5735bfc7b22f1780f80cc89f62a14ca809fe1280298d172f92dde74400db1f5378f8d3eae8834e886d3ca4f5ae6f1074d66c5c956613cf9e0cce961738514212
+DIST SDL2-2.24.2.tar.gz 7525041 BLAKE2B bdd6fdffca8f5360b96bba31b2f64e5b01f1081c184070fba6a0a52b7ee5f6d08ca5d647a40bbfb9b2ba49374ce7d7f21bc60e798017fa79d673ab048f5a281c SHA512 6f3ce5c4121a17d4e85a087c9010fdff37eb4e381517dc0d64fff955cf7041016aa1f37ac2f14a335bfaac13cb92031431eb31bfa0f00a6827c177b5a671f841
EBUILD libsdl2-2.24.0-r2.ebuild 6517 BLAKE2B f809229345e39e0c4a0946526181475d18e45dd06c9a74f8df7529afe40cc87af2fe17dfa0256f7ea255be7a49858eaf6ee29b887250817d94c0ce268afe8c86 SHA512 84f2aa5a22dad410e09a86cafb71ec9edbc110f07b9c7a980ce0c5ee77009fbcd48f27e4ba494d909d2a211064a42adf13744d12bf9ecb72b6375a7f46d13281
+EBUILD libsdl2-2.24.2.ebuild 6373 BLAKE2B 174e817baa1a7203465903ee1b94edff04c5dd931e1c945a30afe5f19375b98632d327fdeff1ef2b5561452ef8643bc1623daa170b33bffd460aac6bee2ab3f5 SHA512 3c3512a3a2d9bd9f708f021c872e6b703efd9554dddaa65974fae10674256eff5ab634faeb967195882cefa4961213167b13589bb2e681c7503fb5e2d4fa38a9
MISC metadata.xml 2054 BLAKE2B 611185e0b090bc8865c6ef61cf0dfab07a1806fd2db9fc50f2e3eaefba6ccb26127a51d61afd0a96c520d3d11be5a1a789631554705d7aa36270626d69ddfe89 SHA512 3a9bcecb9e0a8bc74ff8eb36d9dc4e8c1f7bf892428b3f6edd91b97082dd16e591117d45ee3d4558fc1b8137f16b54d01703b9c9c7c24cc149856ccc14bed2c1
diff --git a/media-libs/libsdl2/libsdl2-2.24.2.ebuild b/media-libs/libsdl2/libsdl2-2.24.2.ebuild
new file mode 100644
index 000000000000..50a7396fe313
--- /dev/null
+++ b/media-libs/libsdl2/libsdl2-2.24.2.ebuild
@@ -0,0 +1,227 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic multilib-minimal
+
+MY_P="SDL2-${PV}"
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="https://www.libsdl.org/"
+SRC_URI="https://www.libsdl.org/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus doc fcitx4 gles1 gles2 haptic ibus jack +joystick kms libsamplerate nas opengl oss pipewire pulseaudio sndio +sound static-libs +threads udev +video video_cards_vc4 vulkan wayland X xscreensaver"
+REQUIRED_USE="
+ alsa? ( sound )
+ fcitx4? ( dbus )
+ gles1? ( video )
+ gles2? ( video )
+ haptic? ( joystick )
+ ibus? ( dbus )
+ jack? ( sound )
+ nas? ( sound )
+ opengl? ( video )
+ pulseaudio? ( sound )
+ sndio? ( sound )
+ vulkan? ( video )
+ wayland? ( gles2 )
+ xscreensaver? ( X )"
+
+CDEPEND="
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ fcitx4? ( app-i18n/fcitx:4 )
+ gles1? ( media-libs/mesa[${MULTILIB_USEDEP},gles1] )
+ gles2? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
+ ibus? ( app-i18n/ibus )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ kms? (
+ >=x11-libs/libdrm-2.4.82[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-9.0.0[${MULTILIB_USEDEP},gbm(+)]
+ )
+ libsamplerate? ( media-libs/libsamplerate[${MULTILIB_USEDEP}] )
+ nas? (
+ >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ )
+ opengl? (
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ )
+ pipewire? ( media-video/pipewire:=[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ sndio? ( media-sound/sndio:=[${MULTILIB_USEDEP}] )
+ udev? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ wayland? (
+ >=dev-libs/wayland-1.20[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},egl(+),gles2,wayland]
+ >=x11-libs/libxkbcommon-0.2.0[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXcursor-1.1.14[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-6.0.0[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ xscreensaver? ( >=x11-libs/libXScrnSaver-1.2.2-r1[${MULTILIB_USEDEP}] )
+ )"
+RDEPEND="${CDEPEND}
+ vulkan? ( media-libs/vulkan-loader )"
+DEPEND="${CDEPEND}
+ ibus? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )
+ vulkan? ( dev-util/vulkan-headers )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ wayland? ( >=dev-util/wayland-scanner-1.20 )
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/SDL2/SDL_config.h
+ /usr/include/SDL2/SDL_platform.h
+ /usr/include/SDL2/begin_code.h
+ /usr/include/SDL2/close_code.h
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.16-static-libs.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Unbundle some headers.
+ rm -r src/video/khronos || die
+ ln -s "${ESYSROOT}/usr/include" src/video/khronos || die
+
+ # SDL seems to customize SDL_config.h.in to remove macros like
+ # PACKAGE_NAME. Add AT_NOEAUTOHEADER="yes" to prevent those macros from
+ # being reintroduced.
+ # https://bugs.gentoo.org/764959
+ AT_NOEAUTOHEADER="yes" AT_M4DIR="/usr/share/aclocal acinclude" \
+ eautoreconf
+}
+
+multilib_src_configure() {
+ use custom-cflags || strip-flags
+
+ if use ibus; then
+ local -x IBUS_CFLAGS="-I${ESYSROOT}/usr/include/ibus-1.0 -I${ESYSROOT}/usr/include/glib-2.0 -I${ESYSROOT}/usr/$(get_libdir)/glib-2.0/include"
+ fi
+
+ # sorted by `./configure --help`
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --enable-atomic
+ $(use_enable sound audio)
+ $(use_enable video)
+ --enable-render
+ --enable-events
+ $(use_enable joystick)
+ $(use_enable haptic)
+ --enable-power
+ --enable-filesystem
+ $(use_enable threads pthreads)
+ --enable-timers
+ --enable-file
+ --enable-loadso
+ --enable-cpuinfo
+ --enable-assembly
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable cpu_flags_x86_sse ssemath)
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable cpu_flags_x86_3dnow 3dnow)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable oss)
+ $(use_enable alsa)
+ --disable-alsa-shared
+ $(use_enable jack)
+ --disable-jack-shared
+ --disable-esd
+ $(use_enable pipewire)
+ --disable-pipewire-shared
+ $(use_enable pulseaudio)
+ --disable-pulseaudio-shared
+ --disable-arts
+ $(use_enable libsamplerate)
+ $(use_enable nas)
+ --disable-nas-shared
+ $(use_enable sndio)
+ --disable-sndio-shared
+ $(use_enable sound diskaudio)
+ $(use_enable sound dummyaudio)
+ $(use_enable wayland video-wayland)
+ --disable-wayland-shared
+ $(use_enable video_cards_vc4 video-rpi)
+ $(use_enable X video-x11)
+ --disable-x11-shared
+ $(use_enable X video-x11-xcursor)
+ $(use_enable X video-x11-xdbe)
+ $(use_enable X video-x11-xfixes)
+ $(use_enable X video-x11-xinput)
+ $(use_enable X video-x11-xrandr)
+ $(use_enable xscreensaver video-x11-scrnsaver)
+ $(use_enable X video-x11-xshape)
+ $(use_enable aqua video-cocoa)
+ --disable-video-directfb
+ --disable-fusionsound
+ --disable-fusionsound-shared
+ $(use_enable kms video-kmsdrm)
+ --disable-kmsdrm-shared
+ $(use_enable video video-dummy)
+ $(use_enable opengl video-opengl)
+ $(use_enable gles1 video-opengles1)
+ $(use_enable gles2 video-opengles2)
+ $(use_enable vulkan video-vulkan)
+ $(use_enable udev libudev)
+ $(use_enable dbus)
+ $(use_enable fcitx4 fcitx)
+ $(use_enable ibus)
+ --disable-directx
+ --disable-rpath
+ --disable-render-d3d
+ $(use_with X x)
+ )
+
+ ECONF_SOURCE="${S}" \
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake V=1
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+
+ if use doc; then
+ cd docs || die
+ doxygen || die
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ # Do not delete the static .a libraries here as some are
+ # mandatory. They may be needed even when linking dynamically.
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ dodoc {BUGS,CREDITS,README-SDL,TODO,WhatsNew}.txt README.md docs/README*.md
+ use doc && dodoc -r docs/output/html/
+}