summaryrefslogtreecommitdiff
path: root/media-libs/libsdl/libsdl-1.2.60.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-09 06:17:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-09 06:17:43 +0000
commit92ed25ce2ff461f502de1dd96ab0accd683b69d2 (patch)
treeb89b3542822fa853056fb298b934eb336fc067d5 /media-libs/libsdl/libsdl-1.2.60.ebuild
parent4fc232f0223106ced390fbe949c095cb39143f23 (diff)
gentoo auto-resync : 09:01:2023 - 06:17:43
Diffstat (limited to 'media-libs/libsdl/libsdl-1.2.60.ebuild')
-rw-r--r--media-libs/libsdl/libsdl-1.2.60.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/libsdl/libsdl-1.2.60.ebuild b/media-libs/libsdl/libsdl-1.2.60.ebuild
new file mode 100644
index 000000000000..7121bb32b6aa
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.60.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Simple Direct Media Layer 1.2 compatibility wrapper around SDL2"
+HOMEPAGE="https://github.com/libsdl-org/sdl12-compat"
+SRC_URI="https://github.com/libsdl-org/sdl12-compat/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+# IUSE dropped from real SDL1: aalib custom-cflags dga fbcon libcaca nas oss pulseaudio static-libs tslib xinerama xv
+IUSE="alsa +joystick opengl +sound test +video X"
+REQUIRED_USE="test? ( joystick opengl sound video )"
+# The tests are more like example programs.
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/libsdl2[${MULTILIB_USEDEP},alsa=,joystick=,opengl=,sound=,video=,X=]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( virtual/opengl[${MULTILIB_USEDEP}] )
+"
+
+S="${WORKDIR}/sdl12-compat-release-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSDL12TESTS=$(usex test)
+ )
+
+ cmake-multilib_src_configure
+}