summaryrefslogtreecommitdiff
path: root/media-libs/libsbsms/libsbsms-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /media-libs/libsbsms/libsbsms-2.3.0.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'media-libs/libsbsms/libsbsms-2.3.0.ebuild')
-rw-r--r--media-libs/libsbsms/libsbsms-2.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libsbsms/libsbsms-2.3.0.ebuild b/media-libs/libsbsms/libsbsms-2.3.0.ebuild
new file mode 100644
index 000000000000..0519a044dd73
--- /dev/null
+++ b/media-libs/libsbsms/libsbsms-2.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+AUTOTOOLS_AUTORECONF=true
+inherit autotools
+
+DESCRIPTION="A library for high quality time and pitch scale modification"
+HOMEPAGE="https://github.com/claytonotey/libsbsms http://sbsms.sourceforge.net/"
+SRC_URI="https://github.com/claytonotey/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="cpu_flags_x86_sse static-libs"
+
+PATCHES=( "${FILESDIR}/${PN}-2.0.2-cflags.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ --disable-multithreaded
+ # threaded version causes segfaults
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}