summaryrefslogtreecommitdiff
path: root/media-libs/libsamplerate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /media-libs/libsamplerate
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'media-libs/libsamplerate')
-rw-r--r--media-libs/libsamplerate/Manifest4
-rw-r--r--media-libs/libsamplerate/libsamplerate-0.2.2.ebuild49
-rw-r--r--media-libs/libsamplerate/libsamplerate-9999.ebuild5
3 files changed, 54 insertions, 4 deletions
diff --git a/media-libs/libsamplerate/Manifest b/media-libs/libsamplerate/Manifest
index 7410cc62c694..8d60f9250d39 100644
--- a/media-libs/libsamplerate/Manifest
+++ b/media-libs/libsamplerate/Manifest
@@ -1,4 +1,6 @@
DIST libsamplerate-0.2.1.tar.bz2 3747188 BLAKE2B 83540f3e75cfa79cbd166f075d22cab6a63e0e057b90ac6a3760c07196cac962df7d1ca26620a9033de046e0528bee3ded2b482e8629b1ae316844b5b31f3074 SHA512 f54f7f12c9536868d7a11fc9cbb86857505e7b75fe34cedaf0b9bfc864da6037296b3eae303a33d4c87b7fd20d96933b91ef59c8cc3d1313b9fc21654e5daa2d
+DIST libsamplerate-0.2.2.tar.xz 3319468 BLAKE2B 71b1e8a1644a94fff019abc6bf98c557df84994293f1e9bc651ad3ad3f0afeb24f54b8c75fc26e5202ae7c3a3e34e783fd1be7f7c6fdefe9eac9a5dfe7100b91 SHA512 d23ae54d23209ba22baae9e5fd178dd8e0e99205dada7e7c3a7b3a3d8cf816ed427a411bfeb008427f64da7767d645edce40811f238af11c8c386f5ef25a9f0c
EBUILD libsamplerate-0.2.1.ebuild 1283 BLAKE2B 9a2ab16ba202ce58d532b595f8e751f3f17374d7985de6d4dce8a34daaf899c369a30223932f7b34c21f69d5c6373cbe98d492d52b36852b69a29eddc9902120 SHA512 92d9463d1b2f58021e2c9478ccbaca5f611190676aead11430211412fbaa31224ededcf47147545e1298f7588e30b594f53a9e240de0ac18283d1ba6382533ba
-EBUILD libsamplerate-9999.ebuild 1290 BLAKE2B 8444874ab6922d1076ea1774511d290544a0b3a3968437e615cada7fa7df07b07af0c61575e571811fadb4e2d1aa97e6831a7f28f02829e5f15f6f5c22cd9d0f SHA512 fab015255dc964b6387d09b4e7d7add29232ddb86517c7d6105176e91789c7c52416a4bbd8277c163c3197864c57b472e17a0fd4ec99d8d5fc6eccfabff9d691
+EBUILD libsamplerate-0.2.2.ebuild 1268 BLAKE2B 87baa5925767b94b377850cb1285d2097073880f46e8954f6c4936acf70e5a7da5285ba6df9a2cc6e6d19617f7db012990d9fda418377d821c4bed53d11b4d78 SHA512 11cf28cd637b9731502f15def1ee77ae7e1f3dc454ef9c7f3fd36c2b8e7f12638e52603605e1064ae36e08ec2f96848369a48cc0b1d552374974a4052462bd62
+EBUILD libsamplerate-9999.ebuild 1268 BLAKE2B 87baa5925767b94b377850cb1285d2097073880f46e8954f6c4936acf70e5a7da5285ba6df9a2cc6e6d19617f7db012990d9fda418377d821c4bed53d11b4d78 SHA512 11cf28cd637b9731502f15def1ee77ae7e1f3dc454ef9c7f3fd36c2b8e7f12638e52603605e1064ae36e08ec2f96848369a48cc0b1d552374974a4052462bd62
MISC metadata.xml 249 BLAKE2B f7f8f071ecba933f3d39b0b60983281d59299b92de9375a60ab4109d7202800cb790bce0c426227f04b3e2624b1adb20876145741355abc6a4938b8b9698d144 SHA512 9a100fb26586365eda99724330a03a512f4d0be18d39c3a195ba02c2fc841edeee99d22512acf5a058a3b978d3a74f4d963a5aff9aa343b6cb4086cdfefe6343
diff --git a/media-libs/libsamplerate/libsamplerate-0.2.2.ebuild b/media-libs/libsamplerate/libsamplerate-0.2.2.ebuild
new file mode 100644
index 000000000000..698fa623a51a
--- /dev/null
+++ b/media-libs/libsamplerate/libsamplerate-0.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for audio"
+HOMEPAGE="https://libsndfile.github.io/libsamplerate/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/libsndfile/libsamplerate.git"
+else
+ SRC_URI="https://github.com/libsndfile/libsamplerate/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Alsa/FFTW are only required for tests
+# libsndfile is only used by examples and tests
+DEPEND="
+ test? (
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/libsndfile[${MULTILIB_USEDEP}]
+ sci-libs/fftw:3.0[${MULTILIB_USEDEP}]
+ )"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable test alsa) \
+ $(use_enable test fftw) \
+ $(use_enable test sndfile)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -type f -delete || die
+}
diff --git a/media-libs/libsamplerate/libsamplerate-9999.ebuild b/media-libs/libsamplerate/libsamplerate-9999.ebuild
index f754eb4667e5..698fa623a51a 100644
--- a/media-libs/libsamplerate/libsamplerate-9999.ebuild
+++ b/media-libs/libsamplerate/libsamplerate-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multilib-minimal
@@ -12,7 +12,7 @@ if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/libsndfile/libsamplerate.git"
else
- SRC_URI="https://github.com/libsndfile/libsamplerate/releases/download/${PV}/${P}.tar.bz2"
+ SRC_URI="https://github.com/libsndfile/libsamplerate/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
fi
@@ -38,7 +38,6 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
- --disable-static \
$(use_enable test alsa) \
$(use_enable test fftw) \
$(use_enable test sndfile)