summaryrefslogtreecommitdiff
path: root/media-libs/libpgf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-15 06:52:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-15 06:52:13 +0000
commit9f7759b3b1be5a3bc7794010a8ebf9334f017d2f (patch)
treefa4e093c6694ec0590cbbd9a7b86c1edddc43d72 /media-libs/libpgf
parentac35def7deb4a1eecfad26f0eb5907170b2ee5d7 (diff)
gentoo auto-resync : 15:11:2022 - 06:52:13
Diffstat (limited to 'media-libs/libpgf')
-rw-r--r--media-libs/libpgf/Manifest1
-rw-r--r--media-libs/libpgf/libpgf-7.21.7-r1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/libpgf/Manifest b/media-libs/libpgf/Manifest
index f95756e39fea..9eb3018de3b5 100644
--- a/media-libs/libpgf/Manifest
+++ b/media-libs/libpgf/Manifest
@@ -1,3 +1,4 @@
DIST libpgf-7.21.7.zip 2075722 BLAKE2B 31c5ab5930ef5658ca9b320fa3df94b7d8566467a657df6d255781664a4750d6b5cb7b351c828cad7c60b42f8cb8926c51bb0271d5c51e2484426a15f18b5eb2 SHA512 dbc17d9dce1afbeffb272df0d573059914d2ac79d652d1d43e67c49509fd6e643be8594bbd1a3058a5aa3a9d30db100c6dcf641051345049cf8f9375d49e2799
+EBUILD libpgf-7.21.7-r1.ebuild 1186 BLAKE2B 9ccfe5e63242a57f3794cdbec4c8d74be6b68e418bf4e02326baf96c10b3bf8b411a2bce369e62c45f4955d222f8585797dac491dc52146d688a104a8a35bb22 SHA512 13cddc9df7af5b9edc7a8f2d42b17d442d44d891718eb277553ac283053fab61c09299daa4e074773704a3e5649da0ada0a6727adbb3856f0dbc285ac2dcb777
EBUILD libpgf-7.21.7.ebuild 968 BLAKE2B 4da545e6f56dfe15d1a7f0bd837076bc92b5d9614d040b88c3426ac63fe0c97c94019c8a609b8a2f703b834481207e101fd9422daafdc5df821c7af690c761c1 SHA512 64ecf531a41fd11b89534f294bef4b212e944f3b30c8a2e199fdc48cca452438e42c34e40b33b13a08221e8c6b867f39a618e48d656d802349c5c1c0f8500ca8
MISC metadata.xml 249 BLAKE2B 3bc7510e014ef8df90da064f4ef969eab6cc3311951a6dd556ca7b6f4e2e74e229f12a16ceb641393d1ec1f89d1942718267ecc664a8136df194c40de94a58e4 SHA512 63f88d798d410e4fb6670d199a86a665ab61b09cb9508b4047f13fe73070c682231d35a27c9d2c1fd82a1b8a84676d857b534c96bd09f4562cf13d7fc8de36b2
diff --git a/media-libs/libpgf/libpgf-7.21.7-r1.ebuild b/media-libs/libpgf/libpgf-7.21.7-r1.ebuild
new file mode 100644
index 000000000000..a1f9328144bb
--- /dev/null
+++ b/media-libs/libpgf/libpgf-7.21.7-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edos2unix
+
+DESCRIPTION="Library to load, handle and manipulate images in the PGF format"
+HOMEPAGE="https://www.libpgf.org/"
+SRC_URI="https://downloads.sourceforge.net/project/libpgf/libpgf/${PV}/libpgf.zip -> ${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+BDEPEND="
+ app-arch/unzip
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-fontutils
+ )
+"
+
+S="${WORKDIR}/libpgf"
+
+src_prepare() {
+ default
+
+ # configure.ac has wrong version number
+ sed -i "s/7.15.32/${PV}/g" configure.ac || die
+
+ # many files, including configure.ac and Makefile.am, are saved in dos format, causing errors in autotools
+ edos2unix *.{am,ac,in,sh} */*.{am,in}
+
+ # the package does not respect --docdir and installs docs in /usr/share/doc/${PN}
+ sed -i -e 's/\$(DOC_DIR)/$(DESTDIR)@docdir@/' doc/Makefile.am || die
+
+ if ! use doc; then
+ sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ docinto pdf
+ dodoc doc/*.pdf doc/latex/*.pdf
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}