summaryrefslogtreecommitdiff
path: root/media-libs/libopenshot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /media-libs/libopenshot
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'media-libs/libopenshot')
-rw-r--r--media-libs/libopenshot/Manifest4
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild101
-rw-r--r--media-libs/libopenshot/metadata.xml6
3 files changed, 108 insertions, 3 deletions
diff --git a/media-libs/libopenshot/Manifest b/media-libs/libopenshot/Manifest
index fc330a608331..679a288a9c4d 100644
--- a/media-libs/libopenshot/Manifest
+++ b/media-libs/libopenshot/Manifest
@@ -1,4 +1,6 @@
AUX libopenshot-0.2.2-imagemagick7.patch 3545 BLAKE2B e2fe6ae205459c69ff288f14ba2d0a2b461b761e7ff6e9e66e11e4895b10661d5fc2ab9e2011899ca983399af685a0d411aa4820c02d02b4600617bd314d7670 SHA512 06622c81253fd15440e1cf0256a0beb21e2039a5a98a8c889828898b137a9a6efeb6fb295a0646dc5aa12da9805ff73b62c29272b0037cb1ea2454de7571f59b
DIST libopenshot-0.2.2.tar.gz 11037768 BLAKE2B c307e41bf17d40ae421a541bbdf4cd53c6ef4d97041a476c6910bd156c10815aa5a5811813b24fdc472401516f29cf8cb68fbda17a0b434767c3f3aa63d6f222 SHA512 b89189e57e82da68a063417bba9c94704c04b0546c0aed227daa23a794eee56341a05988d8e28dbd339edfcdeeaed48103b347060eccf94f32fe1a4bf23d6553
+DIST libopenshot-0.2.4_pre20190609.tar.gz 10268173 BLAKE2B 01e07c0a7c051b5804f24fab1bfb920862a165ef14d3fdd020430b9e3a47858842c8cab3408ba0d161cb15cc6e90531a3b5df9ad327a01f414ff2e7e392fc243 SHA512 bf8c06aba6a899cb1ca6fbe9ac89fc859083b03175338c04af8dce68698f4ac78eac0b5b594e2b02390cd5e64576445b1c95324b254a267506353bed97ca16d1
EBUILD libopenshot-0.2.2.ebuild 2207 BLAKE2B 31c03e9f5cb7e596930bf01efc6c1897b586a355dd1bd516e37872b0b2a37259ed83a4a1b1155e65b620554d1842ea7c71cc1ba223a542dc622c54d2c4ade00b SHA512 fa3c05436c0bbd2949ac11d8e35e763a96693dbb48d352264f5abd71d24ddaadf099b9035b2236471e07418b8533d3ff3bcbea7034660875e0f740b9bb141c69
-MISC metadata.xml 374 BLAKE2B cc763fd4cda8c70fc654d85ebaa8a3b748499308a4633c6f70aeef1cbb767f5b5eaad0f6c4402a74862e8ebe392b6862722835e92cb53ef4b88a9cc87b2315db SHA512 2a1810910f38b67624eea2d8778c095bbe884cf8a06ababaf595a295d8fbb904e13a809ccc888b8d5956e87a2ddf1295982133741596a08e713f9cbb6a6347ba
+EBUILD libopenshot-0.2.4_pre20190609.ebuild 2530 BLAKE2B 3d7eebaa32640c90891e39202e594deb0b74268a8973d19962a134de011733c9f87c8e01293234d9721fec2f7e701e1b630d6513013bbe72c39a0bb008de9405 SHA512 d6875cbdeb5c0b90ed600bfba050396e168cceda296907871dee3c3c4a4b110dfe07c65a94e005e995a76243a3814fbaa28e49ebd73e3ee670e10a85f0cbd4e8
+MISC metadata.xml 400 BLAKE2B ec8a8b1e8bf03816ba138aa342d428ae322b5e7fe01dbf9d62cbebb42f59656f3d021156a7cf59aeaa75552fab8d1ff028e0b8283d342a1d64be837424104fd2 SHA512 0c5544878c2f7e1572b7e9716f996ede737cb2bb907f912a6b1d371beeee4b8694469eb03dc89197c19fe245a1d3eba193cd850fc52fb663f192d3522aa810d0
diff --git a/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild b/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild
new file mode 100644
index 000000000000..89b540bf332b
--- /dev/null
+++ b/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit cmake-utils python-single-r1 toolchain-funcs
+
+COMMIT="0d4ea7fe71e88bcee4a7fd1404bd52c8e2169997"
+
+DESCRIPTION="Video editing library used by OpenShot"
+HOMEPAGE="https://www.openshot.org/"
+SRC_URI="https://github.com/OpenShot/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0/17"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +imagemagick libav +python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ net-libs/cppzmq
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[widgets]
+ >=media-libs/libopenshot-audio-0.1.9_pre20190502:0=
+ imagemagick? ( >=media-gfx/imagemagick-7:0=[cxx] )
+ libav? ( media-video/libav:0=[encode,x264,xvid,vpx,mp3,theora] )
+ !libav? ( media-video/ffmpeg:0=[encode,x264,xvid,vpx,mp3,theora] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig )
+ test? ( dev-libs/unittest++ )
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+# From Mageia
+# https://github.com/OpenShot/libopenshot/issues/60
+PATCHES=( ${FILESDIR}/${PN}-0.2.2-imagemagick7.patch )
+
+check_compiler() {
+ if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
+ eerror "${P} requires a compiler with OpenMP support. Your current"
+ eerror "compiler does not support it. If you use gcc, you can"
+ eerror "re-emerge it with the 'openmp' use flag enabled."
+ die "The current compiler does not support OpenMP"
+ fi
+}
+
+pkg_pretend() {
+ check_compiler
+}
+
+pkg_setup() {
+ check_compiler
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # https://github.com/OpenShot/libopenshot/issues/17
+ use test || cmake_comment_add_subdirectory tests
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_RUBY=OFF # TODO: add ruby support
+ -DENABLE_PYTHON=$(usex python)
+ $(cmake-utils_use_find_package imagemagick ImageMagick)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_make doc
+}
+
+src_test() {
+ cmake-utils_src_make os_test
+}
+
+src_install() {
+ local DOCS=( AUTHORS README.md doc/HW-ACCEL.md )
+ use examples && DOCS+=( src/examples/ )
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+
+ cmake-utils_src_install
+ use python && python_optimize
+}
diff --git a/media-libs/libopenshot/metadata.xml b/media-libs/libopenshot/metadata.xml
index 2f5ef7858c7c..e12300d5d59d 100644
--- a/media-libs/libopenshot/metadata.xml
+++ b/media-libs/libopenshot/metadata.xml
@@ -1,9 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>steils@gentoo.org</email>
+ <name>Stefan Strogin</name>
+ </maintainer>
<upstream>
- <remote-id type="launchpad">libopenshot</remote-id>
<remote-id type="github">OpenShot/libopenshot</remote-id>
<bugs-to>https://github.com/OpenShot/libopenshot/issues</bugs-to>
</upstream>